From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1756245AbcHBLjj (ORCPT ); Tue, 2 Aug 2016 07:39:39 -0400 Received: from mail-lf0-f51.google.com ([209.85.215.51]:35717 "EHLO mail-lf0-f51.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1755648AbcHBLis (ORCPT ); Tue, 2 Aug 2016 07:38:48 -0400 Subject: Re: [PATCH 0063/1285] Replace numeric parameter like 0444 with macro To: Baole Ni , b.zolnierkie@samsung.com, tj@kernel.org, lenb@kernel.org, x86@kernel.org, hpa@zytor.com References: <20160802103759.17958-1-baolex.ni@intel.com> Cc: linux-ide@vger.kernel.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, travis@sgi.com From: Sergei Shtylyov Message-ID: <5391e340-1285-574d-1979-a19571341eb5@cogentembedded.com> Date: Tue, 2 Aug 2016 14:30:48 +0300 User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Thunderbird/45.2.0 MIME-Version: 1.0 In-Reply-To: <20160802103759.17958-1-baolex.ni@intel.com> Content-Type: text/plain; charset=utf-8; format=flowed Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hello. On 8/2/2016 1:37 PM, Baole Ni wrote: > I find that the developers often just specified the numeric value > when calling a macro which is defined with a parameter for access permission. > As we know, these numeric value for access permission have had the corresponding macro, > and that using macro can improve the robustness and readability of the code, > thus, I suggest replacing the numeric parameter with the macro. > > Signed-off-by: Chuansheng Liu > Signed-off-by: Baole Ni > --- > drivers/ata/pata_legacy.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/ata/pata_legacy.c b/drivers/ata/pata_legacy.c > index bce2a8c..1dc0beb 100644 > --- a/drivers/ata/pata_legacy.c > +++ b/drivers/ata/pata_legacy.c > @@ -76,7 +76,7 @@ > #define NR_HOST 6 > > static int all; > -module_param(all, int, 0444); > +module_param(all, int, S_IRUSR | S_IRGRP | S_IROTH); There's S_IRUGO for this case, no? MBR, Sergei