From: Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>
To: "Antoine Ténart" <antoine.tenart@free-electrons.com>,
balbi@ti.com, gregkh@linuxfoundation.org,
Peter.Chen@freescale.com, kishon@ti.com,
stern@rowland.harvard.edu
Cc: yoshihiro.shimoda.uh@renesas.com,
alexandre.belloni@free-electrons.com,
thomas.petazzoni@free-electrons.com, zmxu@marvell.com,
jszhang@marvell.com, linux-usb@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3 6/9] usb: allow to supply the PHY in the drivers when using HCD
Date: Fri, 22 Aug 2014 20:53:53 +0400 [thread overview]
Message-ID: <53F775A1.4070200@cogentembedded.com> (raw)
In-Reply-To: <1408722621-3635-7-git-send-email-antoine.tenart@free-electrons.com>
Hello.
On 08/22/2014 07:50 PM, Antoine Ténart wrote:
> This patch modify the generic code handling PHYs to allow them to be
> supplied from the drivers. This adds checks to ensure no PHY was already
> there when looking for one in the generic code. This also makes sure we
> do not modify its state in the generic HCD functions, it was provided by
> the driver.
> Signed-off-by: Antoine Ténart <antoine.tenart@free-electrons.com>
> Acked-by: Alan Stern <stern@rowland.harvard.edu>
> ---
> drivers/usb/core/hcd.c | 7 ++++---
> 1 file changed, 4 insertions(+), 3 deletions(-)
> diff --git a/drivers/usb/core/hcd.c b/drivers/usb/core/hcd.c
> index 6619239baf6d..dc0e46e5e618 100644
> --- a/drivers/usb/core/hcd.c
> +++ b/drivers/usb/core/hcd.c
> @@ -2646,7 +2646,7 @@ int usb_add_hcd(struct usb_hcd *hcd,
> }
> }
>
> - if (IS_ENABLED(CONFIG_GENERIC_PHY)) {
> + if (IS_ENABLED(CONFIG_GENERIC_PHY) && !hcd->phy) {
> struct phy *phy = phy_get(hcd->self.controller, "usb");
>
> if (IS_ERR(phy)) {
> @@ -2666,6 +2666,7 @@ int usb_add_hcd(struct usb_hcd *hcd,
> goto err_phy;
> }
> hcd->phy = phy;
> + hcd->remove_phy = 1;
> }
> }
>
> @@ -2812,7 +2813,7 @@ err_allocate_root_hub:
> err_register_bus:
> hcd_buffer_destroy(hcd);
> err_create_buf:
> - if (IS_ENABLED(CONFIG_GENERIC_PHY) && hcd->phy) {
> + if (IS_ENABLED(CONFIG_GENERIC_PHY) && hcd->remove_phy && hcd->phy) {
The 'hcd->phy' check seems redundant now.
> phy_power_off(hcd->phy);
> phy_exit(hcd->phy);
> phy_put(hcd->phy);
> @@ -2896,7 +2897,7 @@ void usb_remove_hcd(struct usb_hcd *hcd)
> usb_deregister_bus(&hcd->self);
> hcd_buffer_destroy(hcd);
>
> - if (IS_ENABLED(CONFIG_GENERIC_PHY) && hcd->phy) {
> + if (IS_ENABLED(CONFIG_GENERIC_PHY) && hcd->remove_phy && hcd->phy) {
Here as well.
[...]
WBR, Sergei
next prev parent reply other threads:[~2014-08-22 16:54 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-08-22 15:50 [PATCH v3 0/9] usb: add support for the generic PHY framework Antoine Ténart
2014-08-22 15:50 ` [PATCH v3 1/9] usb: move the OTG state from the USB PHY to the OTG structure Antoine Ténart
2014-08-22 15:50 ` [PATCH v3 2/9] usb: rename phy to usb_phy in OTG Antoine Ténart
2014-08-22 15:50 ` [PATCH v3 3/9] usb: add support to the generic PHY framework " Antoine Ténart
2014-08-22 15:50 ` [PATCH v3 4/9] usb: rename phy to usb_phy in HCD Antoine Ténart
2014-08-22 15:50 ` [PATCH v3 5/9] usb: rename gen_phy to phy " Antoine Ténart
2014-08-22 15:50 ` [PATCH v3 6/9] usb: allow to supply the PHY in the drivers when using HCD Antoine Ténart
2014-08-22 16:53 ` Sergei Shtylyov [this message]
2014-08-22 17:08 ` Sergei Shtylyov
2014-08-22 15:50 ` [PATCH v3 7/9] usb: rename transceiver and phy to usb_phy in ChipIdea Antoine Ténart
2014-08-26 10:08 ` Peter Chen
2014-08-22 15:50 ` [PATCH v3 8/9] usb: chipidea: move usb_otg into struct ci_hdrc Antoine Ténart
2014-08-26 10:22 ` Peter Chen
2014-08-29 14:25 ` Antoine Tenart
2014-09-01 1:13 ` Peter Chen
2014-09-02 9:08 ` Antoine Tenart
2014-09-02 10:18 ` Peter Chen
2014-08-22 15:50 ` [PATCH v3 9/9] usb: chipidea: add support to the generic PHY framework in ChipIdea Antoine Ténart
2014-08-26 10:42 ` Peter Chen
2014-08-29 14:22 ` Antoine Ténart
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=53F775A1.4070200@cogentembedded.com \
--to=sergei.shtylyov@cogentembedded.com \
--cc=Peter.Chen@freescale.com \
--cc=alexandre.belloni@free-electrons.com \
--cc=antoine.tenart@free-electrons.com \
--cc=balbi@ti.com \
--cc=gregkh@linuxfoundation.org \
--cc=jszhang@marvell.com \
--cc=kishon@ti.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=stern@rowland.harvard.edu \
--cc=thomas.petazzoni@free-electrons.com \
--cc=yoshihiro.shimoda.uh@renesas.com \
--cc=zmxu@marvell.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome