From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from smtp.kernel.org (aws-us-west-2-korg-mail-1.web.codeaurora.org [10.30.226.201]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 08F9739D6F6; Tue, 3 Mar 2026 10:42:35 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=10.30.226.201 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1772534556; cv=none; b=R5+0l5aUzkDN2Nb9pNax2DPLY8hDEZl0XE/ASEFp+M35eBTw4n0XAGydxbgj9x9bQbiikqDTJyV6O89+OxaIAEr2JSBHr+RvvxvsshGxh1X5f26IEcppcbfTA41SgrvqEnYXy6UzHO/avR38FQSIH00B6Uiq5/5Dd8B69Gzq78c= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1772534556; c=relaxed/simple; bh=LXTeLcko8TN4s1+AW7QCG0gHA8xgKDg8hODvm4T/7lc=; h=Message-ID:Date:MIME-Version:Subject:To:Cc:References:From: In-Reply-To:Content-Type; b=u6ItDMCOe/7fUXyp8fKLSyltq3/Jof8CkmSg8QprqMPMkUe6ucYZRBKG2i6FdPTxgJ7yhtZZTYrHKsEA4FcWm44IykjLfLvNJo5CW21ji2vj9LY5rzxiZ6uUAbBz868m/OHtON2lOhJ0lgL9PzY0ZZ9VEi2RoZAxBuG1DHUW3R0= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b=pc4pLu6o; arc=none smtp.client-ip=10.30.226.201 Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b="pc4pLu6o" Received: by smtp.kernel.org (Postfix) with ESMTPSA id 347AEC2BCAF; Tue, 3 Mar 2026 10:42:33 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=kernel.org; s=k20201202; t=1772534555; bh=LXTeLcko8TN4s1+AW7QCG0gHA8xgKDg8hODvm4T/7lc=; h=Date:Subject:To:Cc:References:From:In-Reply-To:From; b=pc4pLu6ohC9WXq6G0jj+NEJ5RkGQ37fiA5oNskpR6+zMukelRCHtriLRP4m7CqHAw nPA2LlF3ddDrXi2EUp2GJ0padvrjbfd0UgIOdtSOReXm0uRZdgPT0InGWehijm2w/y ndQDznoNs8TxIEw1DZhmy2CIPUuafpZ7uSQyLa9iPlJkL2+ESL6Q3lf6nlb+ZH4prL VOKd1DKQ9RB0+R4IsTXYoiUOGwebLqLeSRAF3b5u+sTLjOPxrkQd4qWbV9zg4b6JKd Bhfbxnc/CtloC/kupqmYWciYZEwAEqTyJGFzFWFS8uU+tn9+gYvJhSR8lJS0W1Dcjw biTyQuTKeFhpg== Message-ID: <541a6661-7bfe-4517-a32c-5839002c61e5@kernel.org> Date: Tue, 3 Mar 2026 11:42:31 +0100 Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 User-Agent: Mozilla Thunderbird Subject: Re: [PATCH 5/5] mm: memcg: separate slab stat accounting from objcg charge cache Content-Language: en-US To: Hao Li , Johannes Weiner Cc: Andrew Morton , Michal Hocko , Roman Gushchin , Shakeel Butt , Vlastimil Babka , Harry Yoo , linux-mm@kvack.org, cgroups@vger.kernel.org, linux-kernel@vger.kernel.org References: <20260302195305.620713-1-hannes@cmpxchg.org> <20260302195305.620713-6-hannes@cmpxchg.org> From: "Vlastimil Babka (SUSE)" In-Reply-To: Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 7bit On 3/3/26 09:54, Hao Li wrote: > On Mon, Mar 02, 2026 at 02:50:18PM -0500, Johannes Weiner wrote: >> Cgroup slab metrics are cached per-cpu the same way as the sub-page >> charge cache. However, the intertwined code to manage those dependent >> caches right now is quite difficult to follow. >> >> Specifically, cached slab stat updates occur in consume() if there was >> enough charge cache to satisfy the new object. If that fails, whole >> pages are reserved, and slab stats are updated when the remainder of >> those pages, after subtracting the size of the new slab object, are >> put into the charge cache. This already juggles a delicate mix of the >> object size, the page charge size, and the remainder to put into the >> byte cache. Doing slab accounting in this path as well is fragile, and >> has recently caused a bug where the input parameters between the two >> caches were mixed up. >> >> Refactor the consume() and refill() paths into unlocked and locked >> variants that only do charge caching. Then let the slab path manage >> its own lock section and open-code charging and accounting. >> >> This makes the slab stat cache subordinate to the charge cache: >> __refill_obj_stock() is called first to prepare it; >> __account_obj_stock() follows to hitch a ride. >> >> This results in a minor behavioral change: previously, a mismatching >> percpu stock would always be drained for the purpose of setting up >> slab account caching, even if there was no byte remainder to put into >> the charge cache. Now, the stock is left alone, and slab accounting >> takes the uncached path if there is a mismatch. This is exceedingly >> rare, and it was probably never worth draining the whole stock just to >> cache the slab stat update. >> >> Signed-off-by: Johannes Weiner >> --- >> mm/memcontrol.c | 100 +++++++++++++++++++++++++++++------------------- >> 1 file changed, 61 insertions(+), 39 deletions(-) >> >> diff --git a/mm/memcontrol.c b/mm/memcontrol.c >> index 4f12b75743d4..9c6f9849b717 100644 >> --- a/mm/memcontrol.c >> +++ b/mm/memcontrol.c >> @@ -3218,16 +3218,18 @@ static struct obj_stock_pcp *trylock_stock(void) >> > > [...] > >> @@ -3376,17 +3383,14 @@ static bool obj_stock_flush_required(struct obj_stock_pcp *stock, >> return flush; >> } >> >> -static void refill_obj_stock(struct obj_cgroup *objcg, unsigned int nr_bytes, >> - bool allow_uncharge, int nr_acct, struct pglist_data *pgdat, >> - enum node_stat_item idx) >> +static void __refill_obj_stock(struct obj_cgroup *objcg, >> + struct obj_stock_pcp *stock, >> + unsigned int nr_bytes, >> + bool allow_uncharge) >> { >> - struct obj_stock_pcp *stock; >> unsigned int nr_pages = 0; >> >> - stock = trylock_stock(); >> if (!stock) { >> - if (pgdat) >> - __account_obj_stock(objcg, NULL, nr_acct, pgdat, idx); >> nr_pages = nr_bytes >> PAGE_SHIFT; >> nr_bytes = nr_bytes & (PAGE_SIZE - 1); >> atomic_add(nr_bytes, &objcg->nr_charged_bytes); >> @@ -3404,20 +3408,25 @@ static void refill_obj_stock(struct obj_cgroup *objcg, unsigned int nr_bytes, >> } >> stock->nr_bytes += nr_bytes; >> >> - if (pgdat) >> - __account_obj_stock(objcg, stock, nr_acct, pgdat, idx); >> - >> if (allow_uncharge && (stock->nr_bytes > PAGE_SIZE)) { >> nr_pages = stock->nr_bytes >> PAGE_SHIFT; >> stock->nr_bytes &= (PAGE_SIZE - 1); >> } >> >> - unlock_stock(stock); >> out: >> if (nr_pages) >> obj_cgroup_uncharge_pages(objcg, nr_pages); >> } >> >> +static void refill_obj_stock(struct obj_cgroup *objcg, >> + unsigned int nr_bytes, >> + bool allow_uncharge) >> +{ >> + struct obj_stock_pcp *stock = trylock_stock(); >> + __refill_obj_stock(objcg, stock, nr_bytes, allow_uncharge); >> + unlock_stock(stock); > > Hi Johannes, > > I noticed that after this patch, obj_cgroup_uncharge_pages() is now inside > the obj_stock.lock critical section. Since obj_cgroup_uncharge_pages() calls > refill_stock(), which seems non-trivial, this might increase the lock hold time. > In particular, could that lead to more failed trylocks for IRQ handlers on > non-RT kernel (or for tasks that preempt others on RT kernel)? Yes, it also seems a bit self-defeating? (at least in theory) refill_obj_stock() trylock_stock() __refill_obj_stock() obj_cgroup_uncharge_pages() refill_stock() local_trylock() -> nested, will fail