From: Zubair Lutfullah Kakakhel <Zubair.Kakakhel@imgtec.com>
To: Andy Yan <andy.yan@rock-chips.com>, <airlied@linux.ie>,
<heiko@sntech.de>, <fabio.estevam@freescale.com>,
<rmk+kernel@arm.linux.org.uk>
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
Grant Likely <grant.likely@linaro.org>,
Rob Herring <robh+dt@kernel.org>,
Philipp Zabel <p.zabel@pengutronix.de>,
Shawn Guo <shawn.guo@linaro.org>, Josh Boyer <jwboyer@redhat.com>,
Sean Paul <seanpaul@chromium.org>,
Inki Dae <inki.dae@samsung.com>, Dave Airlie <airlied@redhat.com>,
Arnd Bergmann <arnd@arndb.de>,
Lucas Stach <l.stach@pengutronix.de>, <djkurtz@google.com>,
<ykk@rock-chips.com>, <linux-kernel@vger.kernel.org>,
<dri-devel@lists.freedesktop.org>, <devel@driverdev.osuosl.org>,
<devicetree@vger.kernel.org>,
<linux-rockchip@lists.infradead.org>
Subject: Re: [PATCH 2/2] move imx-hdmi to bridge/dw-hdmi
Date: Tue, 4 Nov 2014 13:50:49 +0000 [thread overview]
Message-ID: <5458D9B9.5030606@imgtec.com> (raw)
In-Reply-To: <1415108398-34376-1-git-send-email-andy.yan@rock-chips.com>
Hi,
On 04/11/14 13:39, Andy Yan wrote:
> From: Andy yan <andy.yan@rock-chips.com>
>
> the original imx hdmi driver is under staging/imx-drm,
> which depends on imx-drm, so move the imx hdmi drvier out
> to drm/bridge and rename imx-hdmi to dw-hdmi
>
> Change-Id: I5f417372f256aa26cd00a3cd0160741680afd39d
> ---
> drivers/gpu/drm/bridge/Kconfig | 5 +
> drivers/gpu/drm/bridge/Makefile | 1 +
> drivers/gpu/drm/bridge/dw_hdmi.c | 1651 +++++++++++++++++++++++++++++++++
> drivers/gpu/drm/bridge/dw_hdmi.h | 1032 +++++++++++++++++++++
> drivers/staging/imx-drm/Kconfig | 1 +
> drivers/staging/imx-drm/Makefile | 2 +-
> drivers/staging/imx-drm/dw_hdmi-imx.c | 66 +-
> drivers/staging/imx-drm/imx-hdmi.c | 1651 ---------------------------------
> drivers/staging/imx-drm/imx-hdmi.h | 1032 ---------------------
> include/drm/bridge/dw_hdmi.h | 26 +-
> 10 files changed, 2737 insertions(+), 2730 deletions(-)
> create mode 100644 drivers/gpu/drm/bridge/dw_hdmi.c
> create mode 100644 drivers/gpu/drm/bridge/dw_hdmi.h
> delete mode 100644 drivers/staging/imx-drm/imx-hdmi.c
> delete mode 100644 drivers/staging/imx-drm/imx-hdmi.h
>
Could you try generating this patch with the -M option?
git format-patch should then understand its a rename.
Then it should generate a smaller patch that is possible to review easily.
Thanks
ZubairLK
next prev parent reply other threads:[~2014-11-04 13:52 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-11-04 13:39 Andy Yan
2014-11-04 13:50 ` Zubair Lutfullah Kakakhel [this message]
2014-11-05 1:55 ` Andy Yan
2014-11-04 16:03 ` Greg Kroah-Hartman
2014-11-05 9:30 ` Dan Carpenter
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=5458D9B9.5030606@imgtec.com \
--to=zubair.kakakhel@imgtec.com \
--cc=airlied@linux.ie \
--cc=airlied@redhat.com \
--cc=andy.yan@rock-chips.com \
--cc=arnd@arndb.de \
--cc=devel@driverdev.osuosl.org \
--cc=devicetree@vger.kernel.org \
--cc=djkurtz@google.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=fabio.estevam@freescale.com \
--cc=grant.likely@linaro.org \
--cc=gregkh@linuxfoundation.org \
--cc=heiko@sntech.de \
--cc=inki.dae@samsung.com \
--cc=jwboyer@redhat.com \
--cc=l.stach@pengutronix.de \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-rockchip@lists.infradead.org \
--cc=p.zabel@pengutronix.de \
--cc=rmk+kernel@arm.linux.org.uk \
--cc=robh+dt@kernel.org \
--cc=seanpaul@chromium.org \
--cc=shawn.guo@linaro.org \
--cc=ykk@rock-chips.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome