From: Krishna Kurapati PSSNV <quic_kriskura@quicinc.com>
To: Johan Hovold <johan@kernel.org>, Rob Herring <robh+dt@kernel.org>
Cc: Thinh Nguyen <Thinh.Nguyen@synopsys.com>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
Philipp Zabel <p.zabel@pengutronix.de>,
"Andy Gross" <agross@kernel.org>,
Bjorn Andersson <andersson@kernel.org>,
"Konrad Dybcio" <konrad.dybcio@linaro.org>,
Krzysztof Kozlowski <krzysztof.kozlowski+dt@linaro.org>,
Felipe Balbi <balbi@kernel.org>,
"Wesley Cheng" <quic_wcheng@quicinc.com>,
<linux-usb@vger.kernel.org>, <linux-kernel@vger.kernel.org>,
<linux-arm-msm@vger.kernel.org>, <devicetree@vger.kernel.org>,
<quic_pkondeti@quicinc.com>, <quic_ppratap@quicinc.com>,
<quic_jackp@quicinc.com>, <quic_harshq@quicinc.com>,
<ahalaney@redhat.com>, <quic_shazhuss@quicinc.com>
Subject: Re: [PATCH v9 01/10] dt-bindings: usb: qcom,dwc3: Add bindings for SC8280 Multiport
Date: Mon, 3 Jul 2023 00:41:59 +0530 [thread overview]
Message-ID: <548e35a7-984d-a62f-ea4b-a5aeace8009a@quicinc.com> (raw)
In-Reply-To: <ZJsCf3nYrikF7nZc@hovoldconsulting.com>
On 6/27/2023 9:08 PM, Johan Hovold wrote:
> On Tue, Jun 27, 2023 at 01:20:59PM +0200, Johan Hovold wrote:
>> On Wed, Jun 21, 2023 at 10:06:19AM +0530, Krishna Kurapati wrote:
>
>>> + items:
>>> + - const: dp1_hs_phy_irq
>>> + - const: dm1_hs_phy_irq
>>> + - const: dp2_hs_phy_irq
>>> + - const: dm2_hs_phy_irq
>>> + - const: dp3_hs_phy_irq
>>> + - const: dm4_hs_phy_irq
>>> + - const: dp4_hs_phy_irq
>>> + - const: dm4_hs_phy_irq
>>> + - const: ss1_phy_irq
>>> + - const: ss2_phy_irq
>>> + - const: pwr_event_1
>>> + - const: pwr_event_2
>>> + - const: pwr_event_3
>>> + - const: pwr_event_4
>>
>> The naming here is inconsistent and interrupts should not have "_irq"
>> suffixes (even if some of the current ones do for historical reasons).
>>
>> I believe these should be named
>>
>> pwr_event_1
>> dp_hs_phy_1
>> dm_hs_phy_1
>> ss_phy_1
>>
>> pwr_event_2
>> dp_hs_phy_2
>> dm_hs_phy_2
>> ss_phy_2
>>
>> pwr_event_3
>> dp_hs_phy_3
>> dm_hs_phy_3
>>
>> pwr_event_4
>> dp_hs_phy_4
>> dm_hs_phy_4
>>
>> or similar and be grouped by port while using the the
>> qcom,sc8280xp-dwc ordering for the individual lines.
>
> Perhaps the ordering you suggested is fine too, but I'd probably move
> the pwr_event ones first to match qcom,sc8280xp-dwc then, that is:
>
> pwr_event_1
> pwr_event_2
> pwr_event_3
> pwr_event_4
> dp_hs_phy_1
> dm_hs_phy_1
> dp_hs_phy_2
> dm_hs_phy_2
> dp_hs_phy_3
> dm_hs_phy_3
> dp_hs_phy_4
> dm_hs_phy_4
> ss_phy_1
> ss_phy_2
>
> so we have them grouped as pwr_event followed by HS and with SS last.
>
>> Side note: Please note how the above interrupt properties can also be
>> used to infer the number of HS and SS ports.
>
> Johan
Can't we just cleanup all at once later ? Might not be a good idea for
some properties in the file to have _irq and for some to not have it. I
will modify the order though.
Regards,
Krishna,
next prev parent reply other threads:[~2023-07-02 19:12 UTC|newest]
Thread overview: 68+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-06-21 4:36 [PATCH v9 00/10] Add multiport support for DWC3 controllers Krishna Kurapati
2023-06-21 4:36 ` [PATCH v9 01/10] dt-bindings: usb: qcom,dwc3: Add bindings for SC8280 Multiport Krishna Kurapati
2023-06-23 20:41 ` Rob Herring
2023-06-27 11:20 ` Johan Hovold
2023-06-27 15:38 ` Johan Hovold
2023-07-02 19:11 ` Krishna Kurapati PSSNV [this message]
2023-07-21 8:10 ` Johan Hovold
2023-06-21 4:36 ` [PATCH v9 02/10] dt-bindings: usb: Add bindings for multiport properties on DWC3 controller Krishna Kurapati
2023-06-23 20:41 ` Rob Herring
2023-06-27 11:24 ` Johan Hovold
2023-06-21 4:36 ` [PATCH v9 03/10] usb: dwc3: core: Access XHCI address space temporarily to read port info Krishna Kurapati
2023-06-23 22:14 ` Thinh Nguyen
2023-06-27 11:45 ` Johan Hovold
2023-07-02 18:48 ` Krishna Kurapati PSSNV
2023-07-21 7:44 ` Johan Hovold
2023-07-23 14:59 ` Krishna Kurapati PSSNV
2023-07-24 15:41 ` Johan Hovold
2023-07-25 5:39 ` Krishna Kurapati PSSNV
2023-06-21 4:36 ` [PATCH v9 04/10] usb: dwc3: core: Skip setting event buffers for host only controllers Krishna Kurapati
2023-06-23 22:27 ` Thinh Nguyen
2023-06-24 7:20 ` Krishna Kurapati PSSNV
2023-06-26 23:34 ` Thinh Nguyen
2023-06-26 23:46 ` Thinh Nguyen
2023-07-02 18:45 ` Krishna Kurapati PSSNV
2023-07-05 22:40 ` Thinh Nguyen
2023-06-21 4:36 ` [PATCH v9 05/10] usb: dwc3: core: Refactor PHY logic to support Multiport Controller Krishna Kurapati
2023-06-23 22:55 ` Thinh Nguyen
2023-06-24 7:15 ` Krishna Kurapati PSSNV
2023-06-27 12:09 ` Johan Hovold
2023-07-02 18:56 ` Krishna Kurapati PSSNV
2023-07-21 7:56 ` Johan Hovold
2023-08-01 1:30 ` Thinh Nguyen
2023-10-19 13:20 ` Johan Hovold
2023-06-21 4:36 ` [PATCH v9 06/10] usb: dwc3: qcom: Add support to read IRQ's related to multiport Krishna Kurapati
2023-06-21 10:05 ` Konrad Dybcio
2023-06-21 10:08 ` Krishna Kurapati PSSNV
2023-06-27 14:31 ` Johan Hovold
2023-07-02 18:59 ` Krishna Kurapati PSSNV
2023-07-11 6:42 ` Krishna Kurapati PSSNV
2023-07-21 8:14 ` Johan Hovold
2023-07-21 8:19 ` Krishna Kurapati PSSNV
2023-07-21 9:21 ` Johan Hovold
2023-07-21 9:35 ` Krishna Kurapati PSSNV
2023-07-21 11:11 ` Johan Hovold
2023-07-12 12:12 ` Johan Hovold
2023-07-12 18:26 ` Krishna Kurapati PSSNV
2023-07-14 9:05 ` Johan Hovold
2023-07-14 10:40 ` Krishna Kurapati PSSNV
2023-07-15 19:01 ` Krishna Kurapati PSSNV
2023-07-17 15:15 ` Krishna Kurapati PSSNV
2023-07-21 8:35 ` Johan Hovold
2023-07-21 8:45 ` Krishna Kurapati PSSNV
2023-06-21 4:36 ` [PATCH v9 07/10] usb: dwc3: qcom: Add multiport suspend/resume support for wrapper Krishna Kurapati
2023-06-27 15:05 ` Johan Hovold
2023-07-02 19:02 ` Krishna Kurapati PSSNV
2023-06-21 4:36 ` [PATCH v9 08/10] arm64: dts: qcom: sc8280xp: Add multiport controller node for SC8280 Krishna Kurapati
2023-06-23 22:39 ` Konrad Dybcio
2023-06-24 7:13 ` Krishna Kurapati PSSNV
2023-06-27 15:16 ` Johan Hovold
2023-07-02 19:10 ` Krishna Kurapati PSSNV
2023-07-21 8:08 ` Johan Hovold
2023-06-27 15:11 ` Johan Hovold
2023-06-21 4:36 ` [PATCH v9 09/10] arm64: dts: qcom: sa8295p: Enable tertiary controller and its 4 USB ports Krishna Kurapati
2023-06-23 22:40 ` Konrad Dybcio
2023-06-21 4:36 ` [PATCH v9 10/10] arm64: dts: qcom: sa8540-ride: Enable first port of tertiary usb controller Krishna Kurapati
2023-06-23 22:42 ` Konrad Dybcio
2023-06-24 7:11 ` Krishna Kurapati PSSNV
2023-06-27 15:19 ` [PATCH v9 00/10] Add multiport support for DWC3 controllers Johan Hovold
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=548e35a7-984d-a62f-ea4b-a5aeace8009a@quicinc.com \
--to=quic_kriskura@quicinc.com \
--cc=Thinh.Nguyen@synopsys.com \
--cc=agross@kernel.org \
--cc=ahalaney@redhat.com \
--cc=andersson@kernel.org \
--cc=balbi@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=gregkh@linuxfoundation.org \
--cc=johan@kernel.org \
--cc=konrad.dybcio@linaro.org \
--cc=krzysztof.kozlowski+dt@linaro.org \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=p.zabel@pengutronix.de \
--cc=quic_harshq@quicinc.com \
--cc=quic_jackp@quicinc.com \
--cc=quic_pkondeti@quicinc.com \
--cc=quic_ppratap@quicinc.com \
--cc=quic_shazhuss@quicinc.com \
--cc=quic_wcheng@quicinc.com \
--cc=robh+dt@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®