mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Xiaoyao Li <xiaoyao.li@intel.com>
To: Sean Christopherson <sean.j.christopherson@intel.com>
Cc: Paolo Bonzini <pbonzini@redhat.com>,
	Vitaly Kuznetsov <vkuznets@redhat.com>,
	Wanpeng Li <wanpengli@tencent.com>,
	Jim Mattson <jmattson@google.com>, Joerg Roedel <joro@8bytes.org>,
	kvm@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 2/7] KVM: X86: Go on updating other CPUID leaves when leaf 1 is absent
Date: Fri, 3 Jul 2020 06:28:39 +0800	[thread overview]
Message-ID: <54c1cea0-75d5-c38f-c3e5-a8a0679c5fcf@intel.com> (raw)
In-Reply-To: <20200702190237.GK3575@linux.intel.com>

On 7/3/2020 3:02 AM, Sean Christopherson wrote:
> On Thu, Jul 02, 2020 at 11:54:03AM -0700, Sean Christopherson wrote:
>> On Tue, Jun 23, 2020 at 07:58:11PM +0800, Xiaoyao Li wrote:
>>> As handling of bits other leaf 1 added over time, kvm_update_cpuid()
>>> should not return directly if leaf 1 is absent, but should go on
>>> updateing other CPUID leaves.
>>>
>>> Signed-off-by: Xiaoyao Li <xiaoyao.li@intel.com>
>>
>> This should probably be marked for stable.
>>
>>> ---
>>>   arch/x86/kvm/cpuid.c | 23 +++++++++++------------
>>>   1 file changed, 11 insertions(+), 12 deletions(-)
>>>
>>> diff --git a/arch/x86/kvm/cpuid.c b/arch/x86/kvm/cpuid.c
>>> index 1d13bad42bf9..0164dac95ef5 100644
>>> --- a/arch/x86/kvm/cpuid.c
>>> +++ b/arch/x86/kvm/cpuid.c
>>> @@ -60,22 +60,21 @@ int kvm_update_cpuid(struct kvm_vcpu *vcpu)
>>>   	struct kvm_lapic *apic = vcpu->arch.apic;
>>>   
>>>   	best = kvm_find_cpuid_entry(vcpu, 1, 0);
>>> -	if (!best)
>>> -		return 0;
>>
>> Rather than wrap the existing code, what about throwing it in a separate
>> helper?  That generates an easier to read diff and also has the nice
>> property of getting 'apic' out of the common code.
> 
> Hrm, that'd be overkill once the apic code is moved in a few patches.
> What if you keep the cpuid updates wrapped (as in this patch), but then
> do
> 
> 	if (best && apic) {
> 	}
> 
> for the apic path?  That'll minimize churn for code that is disappearing,
> e.g. will make future git archaeologists happy :-).

Sure. I'll do it in next version.

>>> -
>>> -	/* Update OSXSAVE bit */
>>> -	if (boot_cpu_has(X86_FEATURE_XSAVE) && best->function == 0x1)
>>> -		cpuid_entry_change(best, X86_FEATURE_OSXSAVE,
>>> +	if (best) {
>>> +		/* Update OSXSAVE bit */
>>> +		if (boot_cpu_has(X86_FEATURE_XSAVE))
>>> +			cpuid_entry_change(best, X86_FEATURE_OSXSAVE,
>>>   				   kvm_read_cr4_bits(vcpu, X86_CR4_OSXSAVE));
>>>   
>>> -	cpuid_entry_change(best, X86_FEATURE_APIC,
>>> +		cpuid_entry_change(best, X86_FEATURE_APIC,
>>>   			   vcpu->arch.apic_base & MSR_IA32_APICBASE_ENABLE);
>>>   
>>> -	if (apic) {
>>> -		if (cpuid_entry_has(best, X86_FEATURE_TSC_DEADLINE_TIMER))
>>> -			apic->lapic_timer.timer_mode_mask = 3 << 17;
>>> -		else
>>> -			apic->lapic_timer.timer_mode_mask = 1 << 17;
>>> +		if (apic) {
>>> +			if (cpuid_entry_has(best, X86_FEATURE_TSC_DEADLINE_TIMER))
>>> +				apic->lapic_timer.timer_mode_mask = 3 << 17;
>>> +			else
>>> +				apic->lapic_timer.timer_mode_mask = 1 << 17;
>>> +		}
>>>   	}
>>>   
>>>   	best = kvm_find_cpuid_entry(vcpu, 7, 0);
>>> -- 
>>> 2.18.2
>>>


  reply	other threads:[~2020-07-02 22:28 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-06-23 11:58 [PATCH v2 0/7] Refactor handling flow of SET_CPUID* Xiaoyao Li
2020-06-23 11:58 ` [PATCH v2 1/7] KVM: X86: Reset vcpu->arch.cpuid_nent to 0 if SET_CPUID fails Xiaoyao Li
2020-06-23 18:20   ` Jim Mattson
2020-06-24  0:40     ` Xiaoyao Li
2020-06-23 11:58 ` [PATCH v2 2/7] KVM: X86: Go on updating other CPUID leaves when leaf 1 is absent Xiaoyao Li
2020-07-02 18:54   ` Sean Christopherson
2020-07-02 19:02     ` Sean Christopherson
2020-07-02 22:28       ` Xiaoyao Li [this message]
2020-06-23 11:58 ` [PATCH v2 3/7] KVM: X86: Introduce kvm_check_cpuid() Xiaoyao Li
2020-06-23 11:58 ` [PATCH v2 4/7] KVM: X86: Split kvm_update_cpuid() Xiaoyao Li
2020-06-23 11:58 ` [PATCH v2 5/7] KVM: X86: Rename cpuid_update() to update_vcpu_model() Xiaoyao Li
2020-06-23 11:58 ` [PATCH v2 6/7] KVM: X86: Move kvm_x86_ops.update_vcpu_model() into kvm_update_vcpu_model() Xiaoyao Li
2020-07-02 18:59   ` Sean Christopherson
2020-07-02 22:29     ` Xiaoyao Li
2020-06-23 11:58 ` [PATCH v2 7/7] KVM: X86: Move kvm_apic_set_version() to kvm_update_vcpu_model() Xiaoyao Li
2020-07-02 19:00   ` Sean Christopherson
2020-07-02 22:30     ` Xiaoyao Li

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=54c1cea0-75d5-c38f-c3e5-a8a0679c5fcf@intel.com \
    --to=xiaoyao.li@intel.com \
    --cc=jmattson@google.com \
    --cc=joro@8bytes.org \
    --cc=kvm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=pbonzini@redhat.com \
    --cc=sean.j.christopherson@intel.com \
    --cc=vkuznets@redhat.com \
    --cc=wanpengli@tencent.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome