From: Michal Marek <mmarek@suse.cz>
To: Darren Hart <dvhart@linux.intel.com>,
Josh Triplett <josh@joshtriplett.org>,
Masahiro Yamada <yamada.masahiro@socionext.com>
Cc: linux-kbuild@vger.kernel.org, Josh Boyer <jwboyer@redhat.com>,
john stultz <johnstul@us.ibm.com>,
linux-kernel@vger.kernel.org,
"Yann E. MORIN" <yann.morin.1998@free.fr>
Subject: Re: [PATCH 0/6] kbuild: mergeconfig: fix bugs, improve readability, and add generic entry point
Date: Tue, 24 Mar 2015 16:55:06 +0100 [thread overview]
Message-ID: <551188DA.3090109@suse.cz> (raw)
In-Reply-To: <D128A497.C1D73%dvhart@linux.intel.com>
On 2015-03-13 22:29, Darren Hart wrote:
> On 3/13/15, 1:27 AM, "Josh Triplett" <josh@joshtriplett.org> wrote:
>
>> On Fri, Mar 13, 2015 at 03:21:37PM +0900, Masahiro Yamada wrote:
>>>
>>> This series is related to mergeconfig (scripts/kconfig/merge_config.sh):
>>>
>>> 1/6 and 2/6 fix bugs related to the parallel build. (-j option).
>>> 3/6 thru 5/6 are minor clean-ups.
>>> 6/6 is a new feature; add a generic entry point of mergeconfig.
>>>
>>> The last one is RFC.
>>>
>>> Masahiro Yamada (6):
>>> kbuild: mergeconfig: fix "jobserver unavailable" warning
>>> kbuild: mergeconfig: move an error check to merge_config.sh
>>> kbuild: mergeconfig: remove redundant $(objtree)
>>> merge_config.sh: improve indentation
>>> merge_config.sh: rename MAKE to RUNMAKE
>>> kbuild: add generic mergeconfig target, %.config
>
> Nice improvements, thank you.
>
>>
>> For all six:
>>
>> Reviewed-by: Josh Triplett <josh@joshtriplett.org>
>>
>
> Likewise:
>
> Reviewed-by: Darren Hart <dvhart@linux.intel.com>
Added to kbuild.git#kconfig.
Michal
prev parent reply other threads:[~2015-03-24 15:55 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-03-13 6:21 Masahiro Yamada
2015-03-13 6:21 ` [PATCH 1/6] kbuild: mergeconfig: fix "jobserver unavailable" warning Masahiro Yamada
2015-03-13 6:21 ` [PATCH 2/6] kbuild: mergeconfig: move an error check to merge_config.sh Masahiro Yamada
2015-03-13 6:21 ` [PATCH 3/6] kbuild: mergeconfig: remove redundant $(objtree) Masahiro Yamada
2015-03-13 6:21 ` [PATCH 4/6] merge_config.sh: improve indentation Masahiro Yamada
2015-03-13 6:21 ` [PATCH 5/6] merge_config.sh: rename MAKE to RUNMAKE Masahiro Yamada
2015-03-13 6:21 ` [RFC PATCH 6/6] kbuild: add generic mergeconfig target, %.config Masahiro Yamada
2015-03-13 8:27 ` [PATCH 0/6] kbuild: mergeconfig: fix bugs, improve readability, and add generic entry point Josh Triplett
2015-03-13 21:29 ` Darren Hart
2015-03-24 15:55 ` Michal Marek [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=551188DA.3090109@suse.cz \
--to=mmarek@suse.cz \
--cc=dvhart@linux.intel.com \
--cc=johnstul@us.ibm.com \
--cc=josh@joshtriplett.org \
--cc=jwboyer@redhat.com \
--cc=linux-kbuild@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=yamada.masahiro@socionext.com \
--cc=yann.morin.1998@free.fr \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome