From: Mateusz Kulikowski <mateusz.kulikowski@gmail.com>
To: Dan Carpenter <dan.carpenter@oracle.com>
Cc: gregkh@linuxfoundation.org, devel@driverdev.osuosl.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 15/21] staging: rtl8192e: Fix LONG_LINE warnings - modify variables
Date: Wed, 15 Apr 2015 23:56:45 +0200 [thread overview]
Message-ID: <552EDE9D.4000601@gmail.com> (raw)
In-Reply-To: <20150414084035.GG10964@mwanda>
On 14.04.2015 10:40, Dan Carpenter wrote:
> On Mon, Apr 13, 2015 at 11:47:38PM +0200, Mateusz Kulikowski wrote:
>> + if (*rfa_pti_r > 4) {
>> + (*rfa_pti_r)--;
>
>
> Honestly, I thought that patch 14 was too hard to review and did too
> many things, but this one is kind of ridiculous.
>
> - p->rfa_txpowertrackingindex--;
> + (*rfa_pti)--;
>
> The new version is fewer characters but it's way more complicated to
> think about. Just rename rfa_txpowertrackingindex to something
> reasonable. It's a stupid name, because it_hasninegazillionwordsinit
> and it's too long.
>
> "rfa_pti_r" is a terrible name as well. it_also_hngwit_for_realz.
True, but it's also used as local variable in one-screen function;
Nevertheless - I got the point.
> I'm not going to review the rest of this patch.
Thanks for the patience, I will try to split such commits more in future.
As for v3 I assume patches 15, 19, 20 should be reworked; I will:
- Try to find better names for structure members where possible (this mostly
applies to r8192_priv members),
- Do exactly one type of cleanup 'operation' in each commit (this means fixing
one LONG_LINE warning may take more than one commit)
- Avoid playing with pointers like above
- Standardize local variable names in all functions (i.e. if I use igain as
init_gain pointer, I'll do it like that everywhere)
Is it enough or did I missed something?
Regards,
Mateusz
next prev parent reply other threads:[~2015-04-15 21:57 UTC|newest]
Thread overview: 36+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-04-13 21:47 [PATCH v2 00/21] staging: rtl8192e: Fix more checkpatch.pl warnings Mateusz Kulikowski
2015-04-13 21:47 ` [PATCH v2 01/21] staging: rtl8192e: Fix SPACE_BEFORE_TAB warnings Mateusz Kulikowski
2015-04-13 21:47 ` [PATCH v2 02/21] staging: rtl8192e: Copy comments from r819XE_phyreg.h to r8192E_phyreg.h Mateusz Kulikowski
2015-04-13 21:47 ` [PATCH v2 03/21] staging: rtl8192e: remove r819xE_phyreg.h Mateusz Kulikowski
2015-04-13 21:47 ` [PATCH v2 04/21] staging: rtl8192e: Fix SPACING errors Mateusz Kulikowski
2015-04-13 21:47 ` [PATCH v2 05/21] staging: rtl8192e: Remove bb tx gains from r8192_priv Mateusz Kulikowski
2015-04-13 21:47 ` [PATCH v2 06/21] staging: rtl8192e: Fix LINE_SPACING warning Mateusz Kulikowski
2015-04-13 21:47 ` [PATCH v2 07/21] staging: rtl8192e: Fix DEEP_INDENTATION warnings in rtllib_parse_info_param() Mateusz Kulikowski
2015-04-13 21:47 ` [PATCH v2 08/21] staging: rtl8192e: Fix DEEP_INDENTATION warnings in rtl_dm.c Mateusz Kulikowski
2015-04-13 21:47 ` [PATCH v2 09/21] staging: rtl8192e: Fix DeviceID in rtl8192_pci_findadapter() Mateusz Kulikowski
2015-04-13 21:47 ` [PATCH v2 10/21] staging: rtl8192e: replace memcpy() -> ether_addr_copy_unaligned() Mateusz Kulikowski
2015-04-14 8:00 ` Dan Carpenter
2015-04-15 21:08 ` Mateusz Kulikowski
2015-04-15 21:36 ` Joe Perches
2015-05-03 19:10 ` Greg KH
2015-05-03 19:17 ` Mateusz Kulikowski
2015-04-13 21:47 ` [PATCH v2 11/21] staging: rtl8192e: Fix DEEP_INDENTATION warning in rtllib_parse_info_param() Mateusz Kulikowski
2015-04-13 21:47 ` [PATCH v2 12/21] staging: rtl8192e: replace memcmp() with ether_addr_equal_unaligned() Mateusz Kulikowski
2015-04-13 21:47 ` [PATCH v2 13/21] staging: rtl8192e: Fix PREFER_PR_LEVEL warnings Mateusz Kulikowski
2015-04-14 8:07 ` Dan Carpenter
2015-04-15 21:27 ` Mateusz Kulikowski
2015-04-14 8:09 ` Dan Carpenter
2015-04-13 21:47 ` [PATCH v2 14/21] staging: rtl8192e: Fix LONG_LINE warnings Mateusz Kulikowski
2015-04-13 21:47 ` [PATCH v2 15/21] staging: rtl8192e: Fix LONG_LINE warnings - modify variables Mateusz Kulikowski
2015-04-14 8:40 ` Dan Carpenter
2015-04-15 21:56 ` Mateusz Kulikowski [this message]
2015-04-13 21:47 ` [PATCH v2 16/21] staging: rtl8192e: Fix LONG_LING in rtllib_parse_info_param() Mateusz Kulikowski
2015-04-13 21:47 ` [PATCH v2 17/21] staging: rtl8192e: Fix LONG_LINE warnings (conditions) Mateusz Kulikowski
2015-04-13 21:47 ` [PATCH v2 18/21] staging: rtl8192e: fix LONG_LINE warnings - replace ?: expressions Mateusz Kulikowski
2015-04-13 21:47 ` [PATCH v2 19/21] staging: rtl8192e: Fix LONG_LINE in rtllib_parse_mife_generic() Mateusz Kulikowski
2015-04-13 21:47 ` [PATCH v2 20/21] staging: rtl8192e: Fix LONG_LINE in simplify rtl8192_process_phyinfo() Mateusz Kulikowski
2015-04-13 21:47 ` [PATCH v2 21/21] staging: rtl8192e: Remove unimplemented iwpriv handlers Mateusz Kulikowski
2015-04-13 22:12 ` [PATCH v2 00/21] staging: rtl8192e: Fix more checkpatch.pl warnings Dan Carpenter
2015-04-13 22:15 ` Mateusz Kulikowski
2015-04-13 22:33 ` Dan Carpenter
2015-04-13 22:39 ` Mateusz Kulikowski
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=552EDE9D.4000601@gmail.com \
--to=mateusz.kulikowski@gmail.com \
--cc=dan.carpenter@oracle.com \
--cc=devel@driverdev.osuosl.org \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome