From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1756508AbbDOWHC (ORCPT ); Wed, 15 Apr 2015 18:07:02 -0400 Received: from mx0a-00082601.pphosted.com ([67.231.145.42]:59480 "EHLO mx0a-00082601.pphosted.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752720AbbDOWGw (ORCPT ); Wed, 15 Apr 2015 18:06:52 -0400 Message-ID: <552EE0F9.40607@fb.com> Date: Wed, 15 Apr 2015 16:06:49 -0600 From: Jens Axboe User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.6.0 MIME-Version: 1.0 To: Al Viro CC: , Subject: Re: [PATCH v2] direct-io: only inc/dec inode->i_dio_count for file systems References: <1429135298-17153-1-git-send-email-axboe@fb.com> <20150415220550.GO889@ZenIV.linux.org.uk> In-Reply-To: <20150415220550.GO889@ZenIV.linux.org.uk> Content-Type: text/plain; charset="windows-1252"; format=flowed Content-Transfer-Encoding: 7bit X-Originating-IP: [192.168.54.13] X-Proofpoint-Spam-Reason: safe X-FB-Internal: Safe X-Proofpoint-Virus-Version: vendor=fsecure engine=2.50.10432:5.13.68,1.0.33,0.0.0000 definitions=2015-04-15_07:2015-04-15,2015-04-15,1970-01-01 signatures=0 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 04/15/2015 04:05 PM, Al Viro wrote: > On Wed, Apr 15, 2015 at 04:01:35PM -0600, Jens Axboe wrote: >> Hi, >> >> A proper patch series posting of the patch to skip inode dio counts >> where we don't need them. Performance results and general notes in >> patch #1. We can take this a bit further if we want to push this >> truncate locking into the caller, but I'd like to keep that as a >> separate patch series instead. >> >> Changes since v2: >> >> - Changed flag to DIO_SKIP_DIO_COUNT. Patch 2+3 will use this for >> skipping the extra inc/dec for btrfs and ext4, so better rename it >> to something that better tells what is happening in the deep mess >> that is dio. >> >> - Have inode_dio_inc/dec() helpers. Again, this better tells the caller >> what is going on. > > Please, rebase on vfs.git#for-next; it conflicts (at least) with Omar's > ->direct_IO() patches, if not with generic_write_checks() ones following > those. Sure, I can do that. -- Jens Axboe