On 2015/06/27 11:23, Xishi Qiu wrote: > This patch introduces a new config called "CONFIG_ACPI_MIRROR_MEMORY", set it CONFIG_MEMORY_MIRROR > off by default. > > Signed-off-by: Xishi Qiu > --- > mm/Kconfig | 8 ++++++++ > 1 file changed, 8 insertions(+) > > diff --git a/mm/Kconfig b/mm/Kconfig > index 390214d..c40bb8b 100644 > --- a/mm/Kconfig > +++ b/mm/Kconfig > @@ -200,6 +200,14 @@ config MEMORY_HOTREMOVE > depends on MEMORY_HOTPLUG && ARCH_ENABLE_MEMORY_HOTREMOVE > depends on MIGRATION > > +config MEMORY_MIRROR In following patches, you use CONFIG_MEMORY_MIRROR. I think the name is too generic besides it's depends on ACPI. But I'm not sure address based memory mirror is planned in other platform. So, hmm. How about dividing the config into 2 parts like attached ? (just an example) Thanks, -Kame