From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753777AbbIGHx0 (ORCPT ); Mon, 7 Sep 2015 03:53:26 -0400 Received: from mailout4.w1.samsung.com ([210.118.77.14]:59771 "EHLO mailout4.w1.samsung.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751676AbbIGHxX (ORCPT ); Mon, 7 Sep 2015 03:53:23 -0400 X-AuditID: cbfec7f5-f794b6d000001495-51-55ed4270a11f Message-id: <55ED426F.9030109@samsung.com> Date: Mon, 07 Sep 2015 09:53:19 +0200 From: Jacek Anaszewski User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20130804 Thunderbird/17.0.8 MIME-version: 1.0 To: Muhammad Falak R Wani Cc: Bryan Wu , Richard Purdie , linux-leds@vger.kernel.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH] leds: leds-ipaq-micro: Use devm_led_classdev_register References: <1441482942-23447-1-git-send-email-falakreyaz@gmail.com> In-reply-to: <1441482942-23447-1-git-send-email-falakreyaz@gmail.com> Content-type: text/plain; charset=ISO-8859-1; format=flowed Content-transfer-encoding: 7bit X-Brightmail-Tracker: H4sIAAAAAAAAA+NgFjrGLMWRmVeSWpSXmKPExsVy+t/xK7oFTm9DDSaulLY4unMik8Xuh+dZ LS7vmsNmsfXNOkaL3buesjqweuycdZfdY8/8H6wenzfJBTBHcdmkpOZklqUW6dslcGVMvbCH peAca8W7x9fYGhjPs3QxcnJICJhIHDr3kBHCFpO4cG89WxcjF4eQwFJGibcPe1khnGeMEj03 vrOBVPEKaElsmXSQCcRmEVCVeHvoMiuIzSZgKPHzxWuwuKhAhMSf0/tYIeoFJX5Mvge0jYND RMBA4vOnQJAws0Ajo0RvqwhIWFjAS+LsGSuQsJCAi8SyR0/B7uEUcJXYu/koC0S5tcTKSdsY IWx5ic1r3jJPYBSYhWTBLCRls5CULWBkXsUomlqaXFCclJ5rpFecmFtcmpeul5yfu4kRErpf dzAuPWZ1iFGAg1GJh/dG15tQIdbEsuLK3EOMEhzMSiK8JluAQrwpiZVVqUX58UWlOanFhxil OViUxHln7nofIiSQnliSmp2aWpBaBJNl4uCUamAMyNv6sEmir+L2nr8dG18eOBfg+YVvyjHr wtjmszof9J7+3Hbj73VD37h/j2pfXNC5c4X10rWOScZ5msEXF8s/XB72/I2QUJfA/SSWvfqq t/8GrZmfdb3IZinX1GPHu2LkctlfpkaJnI4KXdu65OJLhX9zPC7Ib921SjGlhD3vlVaN79L4 D/n5SizFGYmGWsxFxYkAzmFB1VkCAAA= Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hi Muhammad, Please split coding style fixes to a separate patch and leave only devm related changes here. On 09/05/2015 09:55 PM, Muhammad Falak R Wani wrote: > Use of resource-managed function devm_led_classdev_register > instead of led_classdev_register is preferred, consequently > remove redundant function micro_leds_remove. Also some coding > style issues are fixed, only two remain, which are left alone > to aid better readability. > > Signed-off-by: Muhammad Falak R Wani > --- > drivers/leds/leds-ipaq-micro.c | 47 ++++++++++++++++++------------------------ > 1 file changed, 20 insertions(+), 27 deletions(-) > [...] -- Best Regards, Jacek Anaszewski