From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from szxga02-in.huawei.com (szxga02-in.huawei.com [45.249.212.188]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 4171C4BAAF; Thu, 21 Dec 2023 09:39:36 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; dmarc=pass (p=quarantine dis=none) header.from=huawei.com Authentication-Results: smtp.subspace.kernel.org; spf=pass smtp.mailfrom=huawei.com Received: from mail.maildlp.com (unknown [172.19.88.105]) by szxga02-in.huawei.com (SkyGuard) with ESMTP id 4Swlkk5RrszZdLr; Thu, 21 Dec 2023 17:39:26 +0800 (CST) Received: from dggpemm500005.china.huawei.com (unknown [7.185.36.74]) by mail.maildlp.com (Postfix) with ESMTPS id 602FC140257; Thu, 21 Dec 2023 17:39:34 +0800 (CST) Received: from [10.69.30.204] (10.69.30.204) by dggpemm500005.china.huawei.com (7.185.36.74) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256) id 15.1.2507.35; Thu, 21 Dec 2023 17:39:34 +0800 Subject: Re: [PATCH net-next] page_pool: Rename frag_users to frag_cnt To: Ilias Apalodimas CC: , Jesper Dangaard Brouer , "David S. Miller" , Eric Dumazet , Jakub Kicinski , Paolo Abeni , References: <20231215073119.543560-1-ilias.apalodimas@linaro.org> <6fddeb22-0906-e04c-3a84-7836bef9ffa2@huawei.com> <0dfffe91-2bd4-2151-cf71-ef29bf562767@huawei.com> From: Yunsheng Lin Message-ID: <560730d0-937c-0497-e823-26c6cf72bff1@huawei.com> Date: Thu, 21 Dec 2023 17:39:33 +0800 User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Thunderbird/52.2.0 Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 In-Reply-To: Content-Type: text/plain; charset="utf-8" Content-Language: en-US Content-Transfer-Encoding: 7bit X-ClientProxiedBy: dggems702-chm.china.huawei.com (10.3.19.179) To dggpemm500005.china.huawei.com (7.185.36.74) On 2023/12/21 16:24, Ilias Apalodimas wrote: > >> But if we use 'bias' as part of the name, isn't that more reasonable to set >> both of the bias number to BIAS_MAX initially, and decrement the runtime >> bais number every time the page is split to more fragments? > > I think it's a matter of taste and how you interpret BIAS_MAX. In any > case, page_pool_drain_frag() will eventually set the *real* number of > references. But since the code can get complicated I like the idea of > making it identical to the mm subsystem tracking. > > Can we just merge v2 and me or you can send the logic inversion > patches right after. They are orthogonal to the rename anyway It is fine by me. And I can send the logic inversion patch if v2 is merged.