From: Andrzej Hajda <a.hajda@samsung.com>
To: Archit Taneja <architt@codeaurora.org>, dri-devel@lists.freedesktop.org
Cc: linux-kernel@vger.kernel.org, airlied@linux.ie, daniel@ffwll.ch,
treding@nvidia.com, l.stach@pengutronix.de, robh@kernel.org,
linux-arm-msm@vger.kernel.org, jani.nikula@linux.intel.com
Subject: Re: [RFC v2 3/5] drm/dsi: Check for used channels
Date: Fri, 30 Oct 2015 13:52:01 +0100 [thread overview]
Message-ID: <563367F1.2060202@samsung.com> (raw)
In-Reply-To: <1444123482-25579-4-git-send-email-architt@codeaurora.org>
On 10/06/2015 11:24 AM, Archit Taneja wrote:
> We don't check whether a previously registered mipi_dsi_device under the
> same host shares the same virtual channel.
>
> Before registering, check if any of the registered devices doesn't
> already have the same virtual channel.
>
> This wasn't crucial when all the devices under a host were populated via
> DT. Now that we also support creating devices manually, we could end up
> in a situation where a driver tries to create a device with a virtual
> channel already taken by a device populated in DT.
>
> Signed-off-by: Archit Taneja <architt@codeaurora.org>
Beside few non-blcking nitpicks.
Reviewed-by: Andrzej Hajda <a.hajda@samsung.com>
> ---
> drivers/gpu/drm/drm_mipi_dsi.c | 26 ++++++++++++++++++++++++--
> 1 file changed, 24 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/gpu/drm/drm_mipi_dsi.c b/drivers/gpu/drm/drm_mipi_dsi.c
> index 46ee515..db6130a 100644
> --- a/drivers/gpu/drm/drm_mipi_dsi.c
> +++ b/drivers/gpu/drm/drm_mipi_dsi.c
> @@ -123,6 +123,22 @@ static const struct device_type mipi_dsi_device_type = {
> .release = mipi_dsi_dev_release,
> };
>
> +static int __dsi_check_chan_busy(struct device *dev, void *data)
> +{
> + struct mipi_dsi_device *dsi = to_mipi_dsi_device(dev);
> + u32 reg = *(u32 *) data;
> +
> + if (dsi && dsi->channel == reg)
Maybe simpler would be:
u32 *reg = data;
if (dsi && dsi->channel == *reg)
> + return -EBUSY;
> +
> + return 0;
> +}
> +
> +static int mipi_dsi_check_chan_busy(struct mipi_dsi_host *host, u32 reg)
> +{
> + return device_for_each_child(host->dev, ®, __dsi_check_chan_busy);
> +}
> +
> struct mipi_dsi_device *mipi_dsi_device_new(struct mipi_dsi_host *host,
> struct mipi_dsi_device_info *info)
> {
> @@ -150,14 +166,20 @@ struct mipi_dsi_device *mipi_dsi_device_new(struct mipi_dsi_host *host,
>
> dev_set_name(&dsi->dev, "%s.%d", dev_name(host->dev), info->reg);
>
> + r = mipi_dsi_check_chan_busy(host, info->reg);
I know this r variable was introduced in the 1st patch, but if you will send
next iteration
consider replacing it with ret, looks more readable and follows file convention :)
Regards
Andrzej
> + if (r)
> + goto err;
> +
> r = device_register(&dsi->dev);
> if (r) {
> dev_err(dev, "failed to register device: %d\n", r);
> - kfree(dsi);
> - return ERR_PTR(r);
> + goto err;
> }
>
> return dsi;
> +err:
> + kfree(dsi);
> + return ERR_PTR(r);
> }
> EXPORT_SYMBOL(mipi_dsi_device_new);
>
next prev parent reply other threads:[~2015-10-30 12:52 UTC|newest]
Thread overview: 84+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-06-30 5:24 [RFC 0/2] drm/dsi: DSI for devices with different control bus Archit Taneja
2015-06-30 5:24 ` [RFC 1/2] drm/dsi: Create dummy DSI devices Archit Taneja
2015-08-19 8:10 ` Andrzej Hajda
2015-08-19 9:30 ` Archit Taneja
2015-06-30 5:24 ` [RFC 2/2] drm/dsi: Get DSI host by DT device node Archit Taneja
2015-08-19 8:46 ` Andrzej Hajda
2015-08-19 5:07 ` [RFC 0/2] drm/dsi: DSI for devices with different control bus Archit Taneja
2015-08-19 13:13 ` Thierry Reding
2015-08-19 14:17 ` Lucas Stach
2015-08-19 14:34 ` Thierry Reding
2015-08-19 14:52 ` Lucas Stach
2015-08-19 15:02 ` Thierry Reding
2015-08-19 15:39 ` Jani Nikula
2015-08-20 4:16 ` Archit Taneja
2015-08-20 11:48 ` Thierry Reding
2015-08-21 6:09 ` Archit Taneja
2015-09-07 11:46 ` Archit Taneja
2015-09-08 10:27 ` Andrzej Hajda
2015-09-10 6:15 ` Archit Taneja
2015-09-10 7:32 ` Thierry Reding
2015-09-15 10:32 ` Archit Taneja
2015-09-15 15:43 ` Rob Herring
2015-09-17 8:56 ` Archit Taneja
2015-09-15 10:41 ` Archit Taneja
2015-10-06 9:24 ` [RFC v2 0/5] " Archit Taneja
2015-10-06 9:24 ` [RFC v2 1/5] drm/dsi: Refactor device creation Archit Taneja
2015-10-30 11:28 ` Andrzej Hajda
2015-10-06 9:24 ` [RFC v2 2/5] drm/dsi: Try to match non-DT dsi devices Archit Taneja
2015-10-30 12:42 ` Andrzej Hajda
2015-11-02 5:26 ` Archit Taneja
2015-10-06 9:24 ` [RFC v2 3/5] drm/dsi: Check for used channels Archit Taneja
2015-10-30 12:52 ` Andrzej Hajda [this message]
2015-11-02 5:28 ` Archit Taneja
2015-10-06 9:24 ` [RFC v2 4/5] drm/dsi: Add routine to unregister dsi device Archit Taneja
2015-10-30 14:21 ` Andrzej Hajda
2015-11-02 6:28 ` Archit Taneja
2015-11-02 10:42 ` Andrzej Hajda
2015-11-03 7:18 ` Archit Taneja
2015-10-06 9:24 ` [RFC v2 5/5] drm/dsi: Get DSI host by DT device node Archit Taneja
2015-10-06 10:00 ` kbuild test robot
2015-11-02 10:50 ` Andrzej Hajda
2015-11-03 7:20 ` Archit Taneja
2015-11-30 12:01 ` [PATCH v3 0/5] drm/dsi: DSI for devices with different control bus Archit Taneja
2015-11-30 12:01 ` [PATCH v3 1/5] drm/dsi: Refactor device creation Archit Taneja
2015-11-30 12:01 ` [PATCH v3 2/5] drm/dsi: Try to match non-DT dsi devices Archit Taneja
2015-11-30 12:45 ` kbuild test robot
2015-12-07 5:29 ` Archit Taneja
2015-12-07 8:45 ` Jani Nikula
2015-12-07 8:59 ` Archit Taneja
2015-12-07 9:10 ` Jani Nikula
2015-12-07 9:18 ` Archit Taneja
2015-12-07 10:07 ` Jani Nikula
2015-12-07 16:55 ` Rob Clark
2015-11-30 12:01 ` [PATCH v3 3/5] drm/dsi: Check for used channels Archit Taneja
2015-11-30 12:01 ` [PATCH v3 4/5] drm/dsi: Add routine to unregister dsi device Archit Taneja
2015-11-30 12:34 ` Andrzej Hajda
2015-11-30 12:01 ` [PATCH v3 5/5] drm/dsi: Get DSI host by DT device node Archit Taneja
2015-12-10 12:41 ` [PATCH v4 0/6] drm/dsi: DSI for devices with different control bus Archit Taneja
2015-12-10 12:41 ` [PATCH v4 1/6] drm/dsi: check for CONFIG_OF when defining of_mipi_dsi_device_add Archit Taneja
2016-01-21 15:31 ` Thierry Reding
2016-01-26 14:59 ` Archit Taneja
2015-12-10 12:41 ` [PATCH v4 2/6] drm/dsi: Refactor device creation Archit Taneja
2016-01-21 15:46 ` Thierry Reding
2016-01-26 17:05 ` Archit Taneja
2015-12-10 12:41 ` [PATCH v4 3/6] drm/dsi: Try to match non-DT dsi devices Archit Taneja
2016-01-21 16:05 ` Thierry Reding
2016-01-26 18:04 ` Archit Taneja
2015-12-10 12:41 ` [PATCH v4 4/6] drm/dsi: Check for used channels Archit Taneja
2016-01-21 16:11 ` Thierry Reding
2016-01-27 5:16 ` Archit Taneja
2015-12-10 12:41 ` [PATCH v4 5/6] drm/dsi: Add routine to unregister dsi device Archit Taneja
2016-01-21 16:12 ` Thierry Reding
2016-01-27 5:20 ` Archit Taneja
2015-12-10 12:41 ` [PATCH v4 6/6] drm/dsi: Get DSI host by DT device node Archit Taneja
2016-01-21 16:16 ` Thierry Reding
2016-01-27 5:21 ` Archit Taneja
2016-01-05 5:29 ` [PATCH v4 0/6] drm/dsi: DSI for devices with different control bus Archit Taneja
2016-02-12 9:18 ` [PATCH v5 0/5] " Archit Taneja
2016-02-12 9:18 ` [PATCH v5 1/5] drm/dsi: check for CONFIG_OF when defining of_mipi_dsi_device_add Archit Taneja
2016-02-12 9:18 ` [PATCH v5 2/5] drm/dsi: Use mipi_dsi_device_register_full for DSI device creation Archit Taneja
2016-02-12 9:18 ` [PATCH v5 3/5] drm/dsi: Try to match non-DT DSI devices Archit Taneja
2016-02-12 9:18 ` [PATCH v5 4/5] drm/dsi: Add routine to unregister a DSI device Archit Taneja
2016-02-12 9:18 ` [PATCH v5 5/5] drm/dsi: Get DSI host by DT device node Archit Taneja
2016-03-02 16:05 ` [PATCH v5 0/5] drm/dsi: DSI for devices with different control bus Thierry Reding
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=563367F1.2060202@samsung.com \
--to=a.hajda@samsung.com \
--cc=airlied@linux.ie \
--cc=architt@codeaurora.org \
--cc=daniel@ffwll.ch \
--cc=dri-devel@lists.freedesktop.org \
--cc=jani.nikula@linux.intel.com \
--cc=l.stach@pengutronix.de \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=robh@kernel.org \
--cc=treding@nvidia.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome