mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Jarkko Nikula <jarkko.nikula@linux.intel.com>
To: Jeremiah Mahler <jmmahler@gmail.com>,
	Wolfram Sang <wsa@the-dreams.de>,
	Mika Westerberg <mika.westerberg@linux.intel.com>,
	Dudley Du <dudl@cypress.com>,
	linux-kernel@vger.kernel.org
Subject: Re: [BUG, bisect] i2c: designware: Move common probe code into i2c_dw_probe()
Date: Tue, 03 Nov 2015 09:28:55 +0200	[thread overview]
Message-ID: <56386237.9080904@linux.intel.com> (raw)
In-Reply-To: <20151103040216.GA2843@newt.localdomain>

Hi

On 03.11.2015 06:02, Jeremiah Mahler wrote:
> Jarkko, all,
>
> Commit d80d134182ba5 introduced a bug which causes a cyapa based touch
> pad on an Acer C720 Chromebook to become inoperative.  This is present
> in the latest linux-next (20151101).  The patch description is repeated
> below.
>
>    From d80d134182ba536ececab8d5fca50d779befc9a6 Mon Sep 17 00:00:00 2001
>    From: Jarkko Nikula <jarkko.nikula@linux.intel.com>
>    Date: Mon, 12 Oct 2015 16:55:35 +0300
>    Subject: [PATCH] i2c: designware: Move common probe code into i2c_dw_probe()
>
>    There is some code duplication in i2c-designware-platdrv and
>    i2c-designware-pcidrv probe functions. What is even worse that duplication
>    requires i2c_dw_xfer(), i2c_dw_func() and i2c_dw_isr() i2c-designware-core
>    functions to be exported.
>
>    Therefore move common code into new i2c_dw_probe() and make functions above
>    local to i2c-designware-core.
>
>    While merging the code patch does following functional changes:
>
>    - I2C Adapter name will be "Synopsys DesignWare I2C adapter". Previously it
>      was used for platform and ACPI devices but PCI device used
>      "i2c-designware-pci".
>    - Using device name for interrupt name. Previous it was platform device name,
>      ACPI device name or "i2c-designware-pci".
>    - Error code from devm_request_irq() and i2c_add_numbered_adapter() will be
>      printed in case of error.
>
>    Signed-off-by: Jarkko Nikula <jarkko.nikula@linux.intel.com>
>    Signed-off-by: Wolfram Sang <wsa@the-dreams.de>
>    ---
>     drivers/i2c/busses/i2c-designware-core.c    | 49 +++++++++++++++++++++++++----
>     drivers/i2c/busses/i2c-designware-core.h    |  5 +--
>     drivers/i2c/busses/i2c-designware-pcidrv.c  | 30 ++----------------
>     drivers/i2c/busses/i2c-designware-platdrv.c | 28 ++---------------
>     4 files changed, 49 insertions(+), 63 deletions(-)
>
Oh, I didn't notice adapter name was used 
drivers/platform/chrome/chromeos_laptop.c. Could you try does a patch 
below help?

============================ CUT HERE ============================
diff --git a/drivers/platform/chrome/chromeos_laptop.c 
b/drivers/platform/chrome/chromeos_laptop.c
index 02072749fff3..2b441e9ae593 100644
--- a/drivers/platform/chrome/chromeos_laptop.c
+++ b/drivers/platform/chrome/chromeos_laptop.c
@@ -47,8 +47,8 @@ static const char *i2c_adapter_names[] = {
  	"SMBus I801 adapter",
  	"i915 gmbus vga",
  	"i915 gmbus panel",
-	"i2c-designware-pci",
-	"i2c-designware-pci",
+	"Synopsys DesignWare I2C adapter",
+	"Synopsys DesignWare I2C adapter",
  };

  /* Keep this enum consistent with i2c_adapter_names */
============================ CUT HERE ============================

-- 
Jarkko

  reply	other threads:[~2015-11-03  7:29 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-11-03  4:02 Jeremiah Mahler
2015-11-03  7:28 ` Jarkko Nikula [this message]
2015-11-03 18:15   ` Jeremiah Mahler

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=56386237.9080904@linux.intel.com \
    --to=jarkko.nikula@linux.intel.com \
    --cc=dudl@cypress.com \
    --cc=jmmahler@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mika.westerberg@linux.intel.com \
    --cc=wsa@the-dreams.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome