mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Wei Ni <wni@nvidia.com>
To: Thierry Reding <thierry.reding@gmail.com>
Cc: <rui.zhang@intel.com>, <mikko.perttunen@kapsi.fi>,
	<swarren@wwwdotorg.org>, <linux-tegra@vger.kernel.org>,
	<linux-kernel@vger.kernel.org>
Subject: Re: [PATCH V1 04/10] thermal: tegra: add T210-specific SOC_THERM driver
Date: Thu, 14 Jan 2016 18:18:52 +0800	[thread overview]
Message-ID: <5697760C.1000901@nvidia.com> (raw)
In-Reply-To: <20160113150656.GD2588@ulmo>



On 2016年01月13日 23:06, Thierry Reding wrote:
> * PGP Signed by an unknown key
> 
> On Wed, Jan 13, 2016 at 03:58:43PM +0800, Wei Ni wrote:
> [...]
>> diff --git a/drivers/thermal/tegra/tegra_soctherm_fuse.c b/drivers/thermal/tegra/tegra_soctherm_fuse.c
>> index 7c608698f1ae..22f402240672 100644
>> --- a/drivers/thermal/tegra/tegra_soctherm_fuse.c
>> +++ b/drivers/thermal/tegra/tegra_soctherm_fuse.c
>> @@ -28,6 +28,17 @@
>>  #define FUSE_TSENSOR_COMMON			0x180
>>  
>>  /*
>> + * T210: Layout of bits in FUSE_TSENSOR_COMMON:
>> + *    3                   2                   1                   0
>> + *  1 0 9 8 7 6 5 4 3 2 1 0 9 8 7 6 5 4 3 2 1 0 9 8 7 6 5 4 3 2 1 0
>> + * +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>> + * |       BASE_FT       |      BASE_CP      | SHFT_FT | SHIFT_CP  |
>> + * +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>> + *
>> + * In chips prior to T210, this fuse was incorrectly sized as 26 bits,
>> + * and didn't hold SHIFT_CP in [31:26]. Therefore these missing six bits
> 
> The above diagram aso doesn't contain SHIFT_CP in bits [31:26] but
> rather in bits [5:0]. Which one is correct: the text or the diagram?

Hmm, sorry for the confusion. The diagram is for Tegra210, and the text is used
to explain why the Tegra124 would use the FUSE_SPARE_REALIGNMENT_REG.
For Tegra210, the FUSE_TSENSOR_COMMON contain four values, including SHIFT_CP in
the bits of [5:0]
But for Tegra124, the FUSE_TSENSOR_COMMON only contain three values, the
SHIFT_CP is in the FUSE_SPARE_REALIGNMENT_REG which didn't be used in Tegra210.
I will move the text under the line of "* T12x, etc: FUSE_TSENSOR_COMMON:", so
that it will be more readable.

> 
> Thierry
> 
> * Unknown Key
> * 0x7F3EB3A1
> 

      reply	other threads:[~2016-01-14 10:18 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-01-13  7:58 [PATCH V1 00/10] Add T210 support in tegra_soctherm Wei Ni
2016-01-13  7:58 ` [PATCH V1 01/10] thermal: tegra: move tegra thermal files into tegra directory Wei Ni
2016-01-13 14:24   ` Thierry Reding
2016-01-14  5:33     ` Wei Ni
2016-01-13  7:58 ` [PATCH V1 02/10] thermal: tegra: combine sensor group-related data Wei Ni
2016-01-13 14:31   ` Thierry Reding
2016-01-14  5:40     ` Wei Ni
2016-01-13  7:58 ` [PATCH V1 03/10] thermal: tegra: split tegra_soctherm driver Wei Ni
2016-01-13 15:04   ` Thierry Reding
2016-01-14  9:54     ` Wei Ni
2016-01-13  7:58 ` [PATCH V1 04/10] thermal: tegra: add T210-specific SOC_THERM driver Wei Ni
2016-01-13 15:06   ` Thierry Reding
2016-01-14 10:18     ` Wei Ni [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=5697760C.1000901@nvidia.com \
    --to=wni@nvidia.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-tegra@vger.kernel.org \
    --cc=mikko.perttunen@kapsi.fi \
    --cc=rui.zhang@intel.com \
    --cc=swarren@wwwdotorg.org \
    --cc=thierry.reding@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome