From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751959AbcCNQbV (ORCPT ); Mon, 14 Mar 2016 12:31:21 -0400 Received: from avon.wwwdotorg.org ([70.85.31.133]:56014 "EHLO avon.wwwdotorg.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751123AbcCNQbT (ORCPT ); Mon, 14 Mar 2016 12:31:19 -0400 Subject: Re: [PATCH V2 4/5] gpio: DT: Rephrase "gpios" of hog node to support multiple gpios To: Laxman Dewangan References: <1457703804-3016-1-git-send-email-ldewangan@nvidia.com> <1457703804-3016-5-git-send-email-ldewangan@nvidia.com> Cc: linus.walleij@linaro.org, robh+dt@kernel.org, pawel.moll@arm.com, mark.rutland@arm.com, mpa@pengutronix.de, treding@nvidia.com, bparrot@ti.com, acourbot@nvidia.com, devicetree@vger.kernel.org, linux-kernel@vger.kernel.org From: Stephen Warren Message-ID: <56E6E753.1020505@wwwdotorg.org> Date: Mon, 14 Mar 2016 10:31:15 -0600 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.6.0 MIME-Version: 1.0 In-Reply-To: <1457703804-3016-5-git-send-email-ldewangan@nvidia.com> Content-Type: text/plain; charset=windows-1252; format=flowed Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 03/11/2016 06:43 AM, Laxman Dewangan wrote: > The property "gpios" of GPIO hog node support the multiple GPIO entries. > Rephrase the details of this property for this new support. > > Add details of new property "label" for GPIO label name. > diff --git a/Documentation/devicetree/bindings/gpio/gpio.txt b/Documentation/devicetree/bindings/gpio/gpio.txt > Optional properties: > - line-name: The GPIO label name. If not present the node name is used. > +- label: The GPIO lable name. This can have multiple string for GPIO > + label names to match with the GPIOs in "gpios" properties. > + If line-name is prosent than name is taken from line-name. If > + it is not then the name will be taken from label. If both are > + not available then node name is used for GPIO label name. Why are there two properties for the same thing? Why not just allow line-name to have multiple entries instead of introducing a new property?