From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from smtp.kernel.org (aws-us-west-2-korg-mail-1.web.codeaurora.org [10.30.226.201]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 8A19F337B99; Mon, 2 Mar 2026 09:18:31 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=10.30.226.201 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1772443111; cv=none; b=Z8H5rw6l0W0fcUw40MZmq89K5+4bjDbFGy0cTnAGJk5SUeYl0hvzZrvXfhq4vqSv7jSzIXnqShM/dw/kbFUxh47a7P+xxORy55ju70KuvVB8U6UeSUpb1R3Tg3KlcPqE1QuDoRcXYs8bNwp7Ih/L8X5/hUd4fPa687fic4hW0lA= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1772443111; c=relaxed/simple; bh=Hx6ptSB6ZFmCX4cO/KP1aDbPdSw6QQy9NbWFTmrXi+c=; h=Message-ID:Date:MIME-Version:Subject:To:Cc:References:From: In-Reply-To:Content-Type; b=dKAi8rmGjvzPpb6yv5LiE3KvCK2MLTMtW5OS8w+JH4BrN/p0hWE1rA+U1dKjNckQ9o/+HlcqnRjhfhl5DB/rjpES3bOO+gvxfaep5yzerG/rmfdA3TUTLcCMXdW8z6fiQ30qj5/thC8A8qc4e0bBxXFwOiR6XDL2cucnyDeCNgU= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b=f63X9Zu7; arc=none smtp.client-ip=10.30.226.201 Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b="f63X9Zu7" Received: by smtp.kernel.org (Postfix) with ESMTPSA id 2D805C2BC87; Mon, 2 Mar 2026 09:18:24 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=kernel.org; s=k20201202; t=1772443111; bh=Hx6ptSB6ZFmCX4cO/KP1aDbPdSw6QQy9NbWFTmrXi+c=; h=Date:Subject:To:Cc:References:From:In-Reply-To:From; b=f63X9Zu7YNmXyMUaTAFvqbxzoJkekuYETpxFg3R8skFFkLnvP8TImGjjrNDIKxr1u kRhEOHtLl62VFYWV+au5yuJFevSsPvOgEHfOxRFzDOpyR5L9pxLiAAQzO5mKK4i9vM 28yPxhXdRxpdvk7oBCvxAacSFjaKg0TsBx+xJ9KtR0cANeaHZQhepTgNJ2O97ZF10T LpA5xIevqOgnXSdDw8VwUON3/R2HMj2UewnkoFpWCXKzZJiU7vEoDv7PUWw3znKZR0 Q2mSkamufWZlZK2r6UnhfvKh+UvDzYOna3GGaMLY8DEUTqjWOrIehGx3p2HcCeLFZa e9A5Jmr1iF/bQ== Message-ID: <571547b0-007a-4cf9-be1d-95a0ef871cf8@kernel.org> Date: Mon, 2 Mar 2026 10:18:23 +0100 Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 User-Agent: Mozilla Thunderbird Subject: Re: [PATCH v1 4/4] page_reporting: change PAGE_REPORTING_DEFAULT_ORDER to -1 To: Yuvraj Sakshith , Michael Kelley Cc: "akpm@linux-foundation.org" , "mst@redhat.com" , "kys@microsoft.com" , "haiyangz@microsoft.com" , "wei.liu@kernel.org" , "decui@microsoft.com" , "longli@microsoft.com" , "jasowang@redhat.com" , "xuanzhuo@linux.alibaba.com" , "eperezma@redhat.com" , "lorenzo.stoakes@oracle.com" , "Liam.Howlett@oracle.com" , "vbabka@suse.cz" , "rppt@kernel.org" , "surenb@google.com" , "mhocko@suse.com" , "jackmanb@google.com" , "hannes@cmpxchg.org" , "ziy@nvidia.com" , "linux-hyperv@vger.kernel.org" , "virtualization@lists.linux.dev" , "linux-mm@kvack.org" , "linux-kernel@vger.kernel.org" References: <20260227140655.360696-1-yuvraj.sakshith@oss.qualcomm.com> <20260227140655.360696-5-yuvraj.sakshith@oss.qualcomm.com> From: "David Hildenbrand (Arm)" Content-Language: en-US Autocrypt: addr=david@kernel.org; keydata= xsFNBFXLn5EBEAC+zYvAFJxCBY9Tr1xZgcESmxVNI/0ffzE/ZQOiHJl6mGkmA1R7/uUpiCjJ dBrn+lhhOYjjNefFQou6478faXE6o2AhmebqT4KiQoUQFV4R7y1KMEKoSyy8hQaK1umALTdL QZLQMzNE74ap+GDK0wnacPQFpcG1AE9RMq3aeErY5tujekBS32jfC/7AnH7I0v1v1TbbK3Gp XNeiN4QroO+5qaSr0ID2sz5jtBLRb15RMre27E1ImpaIv2Jw8NJgW0k/D1RyKCwaTsgRdwuK Kx/Y91XuSBdz0uOyU/S8kM1+ag0wvsGlpBVxRR/xw/E8M7TEwuCZQArqqTCmkG6HGcXFT0V9 PXFNNgV5jXMQRwU0O/ztJIQqsE5LsUomE//bLwzj9IVsaQpKDqW6TAPjcdBDPLHvriq7kGjt WhVhdl0qEYB8lkBEU7V2Yb+SYhmhpDrti9Fq1EsmhiHSkxJcGREoMK/63r9WLZYI3+4W2rAc UucZa4OT27U5ZISjNg3Ev0rxU5UH2/pT4wJCfxwocmqaRr6UYmrtZmND89X0KigoFD/XSeVv jwBRNjPAubK9/k5NoRrYqztM9W6sJqrH8+UWZ1Idd/DdmogJh0gNC0+N42Za9yBRURfIdKSb B3JfpUqcWwE7vUaYrHG1nw54pLUoPG6sAA7Mehl3nd4pZUALHwARAQABzS5EYXZpZCBIaWxk ZW5icmFuZCAoQ3VycmVudCkgPGRhdmlkQGtlcm5lbC5vcmc+wsGQBBMBCAA6AhsDBQkmWAik AgsJBBUKCQgCFgICHgUCF4AWIQQb2cqtc1xMOkYN/MpN3hD3AP+DWgUCaYJt/AIZAQAKCRBN 3hD3AP+DWriiD/9BLGEKG+N8L2AXhikJg6YmXom9ytRwPqDgpHpVg2xdhopoWdMRXjzOrIKD g4LSnFaKneQD0hZhoArEeamG5tyo32xoRsPwkbpIzL0OKSZ8G6mVbFGpjmyDLQCAxteXCLXz ZI0VbsuJKelYnKcXWOIndOrNRvE5eoOfTt2XfBnAapxMYY2IsV+qaUXlO63GgfIOg8RBaj7x 3NxkI3rV0SHhI4GU9K6jCvGghxeS1QX6L/XI9mfAYaIwGy5B68kF26piAVYv/QZDEVIpo3t7 /fjSpxKT8plJH6rhhR0epy8dWRHk3qT5tk2P85twasdloWtkMZ7FsCJRKWscm1BLpsDn6EQ4 jeMHECiY9kGKKi8dQpv3FRyo2QApZ49NNDbwcR0ZndK0XFo15iH708H5Qja/8TuXCwnPWAcJ DQoNIDFyaxe26Rx3ZwUkRALa3iPcVjE0//TrQ4KnFf+lMBSrS33xDDBfevW9+Dk6IISmDH1R HFq2jpkN+FX/PE8eVhV68B2DsAPZ5rUwyCKUXPTJ/irrCCmAAb5Jpv11S7hUSpqtM/6oVESC 3z/7CzrVtRODzLtNgV4r5EI+wAv/3PgJLlMwgJM90Fb3CB2IgbxhjvmB1WNdvXACVydx55V7 LPPKodSTF29rlnQAf9HLgCphuuSrrPn5VQDaYZl4N/7zc2wcWM7BTQRVy5+RARAA59fefSDR 9nMGCb9LbMX+TFAoIQo/wgP5XPyzLYakO+94GrgfZjfhdaxPXMsl2+o8jhp/hlIzG56taNdt VZtPp3ih1AgbR8rHgXw1xwOpuAd5lE1qNd54ndHuADO9a9A0vPimIes78Hi1/yy+ZEEvRkHk /kDa6F3AtTc1m4rbbOk2fiKzzsE9YXweFjQvl9p+AMw6qd/iC4lUk9g0+FQXNdRs+o4o6Qvy iOQJfGQ4UcBuOy1IrkJrd8qq5jet1fcM2j4QvsW8CLDWZS1L7kZ5gT5EycMKxUWb8LuRjxzZ 3QY1aQH2kkzn6acigU3HLtgFyV1gBNV44ehjgvJpRY2cC8VhanTx0dZ9mj1YKIky5N+C0f21 zvntBqcxV0+3p8MrxRRcgEtDZNav+xAoT3G0W4SahAaUTWXpsZoOecwtxi74CyneQNPTDjNg azHmvpdBVEfj7k3p4dmJp5i0U66Onmf6mMFpArvBRSMOKU9DlAzMi4IvhiNWjKVaIE2Se9BY FdKVAJaZq85P2y20ZBd08ILnKcj7XKZkLU5FkoA0udEBvQ0f9QLNyyy3DZMCQWcwRuj1m73D sq8DEFBdZ5eEkj1dCyx+t/ga6x2rHyc8Sl86oK1tvAkwBNsfKou3v+jP/l14a7DGBvrmlYjO 59o3t6inu6H7pt7OL6u6BQj7DoMAEQEAAcLBfAQYAQgAJgIbDBYhBBvZyq1zXEw6Rg38yk3e EPcA/4NaBQJonNqrBQkmWAihAAoJEE3eEPcA/4NaKtMQALAJ8PzprBEXbXcEXwDKQu+P/vts IfUb1UNMfMV76BicGa5NCZnJNQASDP/+bFg6O3gx5NbhHHPeaWz/VxlOmYHokHodOvtL0WCC 8A5PEP8tOk6029Z+J+xUcMrJClNVFpzVvOpb1lCbhjwAV465Hy+NUSbbUiRxdzNQtLtgZzOV Zw7jxUCs4UUZLQTCuBpFgb15bBxYZ/BL9MbzxPxvfUQIPbnzQMcqtpUs21CMK2PdfCh5c4gS sDci6D5/ZIBw94UQWmGpM/O1ilGXde2ZzzGYl64glmccD8e87OnEgKnH3FbnJnT4iJchtSvx yJNi1+t0+qDti4m88+/9IuPqCKb6Stl+s2dnLtJNrjXBGJtsQG/sRpqsJz5x1/2nPJSRMsx9 5YfqbdrJSOFXDzZ8/r82HgQEtUvlSXNaXCa95ez0UkOG7+bDm2b3s0XahBQeLVCH0mw3RAQg r7xDAYKIrAwfHHmMTnBQDPJwVqxJjVNr7yBic4yfzVWGCGNE4DnOW0vcIeoyhy9vnIa3w1uZ 3iyY2Nsd7JxfKu1PRhCGwXzRw5TlfEsoRI7V9A8isUCoqE2Dzh3FvYHVeX4Us+bRL/oqareJ CIFqgYMyvHj7Q06kTKmauOe4Nf0l0qEkIuIzfoLJ3qr5UyXc2hLtWyT9Ir+lYlX9efqh7mOY qIws/H2t In-Reply-To: Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 7bit On 3/2/26 09:54, Yuvraj Sakshith wrote: > On Mon, Mar 02, 2026 at 09:09:13AM +0100, David Hildenbrand (Arm) wrote: >> On 3/2/26 09:00, Yuvraj Sakshith wrote: >>> Option 1: >>> >>> if (page_reporting_order == PAGE_REPORTING_DEFAULT_ORDER) { >>> if (page_reporting_order != PAGE_REPORTING_DEFAULT_ORDER >>> && prdev->order <= MAX_PAGE_ORDER) { >>> page_reporting_order = prdev->order; >>> } else { >>> page_reporting_order = pageblock_order; >>> } >>> } >>> >>> Option 2: >>> >>> if (page_reporting_order == PAGE_REPORTING_ORDER_NOT_SET) { >>> if (page_reporting_order != PAGE_REPORTING_DEFAULT_ORDER >>> && prdev->order <= MAX_PAGE_ORDER) { >>> page_reporting_order = prdev->order; >>> } else { >>> page_reporting_order = pageblock_order; >>> } >>> } >>> >>> >>> >>> Agreed. >>> >>> If we were to read this code without context, wouldn't it be confusing as to >>> why PAGE_REPORTING_DEFAULT_ORDER is being checked in the first place? >> >> I proposed in one of the last mail that >> "PAGE_REPORTING_USE_DEFAULT_ORDER" could be clearer, stating that it's >> not really an order just yet. Maybe just using >> PAGE_REPORTING_ORDER_UNSET might be clearer. >> > Ok >>> >>> Option 1 checks if page_reporting_order is equal to PAGE_REPORTING_DEFAULT_ORDER >>> and then immediately checks if its not equal to it. Which is a bit confusing.. >> >> >> Because it's wrong? :) We're not supposed to check page_reporting_order >> a second time. Assume we >> s/PAGE_REPORTING_ORDER/PAGE_REPORTING_ORDER_UNSET/ and actually check >> prdev->order: > Oops, typo :) I meant prdev->order. >> >> if (page_reporting_order == PAGE_REPORTING_ORDER_UNSET) { >> if (prdev->order != PAGE_REPORTING_ORDER_UNSET && >> prdev->order <= MAX_PAGE_ORDER) { >> page_reporting_order = prdev->order; >> } else { >> page_reporting_order = pageblock_order; >> } >> } >> > Great. Much more clearer on page_reporting.c 's end. > > Don't you think on the driver's end: > > prdev->order = PAGE_REPORTING_USE_DEFAULT; looks clearer? As compared to: > prdev->order = PAGE_REPORTING_ORDER_UNSET; ? > > I'm thinking, why would a driver worry about page_reporting_order being set/unset? Maybe PAGE_REPORTING_ORDER_UNSPECIFIED ? In any case, we should use a single flag for this. Everything else will be confusing once drivers could use only one of them. -- Cheers, David