From: Roger Quadros <rogerq@ti.com>
To: Jun Li <jun.li@nxp.com>,
"stern@rowland.harvard.edu" <stern@rowland.harvard.edu>,
"balbi@kernel.org" <balbi@kernel.org>,
"gregkh@linuxfoundation.org" <gregkh@linuxfoundation.org>,
"peter.chen@freescale.com" <peter.chen@freescale.com>
Cc: "dan.j.williams@intel.com" <dan.j.williams@intel.com>,
"jun.li@freescale.com" <jun.li@freescale.com>,
"mathias.nyman@linux.intel.com" <mathias.nyman@linux.intel.com>,
"tony@atomide.com" <tony@atomide.com>,
"Joao.Pinto@synopsys.com" <Joao.Pinto@synopsys.com>,
"abrestic@chromium.org" <abrestic@chromium.org>,
"r.baldyga@samsung.com" <r.baldyga@samsung.com>,
"linux-usb@vger.kernel.org" <linux-usb@vger.kernel.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"linux-omap@vger.kernel.org" <linux-omap@vger.kernel.org>
Subject: Re: [PATCH v6 09/12] usb: gadget: udc: adapt to OTG core
Date: Thu, 28 Apr 2016 12:54:45 +0300 [thread overview]
Message-ID: <5721DDE5.7060708@ti.com> (raw)
In-Reply-To: <5720A106.1030702@ti.com>
Hi,
On 27/04/16 14:22, Roger Quadros wrote:
> On 26/04/16 03:07, Jun Li wrote:
>> Hi
>>
>>> -----Original Message-----
>>> From: Roger Quadros [mailto:rogerq@ti.com]
>>> Sent: Monday, April 25, 2016 10:04 PM
>>> To: Jun Li <jun.li@nxp.com>; stern@rowland.harvard.edu; balbi@kernel.org;
>>> gregkh@linuxfoundation.org; peter.chen@freescale.com
>>> Cc: dan.j.williams@intel.com; jun.li@freescale.com;
>>> mathias.nyman@linux.intel.com; tony@atomide.com; Joao.Pinto@synopsys.com;
>>> abrestic@chromium.org; r.baldyga@samsung.com; linux-usb@vger.kernel.org;
>>> linux-kernel@vger.kernel.org; linux-omap@vger.kernel.org
>>> Subject: Re: [PATCH v6 09/12] usb: gadget: udc: adapt to OTG core
>>>
>>> Hi,
>>>
>>> On 21/04/16 09:38, Jun Li wrote:
>>>> Hi,
>>>>
>>>> ...
>>>>>
>>>>> /**
>>>>> + * usb_gadget_start - start the usb gadget controller and connect to
>>>>> +bus
>>>>> + * @gadget: the gadget device to start
>>>>> + *
>>>>> + * This is external API for use by OTG core.
>>>>> + *
>>>>> + * Start the usb device controller and connect to bus (enable pull).
>>>>> + */
>>>>> +static int usb_gadget_start(struct usb_gadget *gadget) {
>>>>> + int ret;
>>>>> + struct usb_udc *udc = NULL;
>>>>> +
>>>>> + dev_dbg(&gadget->dev, "%s\n", __func__);
>>>>> + mutex_lock(&udc_lock);
>>>>> + list_for_each_entry(udc, &udc_list, list)
>>>>> + if (udc->gadget == gadget)
>>>>> + goto found;
>>>>> +
>>>>> + dev_err(gadget->dev.parent, "%s: gadget not registered.\n",
>>>>> + __func__);
>>>>> + mutex_unlock(&udc_lock);
>>>>> + return -EINVAL;
>>>>> +
>>>>> +found:
>>>>> + ret = usb_gadget_udc_start(udc);
>>>>> + if (ret)
>>>>> + dev_err(&udc->dev, "USB Device Controller didn't start: %d\n",
>>>>> + ret);
>>>>> + else
>>>>> + usb_udc_connect_control(udc);
>>>>
>>>> For drd, it's fine, but for real otg, gadget connect should be done by
>>>> loc_conn() instead of gadget start.
>>>
>>> It is upto the OTG state machine to call gadget_start() when it needs to
>>> connect to the bus (i.e. loc_conn()). I see no point in calling gadget
>>> start before.
>>>
>>> Do you see any issue in doing so?
>>
>> This is what OTG state machine does:
>> case OTG_STATE_B_PERIPHERAL:
>> otg_chrg_vbus(otg, 0);
>> otg_loc_sof(otg, 0);
>> otg_set_protocol(fsm, PROTO_GADGET);
>> otg_loc_conn(otg, 1);
>> break;
On second thoughts, after seen the OTG state machine.
otg_set_protocol(fsm, PROTO_GADGET); is always followed by otg_loc_conn(otg, 1);
And whenever protocol changes to anything other the PROTO_GADGET, we use
otg_loc_conn(otg, 0);
So otg_loc_conn seems redundant. Can we just get rid of it?
usb_gadget_start() implies that gadget controller starts up and enables pull.
usb_gadget_stop() implies that gadget controller disables pull and stops.
Can you please explain why just these 2 APIs are not sufficient for full OTG?
Do we want anything to happen between gadget controller start/stop and
pull on/off?
cheers,
-roger
>>
>> You intend to abstract something common in this api when start gadget,
>> which should be called by otg_set_protocol(fsm, PROTO_GADGET); and
>> drd_set_protocol(fsm, PROTO_GADGET); right?
>>
>> So you may move usb_udc_connect_control(IMO usb_gadget_connect()
>> is better)out of usb_gadget_start(), then for drd:
>>
>> case OTG_STATE_B_PERIPHERAL:
>> drd_set_protocol(fsm, PROTO_GADGET);
>> otg_drv_vbus(otg, 0);
>> usb_gadget_connect();
>
> OK. I understand now. I'll implement your suggestion. Thanks.
>
> cheers,
> -roger
>
>>>>
>>>>> +
>>>>> + mutex_unlock(&udc_lock);
>>>>> +
>>>>> + return ret;
>>>>> +}
>>>>> +
>>>>> +/**
>>>>> + * usb_gadget_stop - disconnect from bus and stop the usb gadget
>>>>> + * @gadget: The gadget device we want to stop
>>>>> + *
>>>>> + * This is external API for use by OTG core.
>>>>> + *
>>>>> + * Disconnect from the bus (disable pull) and stop the
>>>>> + * gadget controller.
>>>>> + */
>>>>> +static int usb_gadget_stop(struct usb_gadget *gadget) {
>>>>> + struct usb_udc *udc = NULL;
>>>>> +
>>>>> + dev_dbg(&gadget->dev, "%s\n", __func__);
>>>>> + mutex_lock(&udc_lock);
>>>>> + list_for_each_entry(udc, &udc_list, list)
>>>>> + if (udc->gadget == gadget)
>>>>> + goto found;
>>>>> +
>>>>> + dev_err(gadget->dev.parent, "%s: gadget not registered.\n",
>>>>> + __func__);
>>>>> + mutex_unlock(&udc_lock);
>>>>> + return -EINVAL;
>>>>> +
>>>>> +found:
>>>>> + usb_gadget_disconnect(udc->gadget);
>>>>
>>>> Likewise, gadget disconnect also should be done by loc_conn() instead
>>>> of gadget stop.
>>>>
>>>>> + udc->driver->disconnect(udc->gadget);
>>>>> + usb_gadget_udc_stop(udc);
>>>>> + mutex_unlock(&udc_lock);
>>>>> +
>>>>> + return 0;
>>>>> +}
>>>>> +
>>>>
>>>> Li Jun
>>>>
> --
> To unsubscribe from this list: send the line "unsubscribe linux-usb" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at http://vger.kernel.org/majordomo-info.html
>
next prev parent reply other threads:[~2016-04-28 9:55 UTC|newest]
Thread overview: 100+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-04-05 14:05 [PATCH v6 00/12] USB OTG/dual-role framework Roger Quadros
2016-04-05 14:05 ` [PATCH v6 01/12] usb: hcd: Initialize hcd->flags to 0 Roger Quadros
2016-04-06 6:09 ` Felipe Balbi
2016-04-06 6:32 ` Roger Quadros
2016-04-07 9:42 ` Peter Chen
2016-04-07 10:40 ` Roger Quadros
2016-04-08 1:01 ` Peter Chen
2016-04-08 7:16 ` Roger Quadros
2016-04-08 7:45 ` Peter Chen
2016-04-18 2:29 ` Peter Chen
2016-04-18 14:11 ` Alan Stern
2016-04-19 1:56 ` Peter Chen
2016-04-20 8:15 ` Roger Quadros
2016-04-20 9:40 ` Peter Chen
2016-04-05 14:05 ` [PATCH v6 02/12] usb: hcd.h: Add OTG to HCD interface Roger Quadros
2016-04-18 7:41 ` Peter Chen
2016-04-05 14:05 ` [PATCH v6 03/12] usb: otg-fsm: use usb_otg wherever possible Roger Quadros
2016-04-18 7:42 ` Peter Chen
2016-04-05 14:05 ` [PATCH v6 04/12] usb: otg-fsm: move host controller operations into usb_otg->hcd_ops Roger Quadros
2016-04-18 8:00 ` Peter Chen
2016-04-05 14:05 ` [PATCH v6 05/12] usb: gadget.h: Add OTG to gadget interface Roger Quadros
2016-04-05 14:05 ` [PATCH v6 06/12] usb: otg: get rid of CONFIG_USB_OTG_FSM in favour of CONFIG_USB_OTG Roger Quadros
2016-04-18 8:05 ` Peter Chen
2016-04-20 8:12 ` Roger Quadros
2016-04-05 14:05 ` [PATCH v6 07/12] usb: otg: add OTG/dual-role core Roger Quadros
2016-04-07 8:52 ` Yoshihiro Shimoda
2016-04-07 11:45 ` Roger Quadros
2016-04-08 11:22 ` Yoshihiro Shimoda
2016-04-11 10:54 ` Roger Quadros
2016-04-14 8:36 ` Yoshihiro Shimoda
2016-04-14 10:59 ` Roger Quadros
2016-04-14 11:15 ` Yoshihiro Shimoda
2016-04-14 11:32 ` Roger Quadros
2016-04-15 9:59 ` Yoshihiro Shimoda
2016-04-15 10:57 ` Roger Quadros
2016-04-15 10:03 ` Yoshihiro Shimoda
2016-04-19 9:18 ` Peter Chen
2016-04-20 5:08 ` Yoshihiro Shimoda
2016-04-20 7:03 ` Roger Quadros
2016-04-22 6:05 ` Peter Chen
2016-04-22 1:26 ` Peter Chen
2016-04-22 3:34 ` Peter Chen
2016-04-22 5:57 ` Yoshihiro Shimoda
2016-04-15 9:25 ` Peter Chen
2016-04-15 11:00 ` Roger Quadros
2016-04-18 2:09 ` Peter Chen
2016-04-20 6:54 ` Roger Quadros
2016-04-20 9:26 ` Peter Chen
2016-04-19 8:06 ` Peter Chen
2016-04-20 7:02 ` Roger Quadros
2016-04-20 9:39 ` Peter Chen
2016-04-21 6:52 ` Peter Chen
2016-04-25 14:05 ` Roger Quadros
2016-04-26 2:07 ` Jun Li
2016-04-26 3:47 ` Peter Chen
2016-04-26 5:11 ` Jun Li
2016-04-26 6:28 ` Peter Chen
2016-04-26 7:00 ` Jun Li
2016-04-26 8:21 ` Peter Chen
2016-04-27 3:15 ` Peter Chen
2016-04-27 10:59 ` Roger Quadros
2016-04-28 1:54 ` Peter Chen
2016-04-28 8:01 ` Roger Quadros
2016-04-27 11:15 ` Roger Quadros
2016-04-05 14:05 ` [PATCH v6 08/12] usb: hcd: Adapt to OTG core Roger Quadros
2016-04-18 6:29 ` Peter Chen
2016-04-19 8:14 ` Peter Chen
2016-04-20 6:47 ` Roger Quadros
2016-04-20 6:46 ` Roger Quadros
2016-04-27 10:16 ` Jun Li
2016-04-27 11:00 ` Roger Quadros
2016-04-27 11:11 ` Roger Quadros
2016-04-27 12:49 ` Jun Li
2016-04-27 13:18 ` Jun Li
2016-04-05 14:05 ` [PATCH v6 09/12] usb: gadget: udc: adapt " Roger Quadros
2016-04-18 6:59 ` Peter Chen
2016-04-20 6:51 ` Roger Quadros
2016-04-21 6:38 ` Jun Li
2016-04-25 14:04 ` Roger Quadros
2016-04-26 0:07 ` Jun Li
2016-04-27 11:22 ` Roger Quadros
2016-04-28 9:54 ` Roger Quadros [this message]
2016-04-28 10:23 ` Jun Li
2016-04-28 12:22 ` Roger Quadros
2016-05-03 7:06 ` Jun Li
2016-05-03 15:44 ` Roger Quadros
2016-05-04 1:47 ` Peter Chen
2016-05-04 3:35 ` Peter Chen
2016-05-04 6:37 ` Roger Quadros
2016-05-04 7:53 ` Peter Chen
2016-05-04 8:03 ` Jun Li
2016-05-04 8:40 ` Roger Quadros
2016-05-04 8:39 ` Peter Chen
2016-04-05 14:05 ` [PATCH v6 10/12] usb: doc: dt-binding: Add otg-controller property Roger Quadros
2016-04-05 14:05 ` [PATCH v6 11/12] usb: core: hub: Notify OTG fsm when A device sets b_hnp_enable Roger Quadros
2016-04-18 7:08 ` Peter Chen
2016-04-27 14:35 ` Roger Quadros
2016-04-05 14:05 ` [PATCH v6 12/12] usb: host: xhci-plat: Add otg device to platform data Roger Quadros
2016-04-06 3:23 ` Yoshihiro Shimoda
2016-04-06 6:30 ` Roger Quadros
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=5721DDE5.7060708@ti.com \
--to=rogerq@ti.com \
--cc=Joao.Pinto@synopsys.com \
--cc=abrestic@chromium.org \
--cc=balbi@kernel.org \
--cc=dan.j.williams@intel.com \
--cc=gregkh@linuxfoundation.org \
--cc=jun.li@freescale.com \
--cc=jun.li@nxp.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-omap@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=mathias.nyman@linux.intel.com \
--cc=peter.chen@freescale.com \
--cc=r.baldyga@samsung.com \
--cc=stern@rowland.harvard.edu \
--cc=tony@atomide.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome