From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752173AbcF0LfI (ORCPT ); Mon, 27 Jun 2016 07:35:08 -0400 Received: from youngberry.canonical.com ([91.189.89.112]:51855 "EHLO youngberry.canonical.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752157AbcF0LfD (ORCPT ); Mon, 27 Jun 2016 07:35:03 -0400 Subject: Re: powerpc/fadump: trivial fix of spelling mistake, clean up message To: Michael Ellerman , Joe Perches , Benjamin Herrenschmidt , Paul Mackerras , Jiri Kosina , Rasmus Villemoes , Andrew Morton , linuxppc-dev@lists.ozlabs.org References: <3rcf3g63Wnz9s5Q@ozlabs.org> <5771021E.3050305@canonical.com> <1467024695.1847.87.camel@perches.com> <1467026427.29808.4.camel@ellerman.id.au> Cc: linux-kernel@vger.kernel.org From: Colin Ian King Message-ID: <57710F50.2070800@canonical.com> Date: Mon, 27 Jun 2016 12:34:40 +0100 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.8.0 MIME-Version: 1.0 In-Reply-To: <1467026427.29808.4.camel@ellerman.id.au> Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 27/06/16 12:20, Michael Ellerman wrote: > On Mon, 2016-06-27 at 03:51 -0700, Joe Perches wrote: >> On Mon, 2016-06-27 at 11:38 +0100, Colin Ian King wrote: >>> On 26/06/16 05:19, Michael Ellerman wrote: >>>> On Fri, 2016-24-06 at 17:43:00 UTC, Colin King wrote: >>>>> trivial fix to spelling mistake "rgistration" and minor clean up >>>>> of the printk error message >>>> Can you also: >>>> - use pr_err() >>>> - unsplit the message, ie. keep the string all on one line. >>> I can unsplit the string, but checkpatch will complain about that, so >>> I'm not sure if that's preferred or not. >>> >>> WARNING: line over 80 characters >> >> If the statement is wrapped after the format, >> then checkpatch shouldn't complain. >> >> pr_err("Failed to invalidate firmware-assisted dump registration. Unexpected error (%d).\n", >> rc); > > But that's not actually any more readable, so just ignore checkpatch in this > case IMHO. It's a guide, not the gospel. > > cheers > OK, so shall I'll send a V3 w/o the spit and the pr_err fix?