mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Luis de Bethencourt <luisbg@osg.samsung.com>
To: Salah Triki <salah.triki@gmail.com>,
	akpm@linux-foundation.org, viro@zeniv.linux.org.uk
Cc: mhocko@suse.com, vdavydov@virtuozzo.com,
	linux-fsdevel@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 6/6] fs: befs: remove ret variable
Date: Mon, 01 Aug 2016 15:23:43 +0100	[thread overview]
Message-ID: <579F5B6F.7000701@osg.samsung.com> (raw)
In-Reply-To: <b1b27c874e3ace9344d7827eece1d6cb9afd8a62.1469997250.git.salah.triki@gmail.com>

On 31/07/16 21:34, Salah Triki wrote:
> ret is initialized to -EIO and is never modified, so remove ret and use
> -EIO directly.
> 
> Signed-off-by: Salah Triki <salah.triki@gmail.com>
> ---
>  fs/befs/linuxvfs.c | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
> 
> diff --git a/fs/befs/linuxvfs.c b/fs/befs/linuxvfs.c
> index 2b68c81..c57f831 100644
> --- a/fs/befs/linuxvfs.c
> +++ b/fs/befs/linuxvfs.c
> @@ -300,7 +300,6 @@ static struct inode *befs_iget(struct super_block *sb, unsigned long ino)
>  	struct befs_sb_info *befs_sb = BEFS_SB(sb);
>  	struct befs_inode_info *befs_ino;
>  	struct inode *inode;
> -	long ret = -EIO;
>  
>  	befs_debug(sb, "---> %s inode = %lu", __func__, ino);
>  
> @@ -422,7 +421,7 @@ static struct inode *befs_iget(struct super_block *sb, unsigned long ino)
>        unacquire_none:
>  	iget_failed(inode);
>  	befs_debug(sb, "<--- %s - Bad inode", __func__);
> -	return ERR_PTR(ret);
> +	return ERR_PTR(-EIO);
>  }
>  
>  /* Initialize the inode cache. Called at fs setup.
> 

Hi Salah,

This one is a nice catch, since your patch also makes the code more readable.
No need to check the value of ret when you read that return ERR_PTR() anymore.

This has been this way since the introduction of ret in commit
96eb5419412fbc7f39fa45d987034c5d0e6e1202.
No need to add a "Fixes" tag in the commit message because that commit was 8
years ago.

Acked-by: Luis de Bethencourt <luisbg@osg.samsung.com>

Thanks :)
Luis

Pushed to the befs-next branch:
https://github.com/luisbg/linux-befs/tree/befs-next

  reply	other threads:[~2016-08-01 14:24 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-07-31 20:34 [PATCH 1/6] fs: befs: remove unneeded initialization to zero Salah Triki
2016-07-31 20:34 ` [PATCH 2/6] fs: befs: remove in vain variable assignment Salah Triki
2016-08-01 13:24   ` Luis de Bethencourt
2016-08-06 18:35     ` Salah Triki
2016-07-31 20:34 ` [PATCH 3/6] fs: befs: remove useless initialization to zero Salah Triki
2016-08-01 13:44   ` Luis de Bethencourt
2016-08-06 18:36     ` Salah Triki
2016-07-31 20:34 ` [PATCH 4/6] fs: befs: remove unnecessary *befs_sb variable Salah Triki
2016-08-01 14:02   ` Luis de Bethencourt
2016-08-06 18:37     ` Salah Triki
2016-07-31 20:34 ` [PATCH 5/6] fs: befs: remove in vain variable assignment Salah Triki
2016-08-01 14:17   ` Luis de Bethencourt
2016-07-31 20:34 ` [PATCH 6/6] fs: befs: remove ret variable Salah Triki
2016-08-01 14:23   ` Luis de Bethencourt [this message]
2016-08-01 12:51 ` [PATCH 1/6] fs: befs: remove unneeded initialization to zero Luis de Bethencourt

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=579F5B6F.7000701@osg.samsung.com \
    --to=luisbg@osg.samsung.com \
    --cc=akpm@linux-foundation.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mhocko@suse.com \
    --cc=salah.triki@gmail.com \
    --cc=vdavydov@virtuozzo.com \
    --cc=viro@zeniv.linux.org.uk \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome