From: Waiman Long <waiman.long@hpe.com>
To: Thomas Gleixner <tglx@linutronix.de>
Cc: Ingo Molnar <mingo@kernel.org>,
Peter Zijlstra <peterz@infradead.org>,
Jonathan Corbet <corbet@lwn.net>, <linux-kernel@vger.kernel.org>,
<linux-doc@vger.kernel.org>, Davidlohr Bueso <dave@stgolabs.net>,
Jason Low <jason.low2@hpe.com>,
Scott J Norton <scott.norton@hpe.com>,
Douglas Hatch <doug.hatch@hpe.com>
Subject: Re: [RFC PATCH v2 1/5] futex: Add futex_set_timer() helper function
Date: Thu, 22 Sep 2016 20:45:06 -0400 [thread overview]
Message-ID: <57E47B12.5070509@hpe.com> (raw)
In-Reply-To: <alpine.DEB.2.20.1609222317040.5640@nanos>
On 09/22/2016 05:31 PM, Thomas Gleixner wrote:
> On Tue, 20 Sep 2016, Waiman Long wrote:
>
> Please be more careful of your subject lines. First thing I thought was
> that you add a helper which is used in later patches to find out that you
> actualy consolidate duplicated code. Something like:
>
> futex: Consolidate duplicated timer setup code
>
> would have told me right away what this is about.
>
>> This patch adds a new futex_set_timer() function to consolidate all
> Please do not use: "This patch ...". We already know that this is a patch,
> otherwise it would not be tagged [PATCH n/m] in the subject line.
>
> See Documentation/SubmittingPatches ....
>
>> the sleeping hrtime setup code.
> Let me give you a hint:
>
> 1: The code has three identical code copies to set up the futex timeout.
>
> 2: Add a helper function and consolidate the call sites.
>
> #1 tells precisely what the problem is
> #2 tells precisely how it is solved
>
> Can you see the difference?
>
>> +/*
>> + * Helper function to set the sleeping hrtimer.
>> + */
>> +static inline void futex_set_timer(ktime_t *time, struct hrtimer_sleeper **pto,
>> + struct hrtimer_sleeper *timeout, int flags, u64 range_ns)
> Please use futex_setup_timer() as the function name. I was confused when I
> read the other patch that you wanted to "set" the timer before entering
> into the place which would actually need it.
>
>> +{
>> + if (!time)
>> + return;
>> + *pto = timeout;
> Please don't do that. That's a horrible coding style.
>
> What's wrong with returning NULL or the timeout pointer and assign it to
> "to" at the call site?
>
> Thanks,
>
> tglx
>
Thanks for the suggestions. I will fix this patch in the next revision.
Cheers,
Longman
next prev parent reply other threads:[~2016-09-23 0:45 UTC|newest]
Thread overview: 35+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-09-20 13:42 [RFC PATCH v2 0/5] futex: Introducing throughput-optimized futexes Waiman Long
2016-09-20 13:42 ` [RFC PATCH v2 1/5] futex: Add futex_set_timer() helper function Waiman Long
2016-09-22 21:31 ` Thomas Gleixner
2016-09-23 0:45 ` Waiman Long [this message]
2016-09-20 13:42 ` [RFC PATCH v2 2/5] futex: Rename futex_pi_state to futex_state Waiman Long
2016-09-20 13:42 ` [RFC PATCH v2 3/5] futex: Throughput-optimized (TO) futexes Waiman Long
2016-09-21 6:59 ` Mike Galbraith
2016-09-21 23:37 ` Waiman Long
2016-09-22 7:49 ` Peter Zijlstra
2016-09-22 13:04 ` Waiman Long
2016-09-22 13:34 ` Thomas Gleixner
2016-09-22 14:41 ` Davidlohr Bueso
2016-09-22 14:46 ` Thomas Gleixner
2016-09-22 15:11 ` Davidlohr Bueso
2016-09-22 20:08 ` Waiman Long
2016-09-22 20:28 ` Waiman Long
2016-09-22 20:38 ` Thomas Gleixner
2016-09-22 21:48 ` Waiman Long
2016-09-23 13:02 ` Thomas Gleixner
2016-09-26 22:02 ` Waiman Long
2016-09-22 21:39 ` Davidlohr Bueso
2016-09-22 21:41 ` Thomas Gleixner
2016-09-22 21:59 ` Waiman Long
2016-09-27 19:02 ` [PATCH v2 -tip] locking/rtmutex: Reduce top-waiter blocking on a lock Davidlohr Bueso
2016-10-24 18:08 ` Davidlohr Bueso
2016-10-24 18:48 ` Thomas Gleixner
2016-09-24 1:28 ` [PATCH " Davidlohr Bueso
2016-09-26 21:40 ` Waiman Long
2016-09-22 19:56 ` [RFC PATCH v2 3/5] futex: Throughput-optimized (TO) futexes Waiman Long
2016-09-22 20:26 ` Thomas Gleixner
2016-09-22 21:13 ` Waiman Long
2016-09-22 13:23 ` Peter Zijlstra
2016-09-22 17:21 ` Waiman Long
2016-09-20 13:42 ` [RFC PATCH v2 4/5] futex: Add timeout support to TO futexes Waiman Long
2016-09-20 13:42 ` [RFC PATCH v2 5/5] futex, doc: TO futexes document Waiman Long
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=57E47B12.5070509@hpe.com \
--to=waiman.long@hpe.com \
--cc=corbet@lwn.net \
--cc=dave@stgolabs.net \
--cc=doug.hatch@hpe.com \
--cc=jason.low2@hpe.com \
--cc=linux-doc@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@kernel.org \
--cc=peterz@infradead.org \
--cc=scott.norton@hpe.com \
--cc=tglx@linutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome