From: "Sverdlin, Alexander" <alexander.sverdlin@siemens.com>
To: "laurent.pinchart@ideasonboard.com"
<laurent.pinchart@ideasonboard.com>,
"andrzej.hajda@intel.com" <andrzej.hajda@intel.com>,
"neil.armstrong@linaro.org" <neil.armstrong@linaro.org>,
"dmitry.baryshkov@linaro.org" <dmitry.baryshkov@linaro.org>,
"tomi.valkeinen@ideasonboard.com"
<tomi.valkeinen@ideasonboard.com>,
"tzimmermann@suse.de" <tzimmermann@suse.de>,
"simona@ffwll.ch" <simona@ffwll.ch>,
"rfoss@kernel.org" <rfoss@kernel.org>,
"airlied@gmail.com" <airlied@gmail.com>,
"aradhya.bhatia@linux.dev" <aradhya.bhatia@linux.dev>,
"jonas@kwiboo.se" <jonas@kwiboo.se>,
"jernej.skrabec@gmail.com" <jernej.skrabec@gmail.com>,
"mripard@kernel.org" <mripard@kernel.org>,
"maarten.lankhorst@linux.intel.com"
<maarten.lankhorst@linux.intel.com>
Cc: "j-choudhary@ti.com" <j-choudhary@ti.com>,
"u-kumar1@ti.com" <u-kumar1@ti.com>,
"dri-devel@lists.freedesktop.org"
<dri-devel@lists.freedesktop.org>,
"devarsht@ti.com" <devarsht@ti.com>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"nm@ti.com" <nm@ti.com>, "vigneshr@ti.com" <vigneshr@ti.com>,
"praneeth@ti.com" <praneeth@ti.com>
Subject: Re: [PATCH v10 11/13] drm/atomic-helper: Separate out bridge pre_enable/post_disable from enable/disable
Date: Tue, 25 Mar 2025 19:12:10 +0000 [thread overview]
Message-ID: <5895a5c837eb2a7998cd8ffee86abf72c8104e48.camel@siemens.com> (raw)
In-Reply-To: <20250226155737.565931-4-aradhya.bhatia@linux.dev>
On Wed, 2025-02-26 at 21:27 +0530, Aradhya Bhatia wrote:
> The encoder-bridge ops occur by looping over the new connector states of
> the display pipelines. The enable sequence runs as follows -
>
> - pre_enable(bridge),
> - enable(encoder),
> - enable(bridge),
>
> while the disable sequnce runs as follows -
>
> - disable(bridge),
> - disable(encoder),
> - post_disable(bridge).
>
> Separate out the pre_enable(bridge), and the post_disable(bridge)
> operations into separate functions each.
>
> This patch keeps the sequence same for any singular disaplay pipe, but
> changes the sequence across multiple display pipelines.
>
> This patch is meant to be an interim patch, to cleanly pave the way for
> the sequence re-ordering patch, and maintain bisectability in the
> process.
>
> Reviewed-by: Dmitry Baryshkov <dmitry.baryshkov@linaro.org>
> Reviewed-by: Jayesh Choudhary <j-choudhary@ti.com>
> Reviewed-by: Tomi Valkeinen <tomi.valkeinen@ideasonboard.com>
> Tested-by: Tomi Valkeinen <tomi.valkeinen@ideasonboard.com>
> Signed-off-by: Aradhya Bhatia <aradhya.bhatia@linux.dev>
Tested with AM62 OLDI series [1] on AM625 with single channel AUO 800x480
LVDS panel. No issues with the patch!
Tested-by: Alexander Sverdlin <alexander.sverdlin@siemens.com>
[1] Link: https://lore.kernel.org/all/20250226181300.756610-1-aradhya.bhatia@linux.dev/
> ---
> Note on checkpatch warning:
> This patch causes the checkpatch to flare up for 1 checkpatch 'check' -
>
> CHECK: Lines should not end with a '('
> #77: FILE: drivers/gpu/drm/drm_atomic_helper.c:1304:
> + new_crtc_state = drm_atomic_get_new_crtc_state(
>
> This patch is largely duplicating the original code, with minor differences to
> perform different operations. This line of code pre-exists in the file and
> have simply been duplicated. I have decided to keep it as is to maintain the
> uniformity and the originally intended readability. Should perhaps a fix be
> required, this patch/series is not the right place, and another patch can be
> created to fix this across the whole file.
>
> ---
> drivers/gpu/drm/drm_atomic_helper.c | 91 ++++++++++++++++++++++++++++-
> 1 file changed, 88 insertions(+), 3 deletions(-)
--
Alexander Sverdlin
Siemens AG
www.siemens.com
next prev parent reply other threads:[~2025-03-25 19:12 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-02-26 15:52 [PATCH v10 00/13] drm/bridge: cdns-dsi: Fix the color-shift issue Aradhya Bhatia
2025-02-26 15:52 ` [PATCH v10 01/13] drm/bridge: cdns-dsi: Fix connecting to next bridge Aradhya Bhatia
2025-02-26 15:52 ` [PATCH v10 02/13] drm/bridge: cdns-dsi: Fix phy de-init and flag it so Aradhya Bhatia
2025-02-26 15:52 ` [PATCH v10 03/13] drm/bridge: cdns-dsi: Fix the clock variable for mode_valid() Aradhya Bhatia
2025-02-26 15:52 ` [PATCH v10 04/13] drm/bridge: cdns-dsi: Check return value when getting default PHY config Aradhya Bhatia
2025-02-26 15:52 ` [PATCH v10 05/13] drm/bridge: cdns-dsi: Wait for Clk and Data Lanes to be ready Aradhya Bhatia
2025-02-26 15:52 ` [PATCH v10 06/13] drm/bridge: cdns-dsi: Move to devm_drm_of_get_bridge() Aradhya Bhatia
2025-02-26 15:52 ` [PATCH v10 07/13] drm/mipi-dsi: Add helper to find input format Aradhya Bhatia
2025-02-26 15:57 ` [PATCH v10 08/13] drm/bridge: cdns-dsi: Support atomic bridge APIs Aradhya Bhatia
2025-02-26 15:57 ` [PATCH v10 09/13] drm/bridge: cdns-dsi: Move DSI mode check to _atomic_check() Aradhya Bhatia
2025-02-26 15:57 ` [PATCH v10 10/13] drm/atomic-helper: Refactor crtc & encoder-bridge op loops into separate functions Aradhya Bhatia
2025-03-25 19:11 ` Sverdlin, Alexander
2025-02-26 15:57 ` [PATCH v10 11/13] drm/atomic-helper: Separate out bridge pre_enable/post_disable from enable/disable Aradhya Bhatia
2025-03-25 19:12 ` Sverdlin, Alexander [this message]
2025-02-26 15:57 ` [PATCH v10 12/13] drm/atomic-helper: Re-order bridge chain pre-enable and post-disable Aradhya Bhatia
2025-03-25 19:12 ` Sverdlin, Alexander
2025-02-26 15:57 ` [PATCH v10 13/13] drm/bridge: cdns-dsi: Use pre_enable/post_disable to enable/disable Aradhya Bhatia
2025-03-11 3:46 ` [PATCH v10 00/13] drm/bridge: cdns-dsi: Fix the color-shift issue Aradhya Bhatia
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=5895a5c837eb2a7998cd8ffee86abf72c8104e48.camel@siemens.com \
--to=alexander.sverdlin@siemens.com \
--cc=airlied@gmail.com \
--cc=andrzej.hajda@intel.com \
--cc=aradhya.bhatia@linux.dev \
--cc=devarsht@ti.com \
--cc=dmitry.baryshkov@linaro.org \
--cc=dri-devel@lists.freedesktop.org \
--cc=j-choudhary@ti.com \
--cc=jernej.skrabec@gmail.com \
--cc=jonas@kwiboo.se \
--cc=laurent.pinchart@ideasonboard.com \
--cc=linux-kernel@vger.kernel.org \
--cc=maarten.lankhorst@linux.intel.com \
--cc=mripard@kernel.org \
--cc=neil.armstrong@linaro.org \
--cc=nm@ti.com \
--cc=praneeth@ti.com \
--cc=rfoss@kernel.org \
--cc=simona@ffwll.ch \
--cc=tomi.valkeinen@ideasonboard.com \
--cc=tzimmermann@suse.de \
--cc=u-kumar1@ti.com \
--cc=vigneshr@ti.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®