From: "SkyLake Huang (黃啟澤)" <SkyLake.Huang@mediatek.com>
To: "daniel@makrotopia.org" <daniel@makrotopia.org>
Cc: "andrew@lunn.ch" <andrew@lunn.ch>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"linux-mediatek@lists.infradead.org"
<linux-mediatek@lists.infradead.org>,
"linux@armlinux.org.uk" <linux@armlinux.org.uk>,
"kuba@kernel.org" <kuba@kernel.org>,
"pabeni@redhat.com" <pabeni@redhat.com>,
"edumazet@google.com" <edumazet@google.com>,
"netdev@vger.kernel.org" <netdev@vger.kernel.org>,
"dqfext@gmail.com" <dqfext@gmail.com>,
"Steven Liu (劉人豪)" <steven.liu@mediatek.com>,
"matthias.bgg@gmail.com" <matthias.bgg@gmail.com>,
"davem@davemloft.net" <davem@davemloft.net>,
"hkallweit1@gmail.com" <hkallweit1@gmail.com>,
"linux-arm-kernel@lists.infradead.org"
<linux-arm-kernel@lists.infradead.org>,
"angelogioacchino.delregno@collabora.com"
<angelogioacchino.delregno@collabora.com>
Subject: Re: [PATCH net-next v10 13/13] net: phy: mediatek: Remove unnecessary outer parens of "supported_triggers" var
Date: Tue, 2 Jul 2024 04:25:31 +0000 [thread overview]
Message-ID: <58fcbf403374c5feee1a1d71c51006383f23188e.camel@mediatek.com> (raw)
In-Reply-To: <ZoKRDSVYD_JMhMqW@makrotopia.org>
On Mon, 2024-07-01 at 12:20 +0100, Daniel Golle wrote:
>
> External email : Please do not click links or open attachments until
> you have verified the sender or the content.
> On Mon, Jul 01, 2024 at 06:54:17PM +0800, Sky Huang wrote:
> > From: "SkyLake.Huang" <skylake.huang@mediatek.com>
> >
> > This patch removes unnecessary outer parens of "supported_triggers"
> vars
> > in mtk-ge.c & mtk-ge-soc.c to improve readability.
> >
> > Signed-off-by: SkyLake.Huang <skylake.huang@mediatek.com>
> > ---
> > diff --git a/drivers/net/phy/mediatek/mtk-ge.c
> b/drivers/net/phy/mediatek/mtk-ge.c
> > index 90f3990..050a4f7 100644
> > --- a/drivers/net/phy/mediatek/mtk-ge.c
> > +++ b/drivers/net/phy/mediatek/mtk-ge.c
> > @@ -152,14 +152,14 @@ static int
> mt753x_phy_led_brightness_set(struct phy_device *phydev,
> > }
> >
> > static const unsigned long supported_triggers =
> > -(BIT(TRIGGER_NETDEV_FULL_DUPLEX) |
> > - BIT(TRIGGER_NETDEV_HALF_DUPLEX) |
> > - BIT(TRIGGER_NETDEV_LINK) |
> > - BIT(TRIGGER_NETDEV_LINK_10) |
> > - BIT(TRIGGER_NETDEV_LINK_100) |
> > - BIT(TRIGGER_NETDEV_LINK_1000) |
> > - BIT(TRIGGER_NETDEV_RX) |
> > - BIT(TRIGGER_NETDEV_TX));
> > +BIT(TRIGGER_NETDEV_FULL_DUPLEX) |
> > +BIT(TRIGGER_NETDEV_HALF_DUPLEX) |
> > +BIT(TRIGGER_NETDEV_LINK) |
> > +BIT(TRIGGER_NETDEV_LINK_10) |
> > +BIT(TRIGGER_NETDEV_LINK_100) |
> > +BIT(TRIGGER_NETDEV_LINK_1000) |
> > +BIT(TRIGGER_NETDEV_RX) |
> > +BIT(TRIGGER_NETDEV_TX);
>
> Those lines are added within the same series by patch 06/13
> ("net: phy: mediatek: Hook LED helper functions in mtk-ge.c").
> I get and like the idea of doing things one by one, but in this case
> instead of editing what you have just added, better move the commit
> removing the unnecessary parentheses somewhere before copying them to
> the mtk-ge.c driver in patch 6/13.
>
> All the rest looks good to me now.
Indeed, I did this on purpose so that patch 13/13 will show that why
mtk-ge-soc.c's & mtk-ge.c's parens around "supported_triggers" var
needs to be removed. However, if this does cause problems for reviewing
and if there's next version for this series, I can move it to patch
6/13.
BRs,
Sky
next prev parent reply other threads:[~2024-07-02 4:25 UTC|newest]
Thread overview: 24+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-07-01 10:54 [PATCH net-next v10 00/13] net: phy: mediatek: Introduce mtk-phy-lib and add 2.5Gphy support Sky Huang
2024-07-01 10:54 ` [PATCH net-next v10 01/13] net: phy: mediatek: Re-organize MediaTek ethernet phy drivers Sky Huang
2024-07-01 10:54 ` [PATCH net-next v10 02/13] net: phy: mediatek: Fix spelling errors and rearrange variables Sky Huang
2024-07-01 10:54 ` [PATCH net-next v10 03/13] net: phy: mediatek: Move LED helper functions into mtk phy lib Sky Huang
2024-07-01 10:54 ` [PATCH net-next v10 04/13] net: phy: mediatek: Improve readability of mtk-phy-lib.c's mtk_phy_led_hw_ctrl_set() Sky Huang
2024-07-01 10:54 ` [PATCH net-next v10 05/13] net: phy: mediatek: Integrate read/write page helper functions Sky Huang
2024-07-01 10:54 ` [PATCH net-next v10 06/13] net: phy: mediatek: Hook LED helper functions in mtk-ge.c Sky Huang
2024-07-01 10:54 ` [PATCH net-next v10 07/13] net: phy: mediatek: add MT7530 & MT7531's PHY ID macros Sky Huang
2024-07-01 10:54 ` [PATCH net-next v10 08/13] net: phy: mediatek: Change mtk-ge-soc.c line wrapping Sky Huang
2024-07-01 10:54 ` [PATCH net-next v10 09/13] net: phy: mediatek: Add token ring access helper functions in mtk-phy-lib Sky Huang
2024-07-01 10:54 ` [PATCH net-next v10 10/13] net: phy: mediatek: Extend 1G TX/RX link pulse time Sky Huang
2024-07-01 10:54 ` [PATCH net-next v10 11/13] net: phy: add driver for built-in 2.5G ethernet PHY on MT7988 Sky Huang
2024-08-09 14:17 ` Andrew Lunn
2024-08-21 9:49 ` SkyLake Huang (黃啟澤)
2024-09-04 8:49 ` SkyLake Huang (黃啟澤)
2024-09-04 9:02 ` Daniel Golle
2024-07-01 10:54 ` [PATCH net-next v10 12/13] net: phy: mediatek: Fix alignment in callback functions' hook Sky Huang
2024-07-01 10:54 ` [PATCH net-next v10 13/13] net: phy: mediatek: Remove unnecessary outer parens of "supported_triggers" var Sky Huang
2024-07-01 11:20 ` Daniel Golle
2024-07-02 4:25 ` SkyLake Huang (黃啟澤) [this message]
2024-08-09 10:58 ` [PATCH net-next v10 00/13] net: phy: mediatek: Introduce mtk-phy-lib and add 2.5Gphy support SkyLake Huang (黃啟澤)
2024-08-09 14:07 ` Andrew Lunn
2024-08-21 23:26 ` Daniel Golle
2024-09-04 8:47 ` SkyLake Huang (黃啟澤)
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=58fcbf403374c5feee1a1d71c51006383f23188e.camel@mediatek.com \
--to=skylake.huang@mediatek.com \
--cc=andrew@lunn.ch \
--cc=angelogioacchino.delregno@collabora.com \
--cc=daniel@makrotopia.org \
--cc=davem@davemloft.net \
--cc=dqfext@gmail.com \
--cc=edumazet@google.com \
--cc=hkallweit1@gmail.com \
--cc=kuba@kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mediatek@lists.infradead.org \
--cc=linux@armlinux.org.uk \
--cc=matthias.bgg@gmail.com \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
--cc=steven.liu@mediatek.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®