mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Pierre-Louis Bossart <pierre-louis.bossart@linux.intel.com>
To: Greg KH <gregkh@linuxfoundation.org>
Cc: Bard Liao <yung-chuan.liao@linux.intel.com>,
	alsa-devel@alsa-project.org, vkoul@kernel.org,
	vinod.koul@linaro.org, linux-kernel@vger.kernel.org,
	tiwai@suse.de, broonie@kernel.org,
	srinivas.kandagatla@linaro.org, sanyog.r.kale@intel.com,
	bard.liao@intel.com
Subject: Re: [PATCH 2/2] ASoC: SOF: Intel: add trigger callback into sdw_callback
Date: Tue, 14 Jun 2022 10:54:44 -0500	[thread overview]
Message-ID: <5928a225-f355-47d7-c502-d95319ce447f@linux.intel.com> (raw)
In-Reply-To: <Yqil3UDSmoXN3E9M@kroah.com>




>>>> @@ -809,6 +814,10 @@ void hda_set_dai_drv_ops(struct snd_sof_dev *sdev, struct snd_sof_dsp_ops *ops)
>>>>  		if (!hda_use_tplg_nhlt)
>>>>  			ipc4_data->nhlt = intel_nhlt_init(sdev->dev);
>>>>  
>>>> +#if IS_ENABLED(CONFIG_SND_SOC_SOF_INTEL_SOUNDWIRE)
>>>> +		sdw_callback.trigger = ipc4_be_dai_common_trigger;
>>>> +#endif
>>>
>>> #if should not be in .c files if at all possible.  Surely there's a
>>> better way here...
>>
>> we could use
>>
>> if (IS_ENABLED(CONFIG_SND_SOC_SOF_INTEL_SOUNDWIRE))
>>     sdw_callback.trigger = ipc4_be_dai_common_trigger;
>>
>> would that work?
> 
> It's more readable, right?  Also easier to maintain over time.

yes, it's more readable, and that's no problem to update.

There's another #if IS_ENABLED( that we can replace by a if (IS_ENABLED
in the same routine, that would make this routine less of an eyesore. I
am not sure why we added all these #if, we can cleanup.

 	case SOF_INTEL_IPC4:
	{
		struct sof_ipc4_fw_data *ipc4_data = sdev->private;

		for (i = 0; i < ops->num_drv; i++) {
			if (strstr(ops->drv[i].name, "DMIC")) {
				ops->drv[i].ops = &ipc4_dmic_dai_ops;
				continue;
			}
			if (strstr(ops->drv[i].name, "SSP")) {
				ops->drv[i].ops = &ipc4_ssp_dai_ops;
				continue;
			}
#if IS_ENABLED(CONFIG_SND_SOC_SOF_HDA)
			if (strstr(ops->drv[i].name, "iDisp") ||
			    strstr(ops->drv[i].name, "Analog") ||
			    strstr(ops->drv[i].name, "Digital"))
				ops->drv[i].ops = &ipc4_hda_dai_ops;
#endif
		}

		if (!hda_use_tplg_nhlt)
			ipc4_data->nhlt = intel_nhlt_init(sdev->dev);

#if IS_ENABLED(CONFIG_SND_SOC_SOF_INTEL_SOUNDWIRE)
		sdw_callback.trigger = ipc4_be_dai_common_trigger;
#endif

		break;
	}
	default:
		break;
	}
}
>> We try to keep this driver configurable, not all platforms require
>> SoundWire or HDaudio, and that 'sdw_callback' ops structure is
>> conditionally declared.
> 
> Perhaps don't conditionally declare that?  How much does it really save
> to do that?

It would force us to expose additional things that are only relevant for
SoundWire, see the large block of code in hda.c

https://elixir.bootlin.com/linux/latest/source/sound/soc/sof/intel/hda.c#L108

We've been burned in the past by having too many things in a single
configuration, so we try to allow for minimal builds that don't depend
on other modules in sound/soc/codecs/, sound/pci/hda and
drivers/soundwire - it also forces us to get the Kconfig dependencies right.

if (IS_ENABLED()) is less invasive in that case.

Thanks for your feedback
-Pierre

      reply	other threads:[~2022-06-14 15:54 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-06-14  7:08 [PATCH 0/2] ASoC/SoundWire: Intel: add sdw BE dai trigger Bard Liao
2022-06-14  7:08 ` [PATCH 1/2] soundwire: Intel: add trigger callback Bard Liao
2022-06-14  7:08 ` [PATCH 2/2] ASoC: SOF: Intel: add trigger callback into sdw_callback Bard Liao
2022-06-14  7:12   ` Greg KH
2022-06-14 14:55     ` Pierre-Louis Bossart
2022-06-14 15:14       ` Greg KH
2022-06-14 15:54         ` Pierre-Louis Bossart [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=5928a225-f355-47d7-c502-d95319ce447f@linux.intel.com \
    --to=pierre-louis.bossart@linux.intel.com \
    --cc=alsa-devel@alsa-project.org \
    --cc=bard.liao@intel.com \
    --cc=broonie@kernel.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=sanyog.r.kale@intel.com \
    --cc=srinivas.kandagatla@linaro.org \
    --cc=tiwai@suse.de \
    --cc=vinod.koul@linaro.org \
    --cc=vkoul@kernel.org \
    --cc=yung-chuan.liao@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®