From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751582AbcGNS3c (ORCPT ); Thu, 14 Jul 2016 14:29:32 -0400 Received: from mx1.redhat.com ([209.132.183.28]:36199 "EHLO mx1.redhat.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751160AbcGNS33 (ORCPT ); Thu, 14 Jul 2016 14:29:29 -0400 Subject: Re: [PATCH v2 0/5] Add support for EPT execute only for nested hypervisors To: Bandan Das References: <1468361932-16580-1-git-send-email-bsd@redhat.com> <82db70ed-761e-0377-5417-acb64bed6cb6@redhat.com> <921eef54-f23b-cd90-8e20-a428a00a3297@redhat.com> <26006044-7096-63e5-8156-a15f001d8403@redhat.com> Cc: kvm@vger.kernel.org, guangrong.xiao@linux.intel.com, kernellwp@gmail.com, linux-kernel@vger.kernel.org From: Paolo Bonzini Message-ID: <5951c0e5-4c41-4817-034a-5214a10cf53c@redhat.com> Date: Thu, 14 Jul 2016 20:29:25 +0200 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.1.1 MIME-Version: 1.0 In-Reply-To: Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 7bit X-Greylist: Sender IP whitelisted, not delayed by milter-greylist-4.5.16 (mx1.redhat.com [10.5.110.29]); Thu, 14 Jul 2016 18:29:29 +0000 (UTC) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 14/07/2016 19:38, Bandan Das wrote: > Paolo Bonzini writes: > >> On 13/07/2016 17:47, Bandan Das wrote: >>>>> I wanted to keep it the former way because "PT_PRESENT_MASK is equal to VMX_EPT_READABLE_MASK" >>>>> is an assumption all throughout. I wanted to use this section to catch mismatches. >>>> >>>> I think there's no such assumption anymore, actually. Can you double >>>> check? If there are any, that's where the BUILD_BUG_ON should be. >>> >>> What I meant is how they are the same bit. is_shadow_present_pte() is probably one >>> and another one is link_shadow_page() which already has a BUILD_BUG_ON(). >> >> You're right about link_shadow_page()! We probably should change the >> PT_PRESENT_MASK to shadow_present_mask there (and then readability in >> the EPT execonly case is still provided by shadow_user_mask). > > Makes sense. Would you like a new version with that added or can that be a > separate patch ? I've already done it and pushed it to kvm/next. :) >> For is_shadow_present_pte() you have removed it in patch 1 though. > > Right. But the assumption is still that is_shadow_present_pte() works because > EPT_READABLE and PT_PRESENT are the same. is_shadow_present_pte() tests 0xFFFFFFFF, so it does not depend on bit 0 alone, for neither EPT nor "normal" page tables. Paolo