From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753974AbdJIDoI (ORCPT ); Sun, 8 Oct 2017 23:44:08 -0400 Received: from mail.cn.fujitsu.com ([183.91.158.132]:4207 "EHLO heian.cn.fujitsu.com" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1753711AbdJIDoF (ORCPT ); Sun, 8 Oct 2017 23:44:05 -0400 X-IronPort-AV: E=Sophos;i="5.42,498,1500912000"; d="scan'208";a="28730673" Subject: Re: [PATCH] kbuild: comments cleanup in Makefile.lib To: Masahiro Yamada References: <1505820967-17302-1-git-send-email-caoj.fnst@cn.fujitsu.com> CC: Linux Kbuild mailing list , Linux Kernel Mailing List , Michal Marek From: Cao jin Message-ID: <59DAF04B.2050601@cn.fujitsu.com> Date: Mon, 9 Oct 2017 11:43:07 +0800 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.1.0 MIME-Version: 1.0 In-Reply-To: Content-Type: text/plain; charset="utf-8" Content-Transfer-Encoding: 7bit X-Originating-IP: [10.167.226.69] X-yoursite-MailScanner-ID: 4FF78482CFF0.A757A X-yoursite-MailScanner: Found to be clean X-yoursite-MailScanner-From: caoj.fnst@cn.fujitsu.com Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Masahiro-san, On 10/04/2017 12:58 PM, Masahiro Yamada wrote: > Hi Cao, > > > 2017-09-19 20:36 GMT+09:00 Cao jin : >> It has: >> 1. Move comments close to what it want to comment. >> 2. Comments cleanup & improvement. >> >> Signed-off-by: Cao jin >> >> -# if $(foo-objs) exists, foo.o is a composite object >> +# if $(foo-objs) or $(foo-y) or $(foo-m) exists, foo.o is a composite object > > > Nit: > > "if $(foo-objs), $(foo-y), or $(foo-m) exists" will be better. > Yes, true. >> multi-used-y := $(sort $(foreach m,$(obj-y), $(if $(strip $($(m:.o=-objs)) $($(m:.o=-y))), $(m)))) >> multi-used-m := $(sort $(foreach m,$(obj-m), $(if $(strip $($(m:.o=-objs)) $($(m:.o=-y)) $($(m:.o=-m))), $(m)))) >> multi-used := $(multi-used-y) $(multi-used-m) >> @@ -90,7 +84,6 @@ subdir-ym := $(addprefix $(obj)/,$(subdir-ym)) >> obj-dirs := $(addprefix $(obj)/,$(obj-dirs)) >> >> # These flags are needed for modversions and compiling, so we define them here >> -# already >> # $(modname_flags) #defines KBUILD_MODNAME as the name of the module it will > > > I am not sure if "#defines" is intentional or not. > I think "#" is unnecessary. > Yes, agree with you -- Sincerely, Cao jin