mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Dave Jiang <dave.jiang@intel.com>
To: Linus Torvalds <torvalds@linux-foundation.org>
Cc: linux-kernel <linux-kernel@vger.kernel.org>,
	"linux-cxl@vger.kernel.org" <linux-cxl@vger.kernel.org>,
	Dan Williams <dan.j.williams@intel.com>,
	Davidlohr Bueso <dave@stgolabs.net>,
	Jonathan Cameron <Jonathan.Cameron@huawei.com>,
	Ira Weiny <ira.weiny@intel.com>,
	Alison Schofield <alison.schofield@intel.com>,
	Vishal Verma <vishal.l.verma@intel.com>
Subject: [GIT PULL] Compute Express Link (CXL) changes for 6.19
Date: Mon, 1 Dec 2025 10:33:18 -0700	[thread overview]
Message-ID: <59b991e0-d7dd-4285-b052-c3574249409f@intel.com> (raw)

Hi Linus, please pull from:

  git://git.kernel.org/pub/scm/linux/kernel/git/cxl/cxl.git tags/cxl-for-6.19

...to receive a collection of changes for CXL.

The additions of note are adding CXL region remove support for locked CXL decoders,
adding unit testing support for XOR address translation, and adding unit testing
support for extended linear cache.

These have all appeared in -next for more than a week with no reported issues.

---

The following changes since commit e9a6fb0bcdd7609be6969112f3fbfcce3b1d4a7c:

  Linux 6.18-rc5 (2025-11-09 15:10:19 -0800)

are available in the Git repository at:

  git://git.kernel.org/pub/scm/linux/kernel/git/cxl/cxl.git tags/cxl-for-6.19

for you to fetch changes up to ea5514e300568cbe8f19431c3e424d4791db8291:

  Merge branch 'for-6.19/cxl-misc' into cxl-for-next (2025-11-18 16:27:58 -0700)

----------------------------------------------------------------
cxl for v6.19

Misc:
- Remove incorrect page-allocator quirk section in documentation.
- Remove unused devm_cxl_port_enumerate_dports() function.
- Fix typo in cdat.c code comment.
- Replace use of system_wq with system_percpu_wq
- Add locked CXL decoder support for region removal.
- Return when generic target updated
- Rename region_res_match_cxl_range() to spa_maps_hpa()
- Clarify comment in spa_maps_hpa()

Enable unit testing for XOR address translation of SPA to DPA and vice versa.
- Refactor address translation funcs for testing in cxl_region.
- Make the XOR calculations available for testing.
- Add cxl_translate module for address translation testing in cxl_test.

Extended Linear Cache changes:
- Add extended linear cache size sysfs attribute.
- Adjust failure emission of extended linear cache detection in cxl_acpi.
- Added extended linear cache unit testing support in cxl_test

Preparation refactor patches for PRM translation support.
- Simplify cxl_rd_ops allocation and handling.
- Group xor arithmetric setup code in a single block.
- Remove local variable @inc in cxl_port_setup_targets()

----------------------------------------------------------------
Alejandro Lucero (1):
      cxl/test: remove unused mock function for cxl_rcd_component_reg_phys()

Alison Schofield (5):
      cxl/region: Refactor address translation funcs for testing
      cxl/acpi: Make the XOR calculations available for testing
      cxl/test: Add cxl_translate module for address translation testing
      cxl/test: Remove ret_limit race condition in mock_get_event()
      cxl/test: Assign overflow_err_count from log->nr_overflow

Alok Tiwari (1):
      cxl: fix typos in cdat.c comments

Dave Jiang (16):
      cxl: Adjust extended linear cache failure emission in cxl_acpi
      cxl/region: Add support to indicate region has extended linear cache
      cxl: Add handling of locked CXL decoder
      acpi/hmat: Return when generic target is updated
      cxl: Rename region_res_match_cxl_range() to spa_maps_hpa()
      cxl: Clarify comment in spa_maps_hpa()
      Merge branch 'for-6.19/cxl-misc' into cxl-for-next
      Merge branch 'for-6.19/cxl-addr-xlat' into cxl-for-next
      Merge branch 'for-6.19/cxl-elc' into cxl-for-next
      Merge branch 'for-6.19/cxl-prm' into cxl-for-next
      cxl/test: Standardize CXL auto region size
      cxl/test: Add cxl_test CFMWS support for extended linear cache
      cxl/test: Add support for acpi extended linear cache
      Merge branch 'for-6.19/cxl-elc-test' into cxl-for-next
      Merge branch 'for-6.19/cxl-misc' into cxl-for-next
      Merge branch 'for-6.19/cxl-misc' into cxl-for-next

Gregory Price (1):
      Documentation/driver-api/cxl: remove page-allocator quirk section

Li Ming (1):
      cxl/port: Remove devm_cxl_port_enumerate_dports()

Marco Crivellari (1):
      cxl/pci: replace use of system_wq with system_percpu_wq

Robert Richter (3):
      cxl: Simplify cxl_rd_ops allocation and handling
      cxl/acpi: Group xor arithmetric setup code in a single block
      cxl/region: Remove local variable @inc in cxl_port_setup_targets()

 Documentation/ABI/testing/sysfs-bus-cxl            |  11 +-
 .../driver-api/cxl/allocation/page-allocator.rst   |  31 --
 drivers/acpi/numa/hmat.c                           |  11 +-
 drivers/cxl/acpi.c                                 |  73 ++--
 drivers/cxl/core/cdat.c                            |   4 +-
 drivers/cxl/core/hdm.c                             |   3 +
 drivers/cxl/core/pci.c                             |  87 +---
 drivers/cxl/core/port.c                            |   1 -
 drivers/cxl/core/region.c                          | 313 ++++++++++-----
 drivers/cxl/cxl.h                                  |  29 +-
 drivers/cxl/cxlpci.h                               |   1 -
 drivers/cxl/pci.c                                  |   2 +-
 tools/testing/cxl/Kbuild                           |   3 +-
 tools/testing/cxl/test/Kbuild                      |   1 +
 tools/testing/cxl/test/cxl.c                       |  86 ++--
 tools/testing/cxl/test/cxl_translate.c             | 445 +++++++++++++++++++++
 tools/testing/cxl/test/mem.c                       |  11 +-
 tools/testing/cxl/test/mock.c                      |  52 +--
 tools/testing/cxl/test/mock.h                      |   4 +-
 19 files changed, 840 insertions(+), 328 deletions(-)
 create mode 100644 tools/testing/cxl/test/cxl_translate.c

             reply	other threads:[~2025-12-01 17:33 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-12-01 17:33 Dave Jiang [this message]
2025-12-05  3:00 ` pr-tracker-bot

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=59b991e0-d7dd-4285-b052-c3574249409f@intel.com \
    --to=dave.jiang@intel.com \
    --cc=Jonathan.Cameron@huawei.com \
    --cc=alison.schofield@intel.com \
    --cc=dan.j.williams@intel.com \
    --cc=dave@stgolabs.net \
    --cc=ira.weiny@intel.com \
    --cc=linux-cxl@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=torvalds@linux-foundation.org \
    --cc=vishal.l.verma@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®