mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Casey Schaufler <casey@schaufler-ca.com>
To: Paul Moore <paul@paul-moore.com>
Cc: linux-security-module@vger.kernel.org, jmorris@namei.org,
	keescook@chromium.org, john.johansen@canonical.com,
	penguin-kernel@i-love.sakura.ne.jp,
	stephen.smalley.work@gmail.com, linux-kernel@vger.kernel.org,
	linux-api@vger.kernel.org, mic@digikod.net,
	Casey Schaufler <casey@schaufler-ca.com>
Subject: Re: [PATCH v8 07/11] LSM: Helpers for attribute names and filling an lsm_ctx
Date: Tue, 18 Apr 2023 15:43:14 -0700	[thread overview]
Message-ID: <5acc0c6c-0ef6-bc92-0af9-dc33d8a21afa@schaufler-ca.com> (raw)
In-Reply-To: <CAHC9VhTX-JnS11Ywfwf2aTvh1J3KBdsfCp3k1C=8WyLcgRNDig@mail.gmail.com>

On 4/18/2023 2:51 PM, Paul Moore wrote:
> On Tue, Apr 11, 2023 at 12:02 PM Casey Schaufler <casey@schaufler-ca.com> wrote:
>> Add lsm_name_to_attr(), which translates a text string to a
>> LSM_ATTR value if one is available.
>>
>> Add lsm_fill_user_ctx(), which fills a struct lsm_ctx, including
>> the trailing attribute value. The .len value is padded to a multiple
>> of the size of the structure for alignment.
>>
>> All are used in module specific components of LSM system calls.
>>
>> Signed-off-by: Casey Schaufler <casey@schaufler-ca.com>
>> ---
>>  include/linux/security.h | 13 +++++++++++
>>  security/lsm_syscalls.c  | 24 ++++++++++++++++++++
>>  security/security.c      | 48 ++++++++++++++++++++++++++++++++++++++++
>>  3 files changed, 85 insertions(+)
> ..
>
>> diff --git a/security/lsm_syscalls.c b/security/lsm_syscalls.c
>> index 6efbe244d304..67106f642422 100644
>> --- a/security/lsm_syscalls.c
>> +++ b/security/lsm_syscalls.c
>> @@ -17,6 +17,30 @@
>>  #include <linux/lsm_hooks.h>
>>  #include <uapi/linux/lsm.h>
>>
>> +/**
>> + * lsm_name_to_attr - map an LSM attribute name to its ID
>> + * @name: name of the attribute
>> + *
>> + * Returns the LSM attribute value associated with @name, or 0 if
>> + * there is no mapping.
>> + */
>> +u64 lsm_name_to_attr(const char *name)
>> +{
>> +       if (!strcmp(name, "current"))
>> +               return LSM_ATTR_CURRENT;
>> +       if (!strcmp(name, "exec"))
>> +               return LSM_ATTR_EXEC;
>> +       if (!strcmp(name, "fscreate"))
>> +               return LSM_ATTR_FSCREATE;
>> +       if (!strcmp(name, "keycreate"))
>> +               return LSM_ATTR_KEYCREATE;
>> +       if (!strcmp(name, "prev"))
>> +               return LSM_ATTR_PREV;
>> +       if (!strcmp(name, "sockcreate"))
>> +               return LSM_ATTR_SOCKCREATE;
>> +       return 0;
>> +}
> Thank you :)

It didn't hurt all that badly.

>
>>  /**
>>   * sys_lsm_set_self_attr - Set current task's security module attribute
>>   * @attr: which attribute to set
>> diff --git a/security/security.c b/security/security.c
>> index bfe9a1a426b2..453f3ff591ec 100644
>> --- a/security/security.c
>> +++ b/security/security.c
>> @@ -752,6 +752,54 @@ static int lsm_superblock_alloc(struct super_block *sb)
>>         return 0;
>>  }
>>
>> +/**
>> + * lsm_fill_user_ctx - Fill a user space lsm_ctx structure
>> + * @ctx: an LSM context to be filled
>> + * @context: the new context value
>> + * @context_size: the size of the new context value
>> + * @id: LSM id
>> + * @flags: LSM defined flags
>> + *
>> + * Fill all of the fields in a user space lsm_ctx structure.
>> + * Caller is assumed to have verified that @ctx has enough space
>> + * for @context.
>> + *
>> + * The total length is padded to an integral number of lsm_ctx.
> Considering that lsm_ctx is variable length I'm not sure that makes a
> lot of sense, how about we pad the total length so that the @ctx entry
> is a multiple of 64-bits?

64 is fine.

>   If needed we can always change this later
> as the lsm_ctx struct is inherently variable in length and userspace
> will need to deal with the buffer regardless of alignment.
>
>> + * Returns 0 on success, -EFAULT on a copyout error.
>> + */
>> +int lsm_fill_user_ctx(struct lsm_ctx __user *ctx, void *context,
>> +                     size_t context_size, u64 id, u64 flags)
>> +{
>> +       struct lsm_ctx *lctx;
>> +       size_t locallen;
>> +       u8 *composite;
>> +       int rc = 0;
>> +
>> +       locallen = sizeof(*ctx);
>> +       if (context_size)
>> +               locallen += sizeof(*ctx) * ((context_size / sizeof(*ctx)) + 1);
> It seems cleaner to use the kernel's ALIGN() macro:

Indeed. I'll do it.

>
>   /* ensure the lsm_ctx length is a multiple of 64-bits */
>   locallen = ALIGN(sizeof(*ctx) + context_size, 8);
>   lctx = kzalloc(locallen, GFP_KERNEL)
>   if (!lctx)
>     return -ENOMEM;
>
>> +       composite = kzalloc(locallen, GFP_KERNEL);
>> +       if (composite == NULL)
>> +               return -ENOMEM;
>> +
>> +       lctx = (struct lsm_ctx *)composite;
>> +       lctx->id = id;
>> +       lctx->flags = flags;
>> +       lctx->ctx_len = context_size;
>> +       lctx->len = locallen;
>> +
>> +       memcpy(composite + sizeof(*lctx), context, context_size);
> Is there a problem with doing `memcpy(lctx->ctx, context,
> context_size)` in place of the memcpy above?

Nope.

>   That is easier to read
> and we can get rid of @composite.

Point.

>> +       if (copy_to_user(ctx, composite, locallen))
>> +               rc = -EFAULT;
>> +
>> +       kfree(composite);
>> +
>> +       return rc;
>> +}
> I understand Mickaël asked you to do a single copy_to_user(), but I'm
> not sure it is worth it if we have to add a temporary buffer
> allocation like that.  How about something like below (v7 with some
> tweaks/padding)?  You could be a bit more clever with the memset if
> you want, I was just typing this up quickly ...

I prefer two copies to the allocation myself. I'll incorporate this.

>
> int lsm_fill_user_ctx(...)
> {
>   struct lsm_ctx lctx;
>
>   /* ensure the lctx length is a multiple of 64-bits */
>   lctx.len = ALIGN(sizeof(lctx) + context_size, 8);
>
>   lctx.id = id;
>   lctx.flags = flags;
>   lctx.ctx_len = context_size;
>
>   memset(ctx, 0, lctx.len);
>   if (copy_to_user(ctx, &lctx, sizeof(lctx))
>     return -EFAULT;
>   if (copy_to_user(&ctx[1], context, context_size)
>     return -EFAULT;
>
>   return 0;
> }
>
> --
> paul-moore.com

  reply	other threads:[~2023-04-18 22:43 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <20230411155921.14716-1-casey.ref@schaufler-ca.com>
2023-04-11 15:59 ` [PATCH v8 00/11] LSM: Three basic syscalls Casey Schaufler
2023-04-11 15:59   ` [PATCH v8 01/11] LSM: Identify modules by more than name Casey Schaufler
2023-04-11 15:59   ` [PATCH v8 02/11] LSM: Maintain a table of LSM attribute data Casey Schaufler
2023-04-11 15:59   ` [PATCH v8 03/11] proc: Use lsmids instead of lsm names for attrs Casey Schaufler
2023-04-11 15:59   ` [PATCH v8 04/11] LSM: syscalls for current process attributes Casey Schaufler
2023-04-12 11:03     ` kernel test robot
2023-04-18 21:49     ` Paul Moore
2023-04-18 22:34       ` Casey Schaufler
2023-04-19 14:22         ` Paul Moore
2023-04-11 15:59   ` [PATCH v8 05/11] LSM: Create lsm_list_modules system call Casey Schaufler
2023-04-11 15:59   ` [PATCH v8 06/11] LSM: wireup Linux Security Module syscalls Casey Schaufler
2023-04-11 15:59   ` [PATCH v8 07/11] LSM: Helpers for attribute names and filling an lsm_ctx Casey Schaufler
2023-04-18 21:51     ` Paul Moore
2023-04-18 22:43       ` Casey Schaufler [this message]
2023-04-19 22:19         ` Casey Schaufler
2023-04-11 15:59   ` [PATCH v8 08/11] Smack: implement setselfattr and getselfattr hooks Casey Schaufler
2023-04-11 15:59   ` [PATCH v8 09/11] AppArmor: Add selfattr hooks Casey Schaufler
2023-04-11 15:59   ` [PATCH v8 10/11] SELinux: " Casey Schaufler
2023-04-11 15:59   ` [PATCH v8 11/11] LSM: selftests for Linux Security Module syscalls Casey Schaufler

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=5acc0c6c-0ef6-bc92-0af9-dc33d8a21afa@schaufler-ca.com \
    --to=casey@schaufler-ca.com \
    --cc=jmorris@namei.org \
    --cc=john.johansen@canonical.com \
    --cc=keescook@chromium.org \
    --cc=linux-api@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-security-module@vger.kernel.org \
    --cc=mic@digikod.net \
    --cc=paul@paul-moore.com \
    --cc=penguin-kernel@i-love.sakura.ne.jp \
    --cc=stephen.smalley.work@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®