mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Robin Murphy <robin.murphy@arm.com>
To: Christoph Hellwig <hch@lst.de>
Cc: iommu@lists.linux-foundation.org, linux-arch@vger.kernel.org,
	linux-mips@linux-mips.org, "Michal Simek" <monstr@monstr.eu>,
	linux-ia64@vger.kernel.org,
	"Christian König" <ckoenig.leichtzumerken@gmail.com>,
	x86@kernel.org, linux-kernel@vger.kernel.org,
	"Konrad Rzeszutek Wilk" <konrad@darnok.org>,
	"Guan Xuetao" <gxt@mprc.pku.edu.cn>,
	linuxppc-dev@lists.ozlabs.org,
	linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH 08/22] swiotlb: wire up ->dma_supported in swiotlb_dma_ops
Date: Wed, 10 Jan 2018 17:23:08 +0000	[thread overview]
Message-ID: <5b14af5b-e6e9-17c5-d433-f50ccb466f90@arm.com> (raw)
In-Reply-To: <20180110153517.GF17790@lst.de>

On 10/01/18 15:35, Christoph Hellwig wrote:
> On Wed, Jan 10, 2018 at 12:16:15PM +0000, Robin Murphy wrote:
>> On 10/01/18 08:09, Christoph Hellwig wrote:
>>> To properly reject too small DMA masks based on the addressability of the
>>> bounce buffer.
>>
>> I reckon this is self-evident enough that it should simply be squashed into
>> the previous patch.
> 
> x86 didn't wire it up before, so I want a clear blaimpoint for this
> change instead of mixing it up.
That almost makes sense, if x86 were using this generic swiotlb_dma_ops 
already. AFAICS it's only ia64, unicore and tile who end up using it, 
and they all had swiotlb_dma_supported hooked up to begin with. Am I 
missing something?

If regressions are going to happen, they'll surely point at whichever 
commit pulls the ops into the relevant arch code - there doesn't seem to 
be a great deal of value in having a piecemeal history of said ops 
*before* that point.

Robin.

  reply	other threads:[~2018-01-10 17:23 UTC|newest]

Thread overview: 45+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-01-10  8:09 consolidate swiotlb dma_map implementations Christoph Hellwig
2018-01-10  8:09 ` [PATCH 01/22] swiotlb: suppress warning when __GFP_NOWARN is set Christoph Hellwig
2018-01-10  8:09 ` [PATCH 02/22] arm64: rename swiotlb_dma_ops Christoph Hellwig
2018-01-10 12:13   ` Robin Murphy
2018-01-10  8:09 ` [PATCH 03/22] ia64: " Christoph Hellwig
2018-01-12 13:24   ` Konrad Rzeszutek Wilk
2018-01-10  8:09 ` [PATCH 04/22] powerpc: " Christoph Hellwig
2018-01-12 13:25   ` Konrad Rzeszutek Wilk
2018-01-10  8:09 ` [PATCH 05/22] x86: " Christoph Hellwig
2018-01-12 13:25   ` Konrad Rzeszutek Wilk
2018-01-10  8:09 ` [PATCH 06/22] swiotlb: rename swiotlb_free to swiotlb_exit Christoph Hellwig
2018-01-12 13:39   ` Konrad Rzeszutek Wilk
2018-01-10  8:09 ` [PATCH 07/22] swiotlb: add common swiotlb_map_ops Christoph Hellwig
2018-01-10  8:09 ` [PATCH 08/22] swiotlb: wire up ->dma_supported in swiotlb_dma_ops Christoph Hellwig
2018-01-10 12:16   ` Robin Murphy
2018-01-10 15:35     ` Christoph Hellwig
2018-01-10 17:23       ` Robin Murphy [this message]
2018-01-10  8:09 ` [PATCH 09/22] swiotlb: refactor coherent buffer freeing Christoph Hellwig
2018-01-10  8:09 ` [PATCH 10/22] swiotlb: refactor coherent buffer allocation Christoph Hellwig
2018-01-10 12:22   ` Robin Murphy
2018-01-10 15:46     ` Christoph Hellwig
2018-01-10 17:02       ` Robin Murphy
2018-01-15  9:10         ` Christoph Hellwig
2018-01-10  8:09 ` [PATCH 11/22] swiotlb: remove various exports Christoph Hellwig
2018-01-10  8:09 ` [PATCH 12/22] ia64: replace ZONE_DMA with ZONE_DMA32 Christoph Hellwig
2018-01-10  8:09 ` [PATCH 13/22] ia64: use generic swiotlb_ops Christoph Hellwig
2018-01-10  8:09 ` [PATCH 14/22] ia64: clean up swiotlb support Christoph Hellwig
2018-01-10  8:09 ` [PATCH 15/22] ia64: remove an ifdef around the content of pci-dma.c Christoph Hellwig
2018-01-10  8:09 ` [PATCH 16/22] unicore32: use generic swiotlb_ops Christoph Hellwig
2018-01-10  8:09 ` [PATCH 17/22] tile: replace ZONE_DMA with ZONE_DMA32 Christoph Hellwig
2018-01-10  8:09 ` [PATCH 18/22] tile: use generic swiotlb_ops Christoph Hellwig
2018-01-10  8:09 ` [PATCH 19/22] mips/netlogic: remove swiotlb support Christoph Hellwig
2018-01-10  8:09 ` [PATCH 20/22] mips: use swiotlb_{alloc,free} Christoph Hellwig
2018-01-10  8:09 ` [PATCH 21/22] arm64: replace ZONE_DMA with ZONE_DMA32 Christoph Hellwig
2018-01-10 12:58   ` Robin Murphy
2018-01-10 15:55     ` Christoph Hellwig
2018-01-10 15:55       ` Christoph Hellwig
2018-01-10 17:10         ` Robin Murphy
2018-01-10  8:09 ` [PATCH 22/22] arm64: use swiotlb_alloc and swiotlb_free Christoph Hellwig
2018-01-10 13:16   ` Robin Murphy
2018-01-10  8:23 ` consolidate swiotlb dma_map implementations Christian König
2018-01-16  7:53 ` Christoph Hellwig
2018-01-16  8:22   ` Christian König
2018-01-16  8:28     ` Christoph Hellwig
2018-01-16  8:52       ` Christian König

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=5b14af5b-e6e9-17c5-d433-f50ccb466f90@arm.com \
    --to=robin.murphy@arm.com \
    --cc=ckoenig.leichtzumerken@gmail.com \
    --cc=gxt@mprc.pku.edu.cn \
    --cc=hch@lst.de \
    --cc=iommu@lists.linux-foundation.org \
    --cc=konrad@darnok.org \
    --cc=linux-arch@vger.kernel.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-ia64@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mips@linux-mips.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=monstr@monstr.eu \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®