From: Henrique Carvalho <henrique.carvalho@suse.com>
To: Markus Elfring <Markus.Elfring@web.de>,
linux-cifs@vger.kernel.org, samba-technical@lists.samba.org,
Bharath SM <bharathsm@microsoft.com>,
Paulo Alcantara <pc@manguebit.org>,
Pavel Shilovsky <pshilov@microsoft.com>,
Ronnie Sahlberg <ronniesahlberg@gmail.com>,
Shyam Prasad N <sprasad@microsoft.com>,
Steve French <sfrench@samba.org>, Tom Talpey <tom@talpey.com>
Cc: LKML <linux-kernel@vger.kernel.org>, kernel-janitors@vger.kernel.org
Subject: Re: [PATCH] smb: client: Move an error code assignment in smb3_init_transform_rq()
Date: Wed, 8 Oct 2025 14:17:24 -0300 [thread overview]
Message-ID: <5bd37df6-1743-4b9c-a83a-a811e221489b@suse.com> (raw)
In-Reply-To: <02627021-da2f-41f8-9ea7-fd2da96e0503@web.de>
Hi Markus,
On 10/8/25 2:04 PM, Markus Elfring wrote:
> From: Markus Elfring <elfring@users.sourceforge.net>
> Date: Wed, 8 Oct 2025 18:48:28 +0200
>
> Convert an initialisation for the variable “rc” into an error code
> assignment at the end of this function implementation.
>
> Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
> ---
> fs/smb/client/smb2ops.c | 6 ++++--
> 1 file changed, 4 insertions(+), 2 deletions(-)
>
> diff --git a/fs/smb/client/smb2ops.c b/fs/smb/client/smb2ops.c
> index 7c3e96260fd4..2513270ac596 100644
> --- a/fs/smb/client/smb2ops.c
> +++ b/fs/smb/client/smb2ops.c
> @@ -4596,7 +4596,7 @@ smb3_init_transform_rq(struct TCP_Server_Info *server, int num_rqst,
> {
> struct smb2_transform_hdr *tr_hdr = new_rq[0].rq_iov[0].iov_base;
> unsigned int orig_len = 0;
> - int rc = -ENOMEM;
> + int rc;
>
> for (int i = 1; i < num_rqst; i++) {
> struct smb_rqst *old = &old_rq[i - 1];
> @@ -4611,7 +4611,7 @@ smb3_init_transform_rq(struct TCP_Server_Info *server, int num_rqst,
> if (size > 0) {
> buffer = cifs_alloc_folioq_buffer(size);
> if (!buffer)
> - goto err_free;
> + goto e_nomem;
>
> new->rq_buffer = buffer;
> iov_iter_folio_queue(&new->rq_iter, ITER_SOURCE,
> @@ -4634,6 +4634,8 @@ smb3_init_transform_rq(struct TCP_Server_Info *server, int num_rqst,
>
> return rc;
>
> +e_nomem:
> + rc = -ENOMEM;
> err_free:
> smb3_free_compound_rqst(num_rqst - 1, &new_rq[1]);
> return rc;
I don't think this change improves readability.
I understand that making the assignment explicit is good, but why not
simply set rc to -ENOMEM if !buffer and then goto err_free?
Also, I think its a bit confusing having inconsistent naming styles `e_`
`err_`...
--
Henrique
SUSE Labs
next prev parent reply other threads:[~2025-10-08 17:19 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-10-08 17:04 Markus Elfring
2025-10-08 17:17 ` Henrique Carvalho [this message]
2025-10-08 19:40 ` Markus Elfring
[not found] ` <CAH2r5msZjL_krwN-nd1Ly3skxAHK9srJehPJ_vYXPLRFXpJ_yw@mail.gmail.com>
2025-10-08 21:00 ` Markus Elfring
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=5bd37df6-1743-4b9c-a83a-a811e221489b@suse.com \
--to=henrique.carvalho@suse.com \
--cc=Markus.Elfring@web.de \
--cc=bharathsm@microsoft.com \
--cc=kernel-janitors@vger.kernel.org \
--cc=linux-cifs@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=pc@manguebit.org \
--cc=pshilov@microsoft.com \
--cc=ronniesahlberg@gmail.com \
--cc=samba-technical@lists.samba.org \
--cc=sfrench@samba.org \
--cc=sprasad@microsoft.com \
--cc=tom@talpey.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®