mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Daniel Lezcano <daniel.lezcano@linexp.org>
To: "Rafael J. Wysocki" <rafael@kernel.org>
Cc: Daniel Lezcano <daniel.lezcano@linaro.org>,
	"Zhang, Rui" <rui.zhang@intel.com>,
	Linux PM <linux-pm@vger.kernel.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	Kevin Hilman <khilman@baylibre.com>,
	Alexandre Bailon <abailon@baylibre.com>,
	Lukasz Luba <lukasz.luba@arm.com>,
	Amit Kucheria <amitk@kernel.org>
Subject: Re: [PATCH v5 11/12] thermal/of: Use thermal trips stored in the thermal zone
Date: Thu, 21 Jul 2022 23:29:23 +0200	[thread overview]
Message-ID: <5e9f6d35-08ff-4949-67b0-a2feaab79814@linexp.org> (raw)
In-Reply-To: <CAJZ5v0hTQBXbKNurR0p8_MWmcW-EtezUg1oSNLVEYEAdzpeyBA@mail.gmail.com>

On 19/07/2022 20:26, Rafael J. Wysocki wrote:
> On Sun, Jul 10, 2022 at 2:35 PM Daniel Lezcano
> <daniel.lezcano@linexp.org> wrote:
>> Now that we have the thermal trip stored in the thermal zone in a
>> generic way, we can rely on them and remove one indirection we found
>> in the thermal_of code and do one more step forward the removal of the
>> duplicated structures.
>>
>> Cc: Alexandre Bailon <abailon@baylibre.com>
>> Cc: Kevin Hilman <khilman@baylibre.com>
>> Signed-off-by: Daniel Lezcano <daniel.lezcano@linexp.org>
>> ---
>>   drivers/thermal/thermal_of.c | 53 +++++++++++-------------------------
>>   1 file changed, 16 insertions(+), 37 deletions(-)
>>
>> diff --git a/drivers/thermal/thermal_of.c b/drivers/thermal/thermal_of.c
>> index e187461dd396..601552c55d0b 100644
>> --- a/drivers/thermal/thermal_of.c
>> +++ b/drivers/thermal/thermal_of.c
>> @@ -118,12 +118,7 @@ static int of_thermal_set_trips(struct thermal_zone_device *tz,
>>    */
>>   int of_thermal_get_ntrips(struct thermal_zone_device *tz)
>>   {
>> -       struct __thermal_zone *data = tz->devdata;
>> -
>> -       if (!data || IS_ERR(data))
>> -               return -ENODEV;
>> -
>> -       return data->ntrips;
>> +       return tz->ntrips;
> Hasn't this been renamed to num_trips?

Right, it is changed in patch 12/12



  reply	other threads:[~2022-07-21 21:29 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-07-10 12:34 [PATCH v5 00/12] thermal OF rework Daniel Lezcano
2022-07-10 12:35 ` [PATCH v5 01/12] thermal/core: Remove duplicate information when an error occurs Daniel Lezcano
2022-07-10 12:35 ` [PATCH v5 02/12] thermal/of: Replace device node match with device node search Daniel Lezcano
2022-07-10 12:35 ` [PATCH v5 03/12] thermal/of: Remove the device node pointer for thermal_trip Daniel Lezcano
2022-07-10 12:35 ` [PATCH v5 04/12] thermal/of: Move thermal_trip structure to thermal.h Daniel Lezcano
2022-07-10 12:35 ` [PATCH v5 05/12] thermal/core: Remove unneeded EXPORT_SYMBOLS Daniel Lezcano
2022-07-10 12:35 ` [PATCH v5 06/12] thermal/core: Move thermal_set_delay_jiffies to static Daniel Lezcano
2022-07-10 12:35 ` [PATCH v5 07/12] thermal/core: Rename trips to ntrips Daniel Lezcano
2022-07-19 18:15   ` Rafael J. Wysocki
2022-07-10 12:35 ` [PATCH v5 07/12] thermal/core: Rename 'trips' to 'num_trips' Daniel Lezcano
2022-07-19 18:16   ` Rafael J. Wysocki
2022-07-10 12:35 ` [PATCH v5 08/12] thermal/core: Add thermal_trip in thermal_zone Daniel Lezcano
2022-07-19 18:18   ` Rafael J. Wysocki
2022-07-10 12:35 ` [PATCH v5 09/12] thermal/core: Register with the trip points Daniel Lezcano
2022-07-10 12:35 ` [PATCH v5 10/12] thermal/of: Store the trips in the thermal zone Daniel Lezcano
2022-07-19 18:24   ` Rafael J. Wysocki
2022-07-21 21:31     ` Daniel Lezcano
2022-07-22 16:59       ` Rafael J. Wysocki
2022-07-10 12:35 ` [PATCH v5 11/12] thermal/of: Use thermal trips stored " Daniel Lezcano
2022-07-19 18:26   ` Rafael J. Wysocki
2022-07-21 21:29     ` Daniel Lezcano [this message]
2022-07-22 16:50       ` Rafael J. Wysocki
2022-07-22 17:25         ` Daniel Lezcano
2022-07-10 12:35 ` [PATCH v5 12/12] thermal/of: Initialize trip points separately Daniel Lezcano
2022-07-16 21:56 ` [PATCH v5 00/12] thermal OF rework Daniel Lezcano

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=5e9f6d35-08ff-4949-67b0-a2feaab79814@linexp.org \
    --to=daniel.lezcano@linexp.org \
    --cc=abailon@baylibre.com \
    --cc=amitk@kernel.org \
    --cc=daniel.lezcano@linaro.org \
    --cc=khilman@baylibre.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=lukasz.luba@arm.com \
    --cc=rafael@kernel.org \
    --cc=rui.zhang@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®