From: Joe Perches <joe@perches.com>
To: Michael Straube <straube.linux@gmail.com>, gregkh@linuxfoundation.org
Cc: Larry.Finger@lwfinger.net, phil@philpotter.co.uk,
martin@kaiser.cx, fmdefrancesco@gmail.com,
linux-staging@lists.linux.dev, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/4] staging: r8188eu: refactor rtw_is_cckrates_included()
Date: Mon, 16 Aug 2021 04:14:31 -0700 [thread overview]
Message-ID: <5ec326711eaf178754a02816f20510a7d860b378.camel@perches.com> (raw)
In-Reply-To: <20210816095840.24259-1-straube.linux@gmail.com>
On Mon, 2021-08-16 at 11:58 +0200, Michael Straube wrote:
> Refactor function rtw_is_cckrates_included(). Improves readability
> and slightly reduces object file size.
[]
> diff --git a/drivers/staging/r8188eu/core/rtw_ieee80211.c b/drivers/staging/r8188eu/core/rtw_ieee80211.c
[]
> @@ -70,13 +70,12 @@ int rtw_get_bit_value_from_ieee_value(u8 val)
>
>
> uint rtw_is_cckrates_included(u8 *rate)
> {
> - u32 i = 0;
> + while (*rate) {
> + u8 r = *rate & 0x7f;
>
> - while (rate[i] != 0) {
> - if ((((rate[i]) & 0x7f) == 2) || (((rate[i]) & 0x7f) == 4) ||
> - (((rate[i]) & 0x7f) == 11) || (((rate[i]) & 0x7f) == 22))
> + if (r == 2 || r == 4 || r == 11 || r == 22)
> return true;
> - i++;
> + rate++;
> }
> return false;
> }
Bikeshed:
More compact code with only 1 reference of rate not 3 is more
readable to at least me.
u8 r;
while ((r = *rate++ & 0x7f)) {
if (r == 2 || r == 4 || r == 11 || r == 22)
return true;
}
return false;
And you might make a static inline for the test of r so it could
be reused in the rtw_is_cckratesonly_included function
static inline bool is_cckrate(u8 rate)
{
return rate == 2 || rate == 4 || rate == 11 || rate == 22;
}
so this could be:
u8 r;
while ((r = *rate++ & 0x7f)) {
if (is_cckrate(r))
return true;
}
return false;
prev parent reply other threads:[~2021-08-16 11:14 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-08-16 9:58 Michael Straube
2021-08-16 9:58 ` [PATCH 2/4] staging: r8188eu: convert rtw_is_cckrates_included() to bool Michael Straube
2021-08-16 9:58 ` [PATCH 3/4] staging: r8188eu: refactor rtw_is_cckratesonly_included() Michael Straube
2021-08-16 9:58 ` [PATCH 4/4] staging: r8188eu: convert rtw_is_cckratesonly_included() to bool Michael Straube
2021-08-16 11:14 ` Joe Perches [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=5ec326711eaf178754a02816f20510a7d860b378.camel@perches.com \
--to=joe@perches.com \
--cc=Larry.Finger@lwfinger.net \
--cc=fmdefrancesco@gmail.com \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-staging@lists.linux.dev \
--cc=martin@kaiser.cx \
--cc=phil@philpotter.co.uk \
--cc=straube.linux@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®