From: Mimi Zohar <zohar@linux.ibm.com>
To: Lakshmi Ramasubramanian <nramas@linux.microsoft.com>,
bauerman@linux.ibm.com, robh@kernel.org,
gregkh@linuxfoundation.org, james.morse@arm.com,
catalin.marinas@arm.com, sashal@kernel.org, will@kernel.org,
mpe@ellerman.id.au, benh@kernel.crashing.org, paulus@samba.org,
robh+dt@kernel.org, frowand.list@gmail.com,
vincenzo.frascino@arm.com, mark.rutland@arm.com,
dmitry.kasatkin@gmail.com, jmorris@namei.org, serge@hallyn.com,
pasha.tatashin@soleen.com, allison@lohutok.net,
kstewart@linuxfoundation.org, takahiro.akashi@linaro.org,
tglx@linutronix.de, masahiroy@kernel.org, bhsharma@redhat.com,
mbrugger@suse.com, hsinyi@chromium.org, tao.li@vivo.com,
christophe.leroy@c-s.fr
Cc: linux-integrity@vger.kernel.org, linux-kernel@vger.kernel.org,
devicetree@vger.kernel.org, prsriva@linux.microsoft.com,
balajib@linux.microsoft.com
Subject: Re: [PATCH v8 1/4] powerpc: Refactor kexec functions to move arch independent code to drivers/of
Date: Tue, 03 Nov 2020 14:59:36 -0500 [thread overview]
Message-ID: <5f2d658f63744387fe203bb215968100200b7fb6.camel@linux.ibm.com> (raw)
In-Reply-To: <313e87c1-8f58-b1e0-db3e-950d2ee66927@linux.microsoft.com>
On Tue, 2020-11-03 at 11:15 -0800, Lakshmi Ramasubramanian wrote:
> On 11/3/20 6:55 AM, Mimi Zohar wrote:
>
> Hi Mimi,
>
> Thanks for reviewing the patches.
>
> > On Fri, 2020-10-30 at 10:44 -0700, Lakshmi Ramasubramanian wrote:
> >> The functions remove_ima_buffer() and delete_fdt_mem_rsv() that handle
> >> carrying forward the IMA measurement logs on kexec for powerpc do not
> >> have architecture specific code, but they are currently defined for
> >> powerpc only.
> >
> > ^ ... logs on kexec, do not have architecture specific code, but are
> > currently limited to powerpc.
> Will make this change.
>
> >
> >>
> >> remove_ima_buffer() and delete_fdt_mem_rsv() are used to remove
> >> the IMA log entry from the device tree and free the memory reserved
> >> for the log. These functions need to be defined even if the current
> >> kernel does not support carrying forward IMA log across kexec since
> >> the previous kernel could have supported that and therefore the current
> >> kernel needs to free the allocation.
> >
> > The first paragraph describes these function as "handle carrying
> > forward the IMA measurement logs on kexec", while this paragraph says
> > "are used to remove the IMA log entry". Consider listing all of the
> > functions being moved in the first paragrah, then "handle carrying
> > forward" could be expanded to "carrying ... and removing".
> Sure.
Sorry, even with naming do_get_kexec_buffer(), the measurement list
isn't being carried across kexec. Please adjust the wording.
>
> >
> >>
> >> Rename remove_ima_buffer() to remove_ima_kexec_buffer().
> >> Define remove_ima_kexec_buffer() and delete_fdt_mem_rsv() in
> >> drivers/of/fdt.c. A later patch in this series will use these functions
> >> to free the allocation, if any, made by the previous kernel for ARM64.
> >
> > - ^Define -> Move
> > - Three functions are being moved, but only two are listed.
> > "do_get_kexec_buffer" is not mentioned.
> > - Don't refer to a later patch, but explain the purpose here. For
> > example, "Move ... , making them accessible to other archs."
> Sure.
>
> >
> >>
> >> Define FDT_PROP_IMA_KEXEC_BUFFER for the chosen node, namely
> >> "linux,ima-kexec-buffer", that is added to the DTB to hold
> >> the address and the size of the memory reserved to carry
> >> the IMA measurement log.
> >
> > The above two paragraphs describe renaming a function and defining a
> > chosen node. These two preparatory changes should be made,
> > independently of each other, prior to this patch. This patch should be
> > limited to moving code, with the subject line truncated to "move arch
> > independent code to drivers/of".
> >
>
> Just to be clear -
>
> Split this patch into 3 parts as listed below:
>
> PATCH #1: Rename remove_ima_buffer() to remove_ima_kexec_buffer()
> PATCH #2: Define the chosen node
> PATCH #3: Move the functions to drivers/of/fdt.c
yes, thanks.
Mimi
>
> Sure - I'll make the above changes and update patch descriptions
> accordingly.
next prev parent reply other threads:[~2020-11-03 20:00 UTC|newest]
Thread overview: 19+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-10-30 17:44 [PATCH v8 0/4] Carry forward IMA measurement log on kexec on ARM64 Lakshmi Ramasubramanian
2020-10-30 17:44 ` [PATCH v8 1/4] powerpc: Refactor kexec functions to move arch independent code to drivers/of Lakshmi Ramasubramanian
2020-11-03 14:55 ` Mimi Zohar
2020-11-03 19:15 ` Lakshmi Ramasubramanian
2020-11-03 19:59 ` Mimi Zohar [this message]
2020-11-03 20:07 ` Lakshmi Ramasubramanian
2020-11-04 22:28 ` Rob Herring
2020-11-05 0:46 ` Lakshmi Ramasubramanian
2020-11-05 14:38 ` Rob Herring
2020-11-05 21:54 ` Lakshmi Ramasubramanian
2020-10-30 17:44 ` [PATCH v8 2/4] powerpc: Refactor kexec functions to move arch independent code to ima Lakshmi Ramasubramanian
2020-11-03 14:55 ` Mimi Zohar
2020-11-03 19:23 ` Lakshmi Ramasubramanian
2020-11-03 19:50 ` Mimi Zohar
2020-11-03 20:05 ` Lakshmi Ramasubramanian
2020-10-30 17:44 ` [PATCH v8 3/4] arm64: Store IMA log information in kimage used for kexec Lakshmi Ramasubramanian
2020-10-30 17:44 ` [PATCH v8 4/4] arm64: Add IMA kexec buffer to DTB Lakshmi Ramasubramanian
2020-11-03 15:18 ` [PATCH v8 0/4] Carry forward IMA measurement log on kexec on ARM64 Mimi Zohar
2020-11-03 19:26 ` Lakshmi Ramasubramanian
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=5f2d658f63744387fe203bb215968100200b7fb6.camel@linux.ibm.com \
--to=zohar@linux.ibm.com \
--cc=allison@lohutok.net \
--cc=balajib@linux.microsoft.com \
--cc=bauerman@linux.ibm.com \
--cc=benh@kernel.crashing.org \
--cc=bhsharma@redhat.com \
--cc=catalin.marinas@arm.com \
--cc=christophe.leroy@c-s.fr \
--cc=devicetree@vger.kernel.org \
--cc=dmitry.kasatkin@gmail.com \
--cc=frowand.list@gmail.com \
--cc=gregkh@linuxfoundation.org \
--cc=hsinyi@chromium.org \
--cc=james.morse@arm.com \
--cc=jmorris@namei.org \
--cc=kstewart@linuxfoundation.org \
--cc=linux-integrity@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mark.rutland@arm.com \
--cc=masahiroy@kernel.org \
--cc=mbrugger@suse.com \
--cc=mpe@ellerman.id.au \
--cc=nramas@linux.microsoft.com \
--cc=pasha.tatashin@soleen.com \
--cc=paulus@samba.org \
--cc=prsriva@linux.microsoft.com \
--cc=robh+dt@kernel.org \
--cc=robh@kernel.org \
--cc=sashal@kernel.org \
--cc=serge@hallyn.com \
--cc=takahiro.akashi@linaro.org \
--cc=tao.li@vivo.com \
--cc=tglx@linutronix.de \
--cc=vincenzo.frascino@arm.com \
--cc=will@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome