From: Nikolay Borisov <nik.borisov@suse.com>
To: Chao Gao <chao.gao@intel.com>,
linux-kernel@vger.kernel.org, linux-coco@lists.linux.dev,
kvm@vger.kernel.org, Dave Hansen <dave.hansen@linux.intel.com>
Cc: yilun.xu@linux.intel.com, binbin.wu@linux.intel.com,
tony.lindgren@linux.intel.com, Thomas Gleixner <tglx@kernel.org>,
Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
x86@kernel.org, "H. Peter Anvin" <hpa@zytor.com>,
Kiryl Shutsemau <kas@kernel.org>,
Rick Edgecombe <rick.p.edgecombe@intel.com>
Subject: Re: [PATCH v3 02/10] x86/virt/tdx: Convert the version metadata reader
Date: Thu, 1 Oct 2026 19:24:22 +0300 [thread overview]
Message-ID: <5fe666c8-55ad-4f06-b853-a532d73c35be@suse.com> (raw)
In-Reply-To: <20260930053901.22528-3-chao.gao@intel.com>
On 30.09.26 г. 8:38 ч., Chao Gao wrote:
> With the helper to read a table of metadata fields in place, the
> existing metadata readers can be standardized on it.
>
> Convert the version metadata reader: add a table that pairs each field ID
> with the 'struct tdx_sys_info_version' member that holds its value, and
> read all version fields by walking that table.
>
> Name the field IDs for readability, so the table entries don't carry raw
> hex literals.
>
> AI was used under supervision to review code and workshop logs.
>
> Signed-off-by: Chao Gao <chao.gao@intel.com>
> ---
> v3:
> - Drop the get_tdx_sys_info_*() wrappers to remove an unnecessary layer
> of abstraction. [Rick, Dave]
> - Shorten the field ID defines from TDX_MD_FIELD_ID_* to TDX_FIELD_*
> [Rick]
> ---
> arch/x86/virt/vmx/tdx/tdx.c | 15 ++++++++++++---
> arch/x86/virt/vmx/tdx/tdx.h | 10 ++++++++++
> arch/x86/virt/vmx/tdx/tdx_global_metadata.c | 17 +----------------
> 3 files changed, 23 insertions(+), 19 deletions(-)
>
> diff --git a/arch/x86/virt/vmx/tdx/tdx.c b/arch/x86/virt/vmx/tdx/tdx.c
> index 67a80ed86bd3..9d8a55a5da31 100644
> --- a/arch/x86/virt/vmx/tdx/tdx.c
> +++ b/arch/x86/virt/vmx/tdx/tdx.c
> @@ -408,8 +408,8 @@ struct field_mapping {
> };
>
> /* Read each metadata field listed in @mappings[] into @data. */
> -static int __maybe_unused __read_sys_metadata_table(const struct field_mapping *mappings,
> - int num_mappings, void *data)
> +static int __read_sys_metadata_table(const struct field_mapping *mappings,
> + int num_mappings, void *data)
> {
> int i, ret;
> u64 val;
> @@ -434,6 +434,15 @@ static int __maybe_unused __read_sys_metadata_table(const struct field_mapping *
> .size = sizeof_field(_type, _member), \
> }
>
> +#define TDX_SYSINFO_MAP_VERSION(_field_id, _member) \
> + TDX_SYSINFO_MAP(_field_id, struct tdx_sys_info_version, _member)
nit: I personally dislike adding this level of indirection, albeit
rather shallow just so you don't have to repeat 'struct xxxx' in every
TDX_SYS_INFO_MAP. Same goes for the rest of the patches. In the past I
remember TDX code also suffered from, in my opinion, excessive macro
nesting.
Dave, what's your take on this?
> +
> +static const struct field_mapping version_mappings[] = {
> + TDX_SYSINFO_MAP_VERSION(TDX_FIELD_MINOR_VERSION, minor_version),
> + TDX_SYSINFO_MAP_VERSION(TDX_FIELD_MAJOR_VERSION, major_version),
> + TDX_SYSINFO_MAP_VERSION(TDX_FIELD_UPDATE_VERSION, update_version),
> +};
> +
<snip>
next prev parent reply other threads:[~2026-10-01 16:24 UTC|newest]
Thread overview: 28+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-30 5:38 [PATCH v3 00/10] TDX: Stop auto-generating the global metadata code Chao Gao
2026-09-30 5:38 ` [PATCH v3 01/10] x86/virt/tdx: Add a helper to read a table of metadata fields Chao Gao
2026-10-01 0:30 ` Edgecombe, Rick P
2026-10-01 16:19 ` Nikolay Borisov
2026-09-30 5:38 ` [PATCH v3 02/10] x86/virt/tdx: Convert the version metadata reader Chao Gao
2026-10-01 0:30 ` Edgecombe, Rick P
2026-10-01 16:24 ` Nikolay Borisov [this message]
2026-10-01 16:27 ` Dave Hansen
2026-09-30 5:38 ` [PATCH v3 03/10] x86/virt/tdx: Convert the features " Chao Gao
2026-10-01 0:30 ` Edgecombe, Rick P
2026-09-30 5:38 ` [PATCH v3 04/10] x86/virt/tdx: Convert the tdmr " Chao Gao
2026-10-01 0:31 ` Edgecombe, Rick P
2026-09-30 5:38 ` [PATCH v3 05/10] x86/virt/tdx: Convert the td_ctrl " Chao Gao
2026-10-01 0:31 ` Edgecombe, Rick P
2026-09-30 5:38 ` [PATCH v3 06/10] x86/virt/tdx: Convert the handoff " Chao Gao
2026-10-01 0:31 ` Edgecombe, Rick P
2026-09-30 5:38 ` [PATCH v3 07/10] x86/virt/tdx: Convert the td_conf " Chao Gao
2026-09-30 23:54 ` Edgecombe, Rick P
2026-10-01 12:08 ` Chao Gao
2026-10-01 16:34 ` Nikolay Borisov
2026-10-01 20:28 ` Edgecombe, Rick P
2026-09-30 5:38 ` [PATCH v3 08/10] x86/virt/tdx: Remove tdx_global_metadata.c Chao Gao
2026-09-30 5:38 ` [PATCH v3 09/10] x86/virt/tdx: Use early returns in get_tdx_sys_info() Chao Gao
2026-10-01 0:30 ` Edgecombe, Rick P
2026-10-01 13:05 ` Chao Gao
2026-09-30 5:38 ` [PATCH v3 10/10] x86/virt/tdx: Verify structure member sizes against metadata field IDs Chao Gao
2026-10-01 0:29 ` Edgecombe, Rick P
2026-10-01 13:01 ` Chao Gao
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=5fe666c8-55ad-4f06-b853-a532d73c35be@suse.com \
--to=nik.borisov@suse.com \
--cc=binbin.wu@linux.intel.com \
--cc=bp@alien8.de \
--cc=chao.gao@intel.com \
--cc=dave.hansen@linux.intel.com \
--cc=hpa@zytor.com \
--cc=kas@kernel.org \
--cc=kvm@vger.kernel.org \
--cc=linux-coco@lists.linux.dev \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=rick.p.edgecombe@intel.com \
--cc=tglx@kernel.org \
--cc=tony.lindgren@linux.intel.com \
--cc=x86@kernel.org \
--cc=yilun.xu@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®