From: "Arnd Bergmann" <arnd@arndb.de>
To: pzalewski@thegoodpenguin.co.uk,
"Clemens Ladisch" <clemens@ladisch.de>,
"Greg Kroah-Hartman" <gregkh@linuxfoundation.org>,
"Mattia Dongili" <malattia@linux.it>,
"Weili Qian" <qianweili@huawei.com>,
"Olivia Mackall" <olivia@selenic.com>,
"Herbert Xu" <herbert@gondor.apana.org.au>,
"Corey Minyard" <corey@minyard.net>,
"Peter Huewe" <peterhuewe@gmx.de>,
"Jarkko Sakkinen" <jarkko@kernel.org>,
"Jason Gunthorpe" <jgg@ziepe.ca>
Cc: linux-kernel@vger.kernel.org,
platform-driver-x86@vger.kernel.org,
linux-crypto@vger.kernel.org,
openipmi-developer@lists.sourceforge.net,
linux-integrity@vger.kernel.org
Subject: Re: [PATCH 1/4] char: use named initializers for acpi_device_id
Date: Fri, 07 Aug 2026 14:26:12 +0200 [thread overview]
Message-ID: <60e25773-b3c6-4aae-a687-92e1ab3b141e@app.fastmail.com> (raw)
In-Reply-To: <20260807-acpi-char-v1-1-742c450254dd@thegoodpenguin.co.uk>
On Fri, Aug 7, 2026, at 13:26, Pawel Zalewski via B4 Relay wrote:
> From: "Pawel Zalewski (The Capable Hub)" <pzalewski@thegoodpenguin.co.uk>
>
> Use a named initializer for the acpi_device_id fields which
> makes the code more readable and consistent with how lists
> are initialized in the rest of the kernel code base. Also
> drop explicitly setting fields to 0 where it is redundant.
>
> While we are at it - unify the list terminator to have
> a single space between the brackets and no trailing
> comma.
>
> Signed-off-by: Pawel Zalewski (The Capable Hub) <pzalewski@thegoodpenguin.co.uk>
I don't think this is the right approach: I see around 1500 instances
of acpi_device_id data with plain initializers and only about 50
with named ones. Converting all of them seems like a lot of
extra work, and I'm fairly sure you can just change the
driver_data to an anonymous union without this.
Arnd
next prev parent reply other threads:[~2026-08-07 12:27 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-07 11:26 [PATCH 0/4] " Pawel Zalewski via B4 Relay
2026-08-07 11:26 ` [PATCH 1/4] " Pawel Zalewski via B4 Relay
2026-08-07 12:26 ` Arnd Bergmann [this message]
2026-09-03 7:15 ` Pawel Zalewski
2026-08-07 11:26 ` [PATCH 2/4] char: hw_random: " Pawel Zalewski via B4 Relay
2026-08-15 1:30 ` Herbert Xu
2026-08-07 11:26 ` [PATCH 3/4] char: ipmi: " Pawel Zalewski via B4 Relay
2026-08-07 11:40 ` Corey Minyard
2026-08-07 11:26 ` [PATCH 4/4] char: tpm: " Pawel Zalewski via B4 Relay
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=60e25773-b3c6-4aae-a687-92e1ab3b141e@app.fastmail.com \
--to=arnd@arndb.de \
--cc=clemens@ladisch.de \
--cc=corey@minyard.net \
--cc=gregkh@linuxfoundation.org \
--cc=herbert@gondor.apana.org.au \
--cc=jarkko@kernel.org \
--cc=jgg@ziepe.ca \
--cc=linux-crypto@vger.kernel.org \
--cc=linux-integrity@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=malattia@linux.it \
--cc=olivia@selenic.com \
--cc=openipmi-developer@lists.sourceforge.net \
--cc=peterhuewe@gmx.de \
--cc=platform-driver-x86@vger.kernel.org \
--cc=pzalewski@thegoodpenguin.co.uk \
--cc=qianweili@huawei.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®