From: "CK Hu (胡俊光)" <ck.hu@mediatek.com>
To: AngeloGioacchino Del Regno
<angelogioacchino.delregno@collabora.com>,
"chunkuang.hu@kernel.org" <chunkuang.hu@kernel.org>
Cc: "robh@kernel.org" <robh@kernel.org>,
"jie.qiu@mediatek.com" <jie.qiu@mediatek.com>,
"tzimmermann@suse.de" <tzimmermann@suse.de>,
"simona@ffwll.ch" <simona@ffwll.ch>,
"mripard@kernel.org" <mripard@kernel.org>,
"Jitao Shi (石记涛)" <jitao.shi@mediatek.com>,
"linux-mediatek@lists.infradead.org"
<linux-mediatek@lists.infradead.org>,
"dri-devel@lists.freedesktop.org"
<dri-devel@lists.freedesktop.org>,
"maarten.lankhorst@linux.intel.com"
<maarten.lankhorst@linux.intel.com>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"devicetree@vger.kernel.org" <devicetree@vger.kernel.org>,
"kernel@collabora.com" <kernel@collabora.com>,
"dmitry.baryshkov@linaro.org" <dmitry.baryshkov@linaro.org>,
"krzk+dt@kernel.org" <krzk+dt@kernel.org>,
"Lewis Liao (廖柏鈞)" <Lewis.Liao@mediatek.com>,
"p.zabel@pengutronix.de" <p.zabel@pengutronix.de>,
"conor+dt@kernel.org" <conor+dt@kernel.org>,
"TommyYL Chen (陳彥良)" <TommyYL.Chen@mediatek.com>,
"Ives Chenjh (陳俊弘)" <Ives.Chenjh@mediatek.com>,
"airlied@gmail.com" <airlied@gmail.com>,
"linux-arm-kernel@lists.infradead.org"
<linux-arm-kernel@lists.infradead.org>,
"matthias.bgg@gmail.com" <matthias.bgg@gmail.com>,
"Jason-JH Lin (林睿祥)" <Jason-JH.Lin@mediatek.com>,
"junzhi.zhao@mediatek.com" <junzhi.zhao@mediatek.com>
Subject: Re: [PATCH v7 36/43] drm/mediatek: mtk_hdmi: Split driver and add common probe function
Date: Thu, 27 Feb 2025 05:56:53 +0000 [thread overview]
Message-ID: <623a5cee0e64cb85f9156364c0ee3e4be937e57c.camel@mediatek.com> (raw)
In-Reply-To: <20250217154836.108895-37-angelogioacchino.delregno@collabora.com>
On Mon, 2025-02-17 at 16:48 +0100, AngeloGioacchino Del Regno wrote:
> External email : Please do not click links or open attachments until you have verified the sender or the content.
>
>
> In preparation for adding a new driver for the HDMI TX v2 IP,
> split out the functions that will be common between the already
> present mtk_hdmi (v1) driver and the new one.
>
> Since the probe flow for both drivers is 90% similar, add a common
> probe function that will be called from each driver's .probe()
> callback, avoiding lots of code duplication.
>
> Signed-off-by: AngeloGioacchino Del Regno <angelogioacchino.delregno@collabora.com>
> ---
> drivers/gpu/drm/mediatek/Kconfig | 11 +-
> drivers/gpu/drm/mediatek/Makefile | 1 +
> drivers/gpu/drm/mediatek/mtk_hdmi.c | 542 +--------------------
> drivers/gpu/drm/mediatek/mtk_hdmi_common.c | 426 ++++++++++++++++
> drivers/gpu/drm/mediatek/mtk_hdmi_common.h | 188 +++++++
> 5 files changed, 633 insertions(+), 535 deletions(-)
> create mode 100644 drivers/gpu/drm/mediatek/mtk_hdmi_common.c
> create mode 100644 drivers/gpu/drm/mediatek/mtk_hdmi_common.h
>
> diff --git a/drivers/gpu/drm/mediatek/Kconfig b/drivers/gpu/drm/mediatek/Kconfig
> index e47debd60619..994b48b82d44 100644
> --- a/drivers/gpu/drm/mediatek/Kconfig
> +++ b/drivers/gpu/drm/mediatek/Kconfig
> @@ -30,9 +30,18 @@ config DRM_MEDIATEK_DP
> help
> DRM/KMS Display Port driver for MediaTek SoCs.
>
> +config DRM_MEDIATEK_HDMI_COMMON
> + tristate
> + depends on DRM_MEDIATEK
> + select DRM_DISPLAY_HDMI_HELPER
> + select DRM_DISPLAY_HELPER
> + select SND_SOC_HDMI_CODEC if SND_SOC
> + help
> + MediaTek SoC HDMI common library
> +
> config DRM_MEDIATEK_HDMI
> tristate "DRM HDMI Support for Mediatek SoCs"
> depends on DRM_MEDIATEK
> - select SND_SOC_HDMI_CODEC if SND_SOC
> + select DRM_MEDIATEK_HDMI_COMMON
> help
> DRM/KMS HDMI driver for Mediatek SoCs
> diff --git a/drivers/gpu/drm/mediatek/Makefile b/drivers/gpu/drm/mediatek/Makefile
> index 43afd0a26d14..78cf2d4fc85f 100644
> --- a/drivers/gpu/drm/mediatek/Makefile
> +++ b/drivers/gpu/drm/mediatek/Makefile
> @@ -21,6 +21,7 @@ mediatek-drm-y := mtk_crtc.o \
>
> obj-$(CONFIG_DRM_MEDIATEK) += mediatek-drm.o
>
> +obj-$(CONFIG_DRM_MEDIATEK_HDMI_COMMON) += mtk_hdmi_common.o
The whole patch looks good to me.
But make common part to a module looks a little bit more modularized.
Let things to be simple, I would like the whole MediaTek hdmi driver be a single module.
For MediaTek drm driver, it is already broken to mediatek-drm, hdmi, dp modules.
Maybe someday dsi or dpi would be broken to modules.
So I would like hdmi to be a single module which include v1, v2 and common part.
If someday we need to optimize code size, then send patch to break hdmi module.
Regards,
CK
> obj-$(CONFIG_DRM_MEDIATEK_HDMI) += mtk_cec.o
> obj-$(CONFIG_DRM_MEDIATEK_HDMI) += mtk_hdmi.o
> obj-$(CONFIG_DRM_MEDIATEK_HDMI) += mtk_hdmi_ddc.o
> diff --git a/drivers/gpu/drm/mediatek/mtk_hdmi.c b/drivers/gpu/drm/mediatek/mtk_hdmi.c
>
next prev parent reply other threads:[~2025-02-27 5:57 UTC|newest]
Thread overview: 74+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-02-17 15:47 [PATCH v7 00/43] Add support for MT8195/88 DPI, HDMIv2 and DDCv2 AngeloGioacchino Del Regno
2025-02-17 15:47 ` [PATCH v7 01/43] dt-bindings: display: mediatek: dpi: Add MT8195 and MT8188 compat AngeloGioacchino Del Regno
2025-03-02 10:34 ` Chun-Kuang Hu
2025-02-17 15:47 ` [PATCH v7 02/43] drm/mediatek: mtk_dpi: Add support for Pattern Generator in debugfs AngeloGioacchino Del Regno
2025-03-02 10:38 ` Chun-Kuang Hu
2025-02-17 15:47 ` [PATCH v7 03/43] drm/mediatek: mtk_dpi: Use an array for pixclk factor calculation AngeloGioacchino Del Regno
2025-03-02 10:53 ` Chun-Kuang Hu
2025-03-02 11:03 ` Chun-Kuang Hu
2025-02-17 15:47 ` [PATCH v7 04/43] drm/mediatek: mtk_dpi: Move pixel clock setting flow to function AngeloGioacchino Del Regno
2025-03-02 11:08 ` Chun-Kuang Hu
2025-02-17 15:47 ` [PATCH v7 05/43] drm/mediatek: mtk_dpi: Add checks for reg_h_fre_con existence AngeloGioacchino Del Regno
2025-03-02 11:06 ` Chun-Kuang Hu
2025-02-17 15:47 ` [PATCH v7 06/43] drm/mediatek: mtk_dpi: Move the input_2p_en bit to platform data AngeloGioacchino Del Regno
2025-03-02 11:14 ` Chun-Kuang Hu
2025-02-17 15:48 ` [PATCH v7 07/43] drm/mediatek: mtk_dpi: Add support for DPI input clock from HDMI AngeloGioacchino Del Regno
2025-02-27 3:45 ` CK Hu (胡俊光)
2025-03-02 11:24 ` Chun-Kuang Hu
2025-02-17 15:48 ` [PATCH v7 08/43] drm/mediatek: mtk_dpi: Support AFIFO 1T1P output and conversion AngeloGioacchino Del Regno
2025-03-02 11:29 ` Chun-Kuang Hu
2025-03-02 14:01 ` Chun-Kuang Hu
2025-02-17 15:48 ` [PATCH v7 09/43] drm/mediatek: mtk_dpi: Explicitly manage TVD clock in power on/off AngeloGioacchino Del Regno
2025-03-02 14:05 ` Chun-Kuang Hu
2025-02-17 15:48 ` [PATCH v7 10/43] drm/mediatek: Add support for MT8195 Digital Parallel Interface AngeloGioacchino Del Regno
2025-03-02 14:14 ` Chun-Kuang Hu
2025-02-17 15:48 ` [PATCH v7 11/43] dt-bindings: display: mediatek: Add binding for HDMIv2 DDC AngeloGioacchino Del Regno
2025-02-17 15:48 ` [PATCH v7 12/43] dt-bindings: display: mediatek: Add binding for MT8195 HDMI-TX v2 AngeloGioacchino Del Regno
2025-02-27 5:36 ` CK Hu (胡俊光)
2025-02-17 15:48 ` [PATCH v7 13/43] drm/mediatek: mtk_cec: Switch to register as module_platform_driver AngeloGioacchino Del Regno
2025-02-17 15:48 ` [PATCH v7 14/43] drm/mediatek: mtk_hdmi_ddc: " AngeloGioacchino Del Regno
2025-02-17 15:48 ` [PATCH v7 15/43] drm/mediatek: mtk_hdmi: Convert to module_platform_driver macro AngeloGioacchino Del Regno
2025-02-17 15:48 ` [PATCH v7 16/43] drm/mediatek: mtk_hdmi: Compress of_device_id array entries AngeloGioacchino Del Regno
2025-02-19 14:14 ` Chun-Kuang Hu
2025-02-17 15:48 ` [PATCH v7 17/43] drm/mediatek: mtk_hdmi: Unregister audio platform device on failure AngeloGioacchino Del Regno
2025-02-19 14:01 ` Chun-Kuang Hu
2025-02-17 15:48 ` [PATCH v7 18/43] drm/mediatek: hdmi: Use regmap instead of iomem for main registers AngeloGioacchino Del Regno
2025-02-17 15:48 ` [PATCH v7 19/43] drm/mediatek: mtk_hdmi: Fix typo for aud_sampe_size member AngeloGioacchino Del Regno
2025-02-19 14:06 ` Chun-Kuang Hu
2025-02-17 15:48 ` [PATCH v7 20/43] drm/mediatek: mtk_hdmi: Disgregate function mtk_hdmi_audio_set_param() AngeloGioacchino Del Regno
2025-02-17 15:48 ` [PATCH v7 21/43] drm/mediatek: mtk_hdmi: Move audio params selection to new function AngeloGioacchino Del Regno
2025-02-17 15:48 ` [PATCH v7 22/43] drm/mediatek: mtk_hdmi: Move plugged_cb/codec_dev setting " AngeloGioacchino Del Regno
2025-02-17 15:48 ` [PATCH v7 23/43] drm/mediatek: mtk_hdmi: Move N/CTS " AngeloGioacchino Del Regno
2025-02-17 15:48 ` [PATCH v7 24/43] drm/mediatek: mtk_hdmi: Move vendor/product strings to drm_bridge AngeloGioacchino Del Regno
2025-02-19 14:23 ` Chun-Kuang Hu
2025-02-17 15:48 ` [PATCH v7 25/43] drm/mediatek: mtk_hdmi: Use dev_err_probe() in mtk_hdmi_dt_parse_pdata() AngeloGioacchino Del Regno
2025-02-27 5:42 ` CK Hu (胡俊光)
2025-02-17 15:48 ` [PATCH v7 26/43] drm/mediatek: mtk_hdmi: Move CEC device parsing in new function AngeloGioacchino Del Regno
2025-02-17 15:48 ` [PATCH v7 27/43] drm/mediatek: mtk_hdmi: Remove unused members of struct mtk_hdmi AngeloGioacchino Del Regno
2025-02-20 14:02 ` Chun-Kuang Hu
2025-02-17 15:48 ` [PATCH v7 28/43] drm/mediatek: mtk_hdmi: Move output init to mtk_hdmi_register_audio_driver() AngeloGioacchino Del Regno
2025-02-17 15:48 ` [PATCH v7 29/43] drm/mediatek: mtk_hdmi: Use devm managed version of drm_bridge_add AngeloGioacchino Del Regno
2025-02-20 14:10 ` Chun-Kuang Hu
2025-02-17 15:48 ` [PATCH v7 30/43] drm/mediatek: mtk_hdmi: Remove ifdef for CONFIG_PM_SLEEP AngeloGioacchino Del Regno
2025-02-20 14:17 ` Chun-Kuang Hu
2025-02-17 15:48 ` [PATCH v7 31/43] drm/mediatek: mtk_hdmi: Remove goto in mtk_hdmi_clk_enable_audio() AngeloGioacchino Del Regno
2025-02-20 14:22 ` Chun-Kuang Hu
2025-02-17 15:48 ` [PATCH v7 32/43] drm/mediatek: mtk_hdmi: Remove driver bound to HDMI print AngeloGioacchino Del Regno
2025-02-20 14:26 ` Chun-Kuang Hu
2025-02-17 15:48 ` [PATCH v7 33/43] drm/mediatek: mtk_hdmi: Cleanup function mtk_hdmi_resume() AngeloGioacchino Del Regno
2025-02-20 14:32 ` Chun-Kuang Hu
2025-02-17 15:48 ` [PATCH v7 34/43] drm/mediatek: mtk_hdmi: Improve mtk_hdmi_get_all_clk() flexibility AngeloGioacchino Del Regno
2025-02-17 15:48 ` [PATCH v7 35/43] drm/mediatek: mtk_hdmi: Add HDMI IP version configuration to pdata AngeloGioacchino Del Regno
2025-02-17 15:48 ` [PATCH v7 36/43] drm/mediatek: mtk_hdmi: Split driver and add common probe function AngeloGioacchino Del Regno
2025-02-27 5:56 ` CK Hu (胡俊光) [this message]
2025-02-17 15:48 ` [PATCH v7 37/43] drm/mediatek: mtk_hdmi_common: Make CEC support optional AngeloGioacchino Del Regno
2025-02-17 15:48 ` [PATCH v7 38/43] drm/mediatek: mtk_hdmi_common: Assign DDC adapter pointer to bridge AngeloGioacchino Del Regno
2025-02-17 15:48 ` [PATCH v7 39/43] drm/mediatek: mtk_hdmi_common: Add OP_HDMI if helper funcs assigned AngeloGioacchino Del Regno
2025-02-17 15:48 ` [PATCH v7 40/43] drm/mediatek: mtk_hdmi_common: Add var to enable interlaced modes AngeloGioacchino Del Regno
2025-02-17 15:48 ` [PATCH v7 41/43] drm/mediatek: Introduce HDMI/DDC v2 for MT8195/MT8188 AngeloGioacchino Del Regno
2025-02-27 8:17 ` CK Hu (胡俊光)
2025-02-17 15:48 ` [PATCH v7 42/43] drm/mediatek: mtk_hdmi_v2: Add debugfs ops and implement ABIST AngeloGioacchino Del Regno
2025-02-27 5:59 ` CK Hu (胡俊光)
2025-02-17 15:48 ` [PATCH v7 43/43] drm/mediatek/hdmi: Use syscon_regmap_lookup_by_phandle_args AngeloGioacchino Del Regno
2025-02-27 6:01 ` CK Hu (胡俊光)
2025-02-25 9:17 ` [PATCH v7 00/43] Add support for MT8195/88 DPI, HDMIv2 and DDCv2 AngeloGioacchino Del Regno
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=623a5cee0e64cb85f9156364c0ee3e4be937e57c.camel@mediatek.com \
--to=ck.hu@mediatek.com \
--cc=Ives.Chenjh@mediatek.com \
--cc=Jason-JH.Lin@mediatek.com \
--cc=Lewis.Liao@mediatek.com \
--cc=TommyYL.Chen@mediatek.com \
--cc=airlied@gmail.com \
--cc=angelogioacchino.delregno@collabora.com \
--cc=chunkuang.hu@kernel.org \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=dmitry.baryshkov@linaro.org \
--cc=dri-devel@lists.freedesktop.org \
--cc=jie.qiu@mediatek.com \
--cc=jitao.shi@mediatek.com \
--cc=junzhi.zhao@mediatek.com \
--cc=kernel@collabora.com \
--cc=krzk+dt@kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mediatek@lists.infradead.org \
--cc=maarten.lankhorst@linux.intel.com \
--cc=matthias.bgg@gmail.com \
--cc=mripard@kernel.org \
--cc=p.zabel@pengutronix.de \
--cc=robh@kernel.org \
--cc=simona@ffwll.ch \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®