mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Jacek Anaszewski <jacek.anaszewski@gmail.com>
To: Dan Murphy <dmurphy@ti.com>, pavel@ucw.cz
Cc: linux-leds@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v20 03/17] leds: multicolor: Introduce a multicolor class definition
Date: Sun, 26 Apr 2020 18:46:20 +0200	[thread overview]
Message-ID: <625e1659-5e8e-f3db-3bdb-7c492dca0403@gmail.com> (raw)
In-Reply-To: <20200423155524.13971-4-dmurphy@ti.com>

Hi Dan,

On 4/23/20 5:55 PM, Dan Murphy wrote:
> Introduce a multicolor class that groups colored LEDs
> within a LED node.
> 
> The multi color class groups monochrome LEDs and allows controlling two
> aspects of the final combined color: hue and lightness. The former is
> controlled via color_intensity file and the latter is controlled
> via brightness file.
> 
> Signed-off-by: Dan Murphy <dmurphy@ti.com>
> ---
> 
> v20 - Change color_ file names to multi_led, dynamically allocate the
> multicolor_info struct.  Fixed documentation issues from Randy D.
> 
[...]
> +MODULE_AUTHOR("Dan Murphy <dmurphy@ti.com>");
> +MODULE_DESCRIPTION("Multi Color LED class interface");
> +MODULE_LICENSE("GPL v2");
> diff --git a/include/linux/led-class-multicolor.h b/include/linux/led-class-multicolor.h
> new file mode 100644
> index 000000000000..7c5befb270f8
> --- /dev/null
> +++ b/include/linux/led-class-multicolor.h
> @@ -0,0 +1,121 @@
> +/* SPDX-License-Identifier: GPL-2.0 */
> +/* LED Multicolor class interface
> + * Copyright (C) 2019-20 Texas Instruments Incorporated - http://www.ti.com/
> + */
> +
> +#ifndef __LINUX_MULTICOLOR_LEDS_H_INCLUDED
> +#define __LINUX_MULTICOLOR_LEDS_H_INCLUDED
> +
> +#include <linux/leds.h>
> +#include <dt-bindings/leds/common.h>
> +
> +struct led_mc_subled {
> +	int color_index;
> +	int color_brightness;
> +	int color_led_intensity;
> +	int color_channel;
> +};
> +
> +struct led_classdev_mc {
> +	/* led class device */
> +	struct led_classdev led_cdev;
> +	int num_colors;
> +
> +	struct led_mc_subled *multicolor_info;

I think mc_subleds (or even subleds alone - we are already in
led_classdev_*mc*) would be way more informative name for this
property.

And as already proposed in the other message:

s/color_led_intensity/color_intensity/

Also, I would like to have just "brightness" instead
of color_brightness, which is ambiguous. And having brightness
in this struct led_mc_subled would clearly state that this is
the value to be written to the hardware similarly as is
struct led_classdev's brightness for monochrome LEDs.

-- 
Best regards,
Jacek Anaszewski

  parent reply	other threads:[~2020-04-26 16:46 UTC|newest]

Thread overview: 44+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-04-23 15:55 [PATCH v20 00/17] Multicolor Framework (array edition) Dan Murphy
2020-04-23 15:55 ` [PATCH v20 01/17] dt: bindings: Add multicolor class dt bindings documention Dan Murphy
2020-04-23 15:55 ` [PATCH v20 02/17] leds: Add multicolor ID to the color ID list Dan Murphy
2020-04-25 19:52   ` Pavel Machek
2020-04-27 17:12     ` Dan Murphy
2020-04-28  8:43       ` Pavel Machek
2020-04-28 12:02         ` Dan Murphy
2020-04-23 15:55 ` [PATCH v20 03/17] leds: multicolor: Introduce a multicolor class definition Dan Murphy
2020-04-25 19:53   ` Pavel Machek
2020-04-27 17:12     ` Dan Murphy
2020-04-25 20:23   ` Pavel Machek
2020-04-26 16:24     ` Jacek Anaszewski
2020-04-26 19:48       ` Pavel Machek
2020-04-27 19:33     ` Dan Murphy
2020-04-28  8:41       ` Pavel Machek
2020-04-26 16:46   ` Jacek Anaszewski [this message]
2020-04-23 15:55 ` [PATCH v20 04/17] dt: bindings: lp50xx: Introduce the lp50xx family of RGB drivers Dan Murphy
2020-04-25 20:24   ` Pavel Machek
2020-04-27 19:02     ` Dan Murphy
2020-04-23 15:55 ` [PATCH v20 05/17] leds: lp50xx: Add the LP50XX family of the RGB LED driver Dan Murphy
2020-04-23 15:55 ` [PATCH v20 06/17] dt: bindings: lp55xx: Be consistent in the document with LED acronym Dan Murphy
2020-04-23 15:55 ` [PATCH v20 07/17] dt: bindings: lp55xx: Update binding for Multicolor Framework Dan Murphy
2020-04-23 15:55 ` [PATCH v20 08/17] ARM: dts: n900: Add reg property to the LP5523 channel node Dan Murphy
2020-04-23 15:55 ` [PATCH v20 09/17] ARM: dts: imx6dl-yapp4: Add reg property to the lp5562 " Dan Murphy
2020-04-25 20:31   ` Pavel Machek
2020-04-23 15:55 ` [PATCH v20 10/17] ARM: dts: ste-href: Add reg property to the LP5521 channel nodes Dan Murphy
2020-04-27 19:06   ` Dan Murphy
2020-04-23 15:55 ` [PATCH v20 11/17] leds: lp55xx: Convert LED class registration to devm_* Dan Murphy
2020-04-23 15:55 ` [PATCH v20 12/17] leds: lp55xx: Add multicolor framework support to lp55xx Dan Murphy
2020-04-25 20:37   ` Pavel Machek
2020-04-26 16:07   ` Jacek Anaszewski
2020-04-27 18:17     ` Dan Murphy
2020-04-27 19:42       ` Jacek Anaszewski
2020-04-27 19:58         ` Dan Murphy
2020-04-23 15:55 ` [PATCH v20 13/17] leds: lp5523: Update the lp5523 code to add multicolor brightness function Dan Murphy
2020-04-25 20:38   ` Pavel Machek
2020-04-23 15:55 ` [PATCH v20 14/17] leds: lp5521: Add multicolor framework multicolor brightness support Dan Murphy
2020-04-25 20:39   ` Pavel Machek
2020-04-23 15:55 ` [PATCH v20 15/17] leds: lp55xx: Fix checkpatch file permissions issues Dan Murphy
2020-04-23 15:55 ` [PATCH v20 16/17] leds: lp5523: Fix checkpatch issues in the code Dan Murphy
2020-04-23 15:55 ` [PATCH v20 17/17] dt: bindings: Update lp55xx binding to recommended LED naming Dan Murphy
2020-04-25 20:48 ` [PATCH v20 00/17] Multicolor Framework (array edition) Pavel Machek
2020-04-27 17:18   ` Dan Murphy
2020-04-27 19:05     ` Dan Murphy

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=625e1659-5e8e-f3db-3bdb-7c492dca0403@gmail.com \
    --to=jacek.anaszewski@gmail.com \
    --cc=dmurphy@ti.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-leds@vger.kernel.org \
    --cc=pavel@ucw.cz \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®