From: Dan Williams <dan.j.williams@intel.com>
To: Jane Chu <jane.chu@oracle.com>, <dan.j.williams@intel.com>,
<linux-kernel@vger.kernel.org>, <hch@lst.de>,
<nvdimm@lists.linux.dev>
Subject: RE: [PATCH v2] pmem: fix a name collision
Date: Tue, 12 Jul 2022 17:53:05 -0700 [thread overview]
Message-ID: <62ce1771b331c_6070c294a6@dwillia2-xfh.jf.intel.com.notmuch> (raw)
In-Reply-To: <20220630182802.3250449-1-jane.chu@oracle.com>
Jane Chu wrote:
> Kernel test robot detected name collision when compiled on 'um'
> architecture. Rename "to_phys()" to "pmem_to_phys()".
>
> >> drivers/nvdimm/pmem.c:48:20: error: conflicting types for 'to_phys'; have 'phys_addr_t(struct pmem_device *, phys_addr_t)' {aka 'long long unsigned int(struct pmem_device *, long long unsigned int)'}
> 48 | static phys_addr_t to_phys(struct pmem_device *pmem, phys_addr_t offset)
> | ^~~~~~~
> In file included from arch/um/include/asm/page.h:98,
> from arch/um/include/asm/thread_info.h:15,
> from include/linux/thread_info.h:60,
> from include/asm-generic/preempt.h:5,
> from ./arch/um/include/generated/asm/preempt.h:1,
>
> arch/um/include/shared/mem.h:12:29: note: previous definition of 'to_phys' with type 'long unsigned int(void *)'
> 12 | static inline unsigned long to_phys(void *virt)
> | ^~~~~~~
>
> vim +48 drivers/nvdimm/pmem.c
> 47
> > 48 static phys_addr_t to_phys(struct pmem_device *pmem, phys_addr_t offset)
> 49 {
> 50 return pmem->phys_addr + offset;
> 51 }
> 52
>
> Fixes: 9409c9b6709e (pmem: refactor pmem_clear_poison())
> Reported-by: kernel test robot <lkp@intel.com>
> Signed-off-by: Jane Chu <jane.chu@oracle.com>
Applied. Sorry for the delay, catching up after vacation.
prev parent reply other threads:[~2022-07-13 0:53 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-06-30 18:28 Jane Chu
2022-06-30 18:29 ` Christoph Hellwig
2022-06-30 18:34 ` Jane Chu
2022-07-13 0:53 ` Dan Williams [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=62ce1771b331c_6070c294a6@dwillia2-xfh.jf.intel.com.notmuch \
--to=dan.j.williams@intel.com \
--cc=hch@lst.de \
--cc=jane.chu@oracle.com \
--cc=linux-kernel@vger.kernel.org \
--cc=nvdimm@lists.linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®