mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Dan Williams <dan.j.williams@intel.com>
To: Guenter Roeck <linux@roeck-us.net>, Richard Weinberger <richard@nod.at>
Cc: Anton Ivanov <anton.ivanov@cambridgegreys.com>,
	Johannes Berg <johannes@sipsolutions.net>,
	Linus Torvalds <torvalds@linux-foundation.org>,
	<linux-um@lists.infradead.org>, <linux-kernel@vger.kernel.org>,
	Guenter Roeck <linux@roeck-us.net>,
	Dan Williams <dan.j.williams@intel.com>,
	"Christoph Hellwig" <hch@lst.de>, <jane.chu@oracle.com>
Subject: RE: [PATCH] um: Replace to_phys() and to_virt() with less generic function names
Date: Thu, 14 Jul 2022 13:23:45 -0700	[thread overview]
Message-ID: <62d07b5120291_16fb97294fb@dwillia2-xfh.jf.intel.com.notmuch> (raw)
In-Reply-To: <20220714184600.3981953-1-linux@roeck-us.net>

[ add Jane ]

Guenter Roeck wrote:
> to_virt() and to_phys() are very generic and may be defined by drivers.
> As it turns out, commit 9409c9b6709e ("pmem: refactor pmem_clear_poison()")
> did exactly that. This results in build errors such as the following
> when trying to build um:allmodconfig.
> 
> drivers/nvdimm/pmem.c: In function ‘pmem_dax_zero_page_range’:
> ./arch/um/include/asm/page.h:105:20: error:
> 			too few arguments to function ‘to_phys’
>   105 | #define __pa(virt) to_phys((void *) (unsigned long) (virt))
>       |                    ^~~~~~~
> 
> Use less generic function names for the um specific to_phys() and to_virt()
> functions to fix the problem and to avoid similar problems in the future.
> 
> Fixes: 9409c9b6709e ("pmem: refactor pmem_clear_poison()")
> Cc: Dan Williams <dan.j.williams@intel.com>
> Cc: Christoph Hellwig <hch@lst.de>

Acked-by: Dan Williams <dan.j.williams@intel.com>

Jane had sent a pmem local fixup, that I was about to push to linux-next:

https://lore.kernel.org/nvdimm/20220630182802.3250449-1-jane.chu@oracle.com/

...but I like this one too, lets do both.

> Signed-off-by: Guenter Roeck <linux@roeck-us.net>
> ---
>  arch/um/include/asm/page.h      | 4 ++--
>  arch/um/include/shared/mem.h    | 4 ++--
>  arch/um/os-Linux/skas/process.c | 6 +++---
>  3 files changed, 7 insertions(+), 7 deletions(-)

      parent reply	other threads:[~2022-07-14 20:23 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-07-14 18:46 Guenter Roeck
2022-07-14 20:12 ` Anton Ivanov
2022-07-14 20:23 ` Dan Williams [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=62d07b5120291_16fb97294fb@dwillia2-xfh.jf.intel.com.notmuch \
    --to=dan.j.williams@intel.com \
    --cc=anton.ivanov@cambridgegreys.com \
    --cc=hch@lst.de \
    --cc=jane.chu@oracle.com \
    --cc=johannes@sipsolutions.net \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-um@lists.infradead.org \
    --cc=linux@roeck-us.net \
    --cc=richard@nod.at \
    --cc=torvalds@linux-foundation.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®