mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Jakob Koschel <jakobkoschel@gmail.com>
To: Chao Yu <chao@kernel.org>
Cc: Jaegeuk Kim <jaegeuk@kernel.org>,
	Linux F2FS Dev Mailing List 
	<linux-f2fs-devel@lists.sourceforge.net>,
	LKML <linux-kernel@vger.kernel.org>,
	Mike Rapoport <rppt@kernel.org>,
	Brian Johannesmeyer <bjohannesmeyer@gmail.com>,
	Cristiano Giuffrida <c.giuffrida@vu.nl>,
	"Bos, H.J." <h.j.bos@vu.nl>
Subject: Re: [PATCH 1/2] f2fs: use separate list iterator variable to call list_move_tail()
Date: Tue, 12 Apr 2022 13:02:17 +0200	[thread overview]
Message-ID: <632AA316-A1B4-4E2C-B5FD-204FD3BE8633@gmail.com> (raw)
In-Reply-To: <4d54f494-b143-8885-a31e-924a83409e2d@kernel.org>



> On 12. Apr 2022, at 11:40, Chao Yu <chao@kernel.org> wrote:
> 
> On 2022/4/1 6:16, Jakob Koschel wrote:
>> In preparation to limit the scope of a list iterator to the list
>> traversal loop, use a dedicated pointer to point to the found element
>> [1].
>> If no break is hit or the list is empty, 'next' will be NULL and
>> list_move_tail() should be called explicitly on the head directly.
>> Link: https://lore.kernel.org/all/CAHk-=wgRr_D8CB-D9Kg-c=EHreAsk5SqXPwr9Y7k9sA6cWXJ6w@mail.gmail.com/
>> Signed-off-by: Jakob Koschel <jakobkoschel@gmail.com>
>> ---
>> fs/f2fs/segment.c | 12 ++++++++----
>> 1 file changed, 8 insertions(+), 4 deletions(-)
>> diff --git a/fs/f2fs/segment.c b/fs/f2fs/segment.c
>> index 22dfeb991529..81ef2c3d08e5 100644
>> --- a/fs/f2fs/segment.c
>> +++ b/fs/f2fs/segment.c
>> @@ -4175,16 +4175,20 @@ static void release_sit_entry_set(struct sit_entry_set *ses)
>> static void adjust_sit_entry_set(struct sit_entry_set *ses,
>> 						struct list_head *head)
>> {
>> -	struct sit_entry_set *next = ses;
>> +	struct sit_entry_set *next = NULL, *iter = ses;
>> 	if (list_is_last(&ses->set_list, head))
>> 		return;
>> -	list_for_each_entry_continue(next, head, set_list)
>> -		if (ses->entry_cnt <= next->entry_cnt)
>> +	list_for_each_entry_continue(iter, head, set_list)
>> +		if (ses->entry_cnt <= iter->entry_cnt) {
>> +			next = iter;
>> +			list_move_tail(&ses->set_list, &iter->set_list);
>> 			break;
> 
> return;
> 
>> +		}
>> -	list_move_tail(&ses->set_list, &next->set_list);
>> +	if (!next)
>> +		list_move_tail(&ses->set_list, head);
> 
> list_move_tail(&ses->set_list, head);
> 
> Then we don't need @next variable, right?

Of course yes, good spot! I'll fix and resend a v2 in the next days.
Thanks for the input.

> 
> Thanks,
> 
>> }
>> static void add_sit_entry(unsigned int segno, struct list_head *head)
>> base-commit: d888c83fcec75194a8a48ccd283953bdba7b2550


      reply	other threads:[~2022-04-12 12:09 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-03-31 22:16 Jakob Koschel
2022-03-31 22:16 ` [PATCH 2/2] f2fs: replace usage of found with dedicated list iterator variable Jakob Koschel
2022-04-12  9:41   ` Chao Yu
2022-04-12  9:40 ` [PATCH 1/2] f2fs: use separate list iterator variable to call list_move_tail() Chao Yu
2022-04-12 11:02   ` Jakob Koschel [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=632AA316-A1B4-4E2C-B5FD-204FD3BE8633@gmail.com \
    --to=jakobkoschel@gmail.com \
    --cc=bjohannesmeyer@gmail.com \
    --cc=c.giuffrida@vu.nl \
    --cc=chao@kernel.org \
    --cc=h.j.bos@vu.nl \
    --cc=jaegeuk@kernel.org \
    --cc=linux-f2fs-devel@lists.sourceforge.net \
    --cc=linux-kernel@vger.kernel.org \
    --cc=rppt@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®