mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Ravi Bangoria <ravi.bangoria@linux.ibm.com>
To: Jiri Olsa <jolsa@redhat.com>
Cc: acme@kernel.org, namhyung@kernel.org, irogers@google.com,
	songliubraving@fb.com, yao.jin@linux.intel.com,
	linux-kernel@vger.kernel.org,
	Ravi Bangoria <ravi.bangoria@linux.ibm.com>
Subject: Re: [PATCH 1/3] perf annotate: Nuke privsize
Date: Mon, 20 Jan 2020 18:19:36 +0530	[thread overview]
Message-ID: <633759b2-8d6c-24b8-b058-b4d4b365fcee@linux.ibm.com> (raw)
In-Reply-To: <20200120100825.GG608405@krava>



On 1/20/20 3:38 PM, Jiri Olsa wrote:
>> -/*
>> - * Allocating the annotation line data with following
>> - * structure:
>> - *
>> - *    --------------------------------------
>> - *    private space | struct annotation_line
>> - *    --------------------------------------
>> - *
>> - * Size of the private space is stored in 'struct annotation_line'.
>> - *
>> - */
>> -static struct annotation_line *
>> -annotation_line__new(struct annotate_args *args, size_t privsize)
>> +static size_t disasm_line_size(int nr)
>>   {
> 
> I agree we can get rid of the 'users' privsize passed from symbol__annotate,
> but could you please put it in separate patch, while keeping privsize in here?
> 
> and then put the rest of the code factoring into separate patch,
> so we can see clearly the change and the benefits
> 
> your new annotation_line__new should be renamed to something like
> annotation_line__init ... we keep __new suffix for functions that
> return new objects

Sure Jiri. Will resend with these changes.

- Ravi


  reply	other threads:[~2020-01-20 12:49 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-01-17  9:26 [PATCH 0/3] perf annotate: Misc fixes / improvements Ravi Bangoria
2020-01-17  9:26 ` [PATCH 1/3] perf annotate: Nuke privsize Ravi Bangoria
2020-01-20 10:08   ` Jiri Olsa
2020-01-20 12:49     ` Ravi Bangoria [this message]
2020-01-17  9:26 ` [PATCH 2/3] perf annotate: Align struct annotate_args Ravi Bangoria
2020-01-17  9:26 ` [PATCH 3/3] perf annotate: Fix segfault with source toggle Ravi Bangoria
2020-01-20 10:12   ` Jiri Olsa
2020-01-20 12:50     ` Ravi Bangoria

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=633759b2-8d6c-24b8-b058-b4d4b365fcee@linux.ibm.com \
    --to=ravi.bangoria@linux.ibm.com \
    --cc=acme@kernel.org \
    --cc=irogers@google.com \
    --cc=jolsa@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=namhyung@kernel.org \
    --cc=songliubraving@fb.com \
    --cc=yao.jin@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®