From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by smtp.lore.kernel.org (Postfix) with ESMTP id F2496C43219 for ; Wed, 19 Jan 2022 16:12:49 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1356115AbiASQMq (ORCPT ); Wed, 19 Jan 2022 11:12:46 -0500 Received: from mxout04.lancloud.ru ([45.84.86.114]:42292 "EHLO mxout04.lancloud.ru" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1355919AbiASQMe (ORCPT ); Wed, 19 Jan 2022 11:12:34 -0500 Received: from LanCloud DKIM-Filter: OpenDKIM Filter v2.11.0 mxout04.lancloud.ru AA47520A2ADD Received: from LanCloud Received: from LanCloud Received: from LanCloud Subject: Re: [PATCH 1/2] platform: make platform_get_irq_optional() optional To: =?UTF-8?Q?Uwe_Kleine-K=c3=b6nig?= , "Geert Uytterhoeven" CC: Andrew Lunn , Ulf Hansson , Vignesh Raghavendra , KVM list , "Rafael J. Wysocki" , , "Linus Walleij" , Amit Kucheria , "ALSA Development Mailing List" , Jaroslav Kysela , Guenter Roeck , Thierry Reding , MTD Maling List , Linux I2C , Miquel Raynal , , linux-spi , Jiri Slaby , "David S. Miller" , Khuong Dinh , Florian Fainelli , Matthias Schiffer , Kamal Dasu , "Greg Kroah-Hartman" , Lee Jones , Bartosz Golaszewski , Daniel Lezcano , Kishon Vijay Abraham I , bcm-kernel-feedback-list , "open list:SERIAL DRIVERS" , Jakub Kicinski , Zhang Rui , , Linux PWM List , Robert Richter , "Saravanan Sekar" , Corey Minyard , Linux PM list , Liam Girdwood , "Mauro Carvalho Chehab" , John Garry , Peter Korsgaard , William Breathitt Gray , Mark Gross , Hans de Goede , Alex Williamson , "Mark Brown" , Borislav Petkov , Takashi Iwai , Matthias Brugger , , Andy Shevchenko , Benson Leung , Pengutronix Kernel Team , Linux ARM , , "Tony Luck" , Richard Weinberger , Mun Yew Tham , Eric Auger , netdev , "open list:GPIO SUBSYSTEM" , Cornelia Huck , "Linux MMC List" , Joakim Zhang , Linux Kernel Mailing List , Linux-Renesas , Vinod Koul , "James Morse" , Zha Qipeng , "Sebastian Reichel" , =?UTF-8?Q?Niklas_S=c3=b6derlund?= , , "Brian Norris" , Yoshihiro Shimoda References: <20220117092444.opoedfcf5k5u6otq@pengutronix.de> <20220117114923.d5vajgitxneec7j7@pengutronix.de> <20220117170609.yxaamvqdkivs56ju@pengutronix.de> <20220118090913.pjumkq4zf4iqtlha@pengutronix.de> <20220118120806.pbjsat4ulg3vnhsh@pengutronix.de> <20220118142945.6y3rmvzt44pjpr4z@pengutronix.de> From: Sergey Shtylyov Organization: Open Mobile Platform Message-ID: <6370798a-7a7e-243d-99f9-09bf772ddbac@omp.ru> Date: Wed, 19 Jan 2022 19:12:23 +0300 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.10.1 MIME-Version: 1.0 In-Reply-To: <20220118142945.6y3rmvzt44pjpr4z@pengutronix.de> Content-Type: text/plain; charset="windows-1252" Content-Language: en-US Content-Transfer-Encoding: 8bit X-Originating-IP: [192.168.11.198] X-ClientProxiedBy: LFEXT01.lancloud.ru (fd00:f066::141) To LFEX1907.lancloud.ru (fd00:f066::207) Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 1/18/22 5:29 PM, Uwe Kleine-König wrote: >> nst the magic not-found value (so no implementation detail magic >>>>> leaks into the caller code) and just pass it to the next API function= >> . >>>>> (And my expectation would be that if you chose to represent not-found= >> by >>>>> (void *)66 instead of NULL, you won't have to adapt any user, just th= >> e >>>>> framework internal checks. This is a good thing!) >>>> >>>> Ah, there is the wrong assumption: drivers sometimes do need to know >>>> if the resource was found, and thus do need to know about (void *)66, >>>> -ENODEV, or -ENXIO. I already gave examples for IRQ and clk before. >>>> I can imagine these exist for gpiod and regulator, too, as soon as >>>> you go beyond the trivial "enable" and "disable" use-cases. >>> >>> My premise is that every user who has to check for "not found" >>> explicitly should not use (clk|gpiod)_get_optional() but >>> (clk|gpiod)_get() and do proper (and explicit) error handling for >>> -ENODEV. (clk|gpiod)_get_optional() is only for these trivial use-cases. >>> >>>> And 0/NULL vs. > 0 is the natural check here: missing, but not >>>> an error. >>> >>> For me it it 100% irrelevant if "not found" is an error for the query >>> function or not. I just have to be able to check for "not found" and >>> react accordingly. >>> >>> And adding a function >>> >>> def platform_get_irq_opional(): >>> ret =3D platform_get_irq() >>> if ret =3D=3D -ENXIO: >>> return 0 >>> return ret >>> >>> it's not a useful addition to the API if I cannot use 0 as a dummy >>> because it doesn't simplify the caller enough to justify the additional >>> function. >>> >>> The only thing I need to be able is to distinguish the cases "there is >>> an irq", "there is no irq" and anything else is "there is a problem I >>> cannot handle and so forward it to my caller". The semantic of >>> platform_get_irq() is able to satisfy this requirement[1], so why introdu= >> ce >>> platform_get_irq_opional() for the small advantage that I can check for >>> not-found using >>> >>> if (!irq) >>> >>> instead of >>> >>> if (irq !=3D -ENXIO) >>> >>> ? The semantic of platform_get_irq() is easier ("Either a usable >>> non-negative irq number or a negative error number") compared to >>> platform_get_irq_optional() ("Either a usable positive irq number or a >>> negative error number or 0 meaning not found"). Usage of >>> platform_get_irq() isn't harder or more expensive (neither for a human >>> reader nor for a maching running the resulting compiled code). >>> For a human reader >>> >>> if (irq !=3D -ENXIO) >>> >>> is even easier to understand because for >>> >>> if (!irq) >>> >>> they have to check where the value comes from, see it's >>> platform_get_irq_optional() and understand that 0 means not-found. >> >> "vIRQ zero does not exist." > > With that statement in mind I would expect that a function that gives me > an (v)irq number never returns 0. > >>> This function just adds overhead because as a irq framework user I have >>> to understand another function. For me the added benefit is too small to >>> justify the additional function. And you break out-of-tree drivers. >>> These are all no major counter arguments, but as the advantage isn't >>> major either, they still matter. >>> >>> Best regards >>> Uwe >>> >>> [1] the only annoying thing is the error message. >> >> So there's still a need for two functions. > > Or a single function not emitting an error message together with the > callers being responsible for calling dev_err(). > > So the options in my preference order (first is best) are: > > - Remove the printk from platform_get_irq() and remove > platform_get_irq_optional(); Strong NAK here: - dev_err() in our function saves a lot of (repeatable!) comments; - we've already discussed that it's more optimal to check againt 0 than against -ENXIO in the callers. > - Rename platform_get_irq_optional() to platform_get_irq_silently() NAK as well. We'd better off complaining about irq < 0 in this function. > - Keep platform_get_irq_optional() as is NAK, it's suboptimal in the call sites. > - Collect underpants > > - ? You're on your own here. :-) > - Change semantic of platform_get_irq_optional() Yes, we should change the semantics if it serves our goals better. > Best regards > Uwe MBR, Sergey