mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: kuiliang Shi <seakeel@gmail.com>
To: Ricardo Neri <ricardo.neri-calderon@linux.intel.com>, alexs@kernel.org
Cc: Ingo Molnar <mingo@redhat.com>,
	Peter Zijlstra <peterz@infradead.org>,
	Juri Lelli <juri.lelli@redhat.com>,
	Vincent Guittot <vincent.guittot@linaro.org>,
	Dietmar Eggemann <dietmar.eggemann@arm.com>,
	Steven Rostedt <rostedt@goodmis.org>,
	Ben Segall <bsegall@google.com>, Mel Gorman <mgorman@suse.de>,
	Daniel Bristot de Oliveira <bristot@redhat.com>,
	Valentin Schneider <vschneid@redhat.com>,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH 4/5] sched/fair: add a func _sched_asym
Date: Fri, 26 Jan 2024 09:57:40 +0800	[thread overview]
Message-ID: <63c456be-f7a5-4dbd-8398-fccf619bb538@gmail.com> (raw)
In-Reply-To: <20240125215622.GA17237@ranerica-svr.sc.intel.com>



On 1/26/24 5:56 AM, Ricardo Neri wrote:
> On Wed, Jan 17, 2024 at 04:57:14PM +0800, alexs@kernel.org wrote:
>> From: Alex Shi <alexs@kernel.org>
>>
>> Use this func in sched_asym and other path to simply code.
>> No function change.
>>
>> Signed-off-by: Alex Shi <alexs@kernel.org>
>> To: Valentin Schneider <vschneid@redhat.com>
>> To: Vincent Guittot <vincent.guittot@linaro.org>
>> To: Peter Zijlstra <peterz@infradead.org>
>> To: Ingo Molnar <mingo@redhat.com>
>> ---
>>  kernel/sched/fair.c | 27 +++++++++++++--------------
>>  1 file changed, 13 insertions(+), 14 deletions(-)
>>
>> diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c
>> index ebd659af2d78..96163ab69ae0 100644
>> --- a/kernel/sched/fair.c
>> +++ b/kernel/sched/fair.c
>> @@ -9745,6 +9745,14 @@ static bool sched_use_asym_prio(struct sched_domain *sd, int cpu)
>>  		(sd->flags & SD_SHARE_CPUCAPACITY) || is_core_idle(cpu);
>>  }
>>  
>> +static inline bool _sched_asym(struct sched_domain *sd,
>> +			int dst_cpu, int repl_cpu)
> 
> What does repl_cpu mean? Maybe renaming to src_cpu?

Uh, src_cpu is better than a 'replacing' cpu. Thanks!

> 
>> +{
>> +	/* Ensure that the whole local core is idle, if applicable. */
>> +	return sched_use_asym_prio(sd, dst_cpu) &&
>> +			sched_asym_prefer(dst_cpu, repl_cpu);
> 
> The comment no longer applies to the whole expression. Perhaps rewording is
> in order. First we check for the whole idle core if applicable (i.e., when
> not balancing among SMT siblings). Then we check priorities.

Right will fix this by v2.
> 
> Also, indentation should be aligned with `return`, IMO.
> 
>> +}
>> +
>>  /**
>>   * sched_asym - Check if the destination CPU can do asym_packing load balance
>>   * @env:	The load balancing environment
>> @@ -9768,20 +9776,13 @@ static bool sched_use_asym_prio(struct sched_domain *sd, int cpu)
>>  static inline bool
>>  sched_asym(struct lb_env *env, struct sg_lb_stats *sgs, struct sched_group *group)
>>  {
>> -	/* Ensure that the whole local core is idle, if applicable. */
>> -	if (!sched_use_asym_prio(env->sd, env->dst_cpu))
>> -		return false;
>> -
>>  	/*
>>  	 * CPU priorities does not make sense for SMT cores with more than one
>>  	 * busy sibling.
> 
> While here, it might be good to fix a syntax error above: s/does/do/.
> 

Yes, thanks

>>  	 */
>> -	if (group->flags & SD_SHARE_CPUCAPACITY) {
>> -		if (sgs->group_weight - sgs->idle_cpus != 1)
>> -			return false;
>> -	}
>> -
>> -	return sched_asym_prefer(env->dst_cpu, group->asym_prefer_cpu);
>> +	return !(group->flags & SD_SHARE_CPUCAPACITY &&
>> +			sgs->group_weight - sgs->idle_cpus != 1) &&
>> +		_sched_asym(env->sd, env->dst_cpu, group->asym_prefer_cpu);
> 
> Perhaps we can come up with a better name than _sched_asym(). After this
> patch the difference between sched_asym() and _sched_asym() is that the
> former considers the stats of the source group. Maybe sched_asym() can be
> renamed as sched_group_asym(); it is only used in update_sg_lb_stats().
> Your _sched_asym() can become sched_asym().

Thanks for good suggestion! will send v2 according your suggestion. 

Alex
> 
>>  }
>>  
>>  /* One group has more than one SMT CPU while the other group does not */
>> @@ -11036,8 +11037,7 @@ static struct rq *find_busiest_queue(struct lb_env *env,
>>  		 * SMT cores with more than one busy sibling.
>>  		 */
>>  		if ((env->sd->flags & SD_ASYM_PACKING) &&
>> -		    sched_use_asym_prio(env->sd, i) &&
>> -		    sched_asym_prefer(i, env->dst_cpu) &&
>> +		    _sched_asym(env->sd, i, env->dst_cpu) &&
>>  		    nr_running == 1)
>>  			continue;
>>  
>> @@ -11907,8 +11907,7 @@ static void nohz_balancer_kick(struct rq *rq)
>>  		 * preferred CPU must be idle.
>>  		 */
>>  		for_each_cpu_and(i, sched_domain_span(sd), nohz.idle_cpus_mask) {
>> -			if (sched_use_asym_prio(sd, i) &&
>> -			    sched_asym_prefer(i, cpu)) {
>> +			if (_sched_asym(sd, i, cpu)) {
>>  				flags = NOHZ_STATS_KICK | NOHZ_BALANCE_KICK;
>>  				goto unlock;
>>  			}
>> -- 
>> 2.43.0
>>

  reply	other threads:[~2024-01-26  1:57 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-01-17  8:57 [PATCH 1/5] sched/fair: add SD_CLUSTER in comments alexs
2024-01-17  8:57 ` [PATCH 2/5] sched/fair: remove unused parameters alexs
2024-01-26  0:18   ` Ricardo Neri
2024-01-17  8:57 ` [PATCH 3/5] sched/fair: cleanup sched_use_asym_prio alexs
2024-01-17  8:57 ` [PATCH 4/5] sched/fair: add a func _sched_asym alexs
2024-01-25 21:56   ` Ricardo Neri
2024-01-26  1:57     ` kuiliang Shi [this message]
2024-01-17  8:57 ` [PATCH 5/5] sched/fair: narrow the sched_use_asym_prio checking scenario alexs
2024-01-23  8:47   ` Shrikanth Hegde
2024-01-25  9:35     ` kuiliang Shi
2024-01-26  0:06       ` Ricardo Neri
2024-01-30 13:18         ` kuiliang Shi
2024-01-26  0:04     ` Ricardo Neri

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=63c456be-f7a5-4dbd-8398-fccf619bb538@gmail.com \
    --to=seakeel@gmail.com \
    --cc=alexs@kernel.org \
    --cc=bristot@redhat.com \
    --cc=bsegall@google.com \
    --cc=dietmar.eggemann@arm.com \
    --cc=juri.lelli@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mgorman@suse.de \
    --cc=mingo@redhat.com \
    --cc=peterz@infradead.org \
    --cc=ricardo.neri-calderon@linux.intel.com \
    --cc=rostedt@goodmis.org \
    --cc=vincent.guittot@linaro.org \
    --cc=vschneid@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®