mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Daniel Lezcano <daniel.lezcano@linaro.org>
To: Daniel Lezcano <daniel.lezcano@linexp.org>, rafael@kernel.org
Cc: khilman@baylibre.com, abailon@baylibre.com,
	linux-pm@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 00/14] thermal OF rework
Date: Fri, 13 May 2022 19:23:45 +0200	[thread overview]
Message-ID: <63f1c4a0-d2c6-8157-5da0-198c2d8d1013@linaro.org> (raw)
In-Reply-To: <20220507125443.2766939-1-daniel.lezcano@linexp.org>


Hi Rafael,

if you are ok with this series, I'll pick it up.

Is that ok ?




On 07/05/2022 14:54, Daniel Lezcano wrote:
> The thermal framework initialization with the device tree appears to
> be complicated and hard to make it to evolve.
> 
> It contains duplication of almost the same thermal generic structures
> and has an assymetric initialization making hard any kind of serious
> changes for more complex features. One of them is the multiple sensors
> support per thermal zone.
> 
> In order to set the scene for the aforementioned feature with generic
> code, we need to cleanup and rework the device tree initialization.
> 
> However this rework is not obvious because of the multiple components
> entering in the composition of a thermal zone and being initialized at
> different moments. For instance, a cooling device can be initialized
> before a sensor, so the thermal zones must exist before the cooling
> device as well as the sensor. This asynchonous initialization forces
> the thermal zone to be created with fake ops because they are
> mandotory and build a list of cooling devices which is used to lookup
> afterwards when the cooling device driver is registering itself.
> 
> As there could be a large number of changes, this first series provide
> some steps forward for a simpler device tree initialization.
> 
> Changelog:
>   - V2:
>     - Drop patch 1/15 which contains too many changes for a simple
>       structure renaming. This could be addressed in a separate series as
>       it is not necessary for the OF rework
>       
>     - Fixed of_node_put with gchild not initialized as reported by
>       kbuild and Dan Carpenter
> 
>   - V1:
>     - Initial post
> 
> Daniel Lezcano (14):
>    thermal/core: Change thermal_zone_ops to thermal_sensor_ops
>    thermal/core: Add a thermal sensor structure in the thermal zone
>    thermal/core: Remove duplicate information when an error occurs
>    thermal/of: Replace device node match with device node search
>    thermal/of: Remove the device node pointer for thermal_trip
>    thermal/of: Move thermal_trip structure to thermal.h
>    thermal/core: Remove unneeded EXPORT_SYMBOLS
>    thermal/core: Move thermal_set_delay_jiffies to static
>    thermal/core: Rename trips to ntrips
>    thermal/core: Add thermal_trip in thermal_zone
>    thermal/core: Register with the trip points
>    thermal/of: Store the trips in the thermal zone
>    thermal/of: Use thermal trips stored in the thermal zone
>    thermal/of: Initialize trip points separately
> 
>   .../driver-api/thermal/sysfs-api.rst          |   2 +-
>   drivers/acpi/thermal.c                        |   6 +-
>   .../ethernet/chelsio/cxgb4/cxgb4_thermal.c    |   2 +-
>   .../ethernet/mellanox/mlxsw/core_thermal.c    |   6 +-
>   drivers/net/wireless/intel/iwlwifi/mvm/tt.c   |   2 +-
>   drivers/platform/x86/acerhdf.c                |   2 +-
>   drivers/power/supply/power_supply_core.c      |   2 +-
>   drivers/thermal/armada_thermal.c              |   2 +-
>   drivers/thermal/broadcom/bcm2835_thermal.c    |   2 +-
>   drivers/thermal/da9062-thermal.c              |   2 +-
>   drivers/thermal/dove_thermal.c                |   2 +-
>   drivers/thermal/gov_bang_bang.c               |   6 +-
>   drivers/thermal/gov_fair_share.c              |  10 +-
>   drivers/thermal/gov_power_allocator.c         |  22 +-
>   drivers/thermal/gov_step_wise.c               |   4 +-
>   drivers/thermal/imx_thermal.c                 |   2 +-
>   .../intel/int340x_thermal/int3400_thermal.c   |   2 +-
>   .../int340x_thermal/int340x_thermal_zone.c    |   6 +-
>   .../int340x_thermal/int340x_thermal_zone.h    |   4 +-
>   .../processor_thermal_device.c                |   4 +-
>   .../processor_thermal_device_pci.c            |   2 +-
>   drivers/thermal/intel/intel_pch_thermal.c     |   2 +-
>   .../thermal/intel/intel_quark_dts_thermal.c   |   2 +-
>   drivers/thermal/intel/intel_soc_dts_iosf.c    |   2 +-
>   drivers/thermal/intel/x86_pkg_temp_thermal.c  |   2 +-
>   drivers/thermal/kirkwood_thermal.c            |   2 +-
>   drivers/thermal/rcar_gen3_thermal.c           |   6 +-
>   drivers/thermal/rcar_thermal.c                |   4 +-
>   drivers/thermal/samsung/exynos_tmu.c          |   6 +-
>   drivers/thermal/spear_thermal.c               |   2 +-
>   drivers/thermal/st/st_thermal.c               |   2 +-
>   drivers/thermal/tegra/soctherm.c              |  10 +-
>   drivers/thermal/tegra/tegra30-tsensor.c       |   6 +-
>   drivers/thermal/thermal_core.c                | 102 ++++----
>   drivers/thermal/thermal_core.h                |  25 +-
>   drivers/thermal/thermal_helpers.c             |  35 ++-
>   drivers/thermal/thermal_hwmon.c               |   4 +-
>   drivers/thermal/thermal_netlink.c             |  10 +-
>   drivers/thermal/thermal_of.c                  | 221 ++++++++++--------
>   drivers/thermal/thermal_sysfs.c               |  62 ++---
>   include/linux/thermal.h                       |  34 ++-
>   41 files changed, 341 insertions(+), 290 deletions(-)
> 


-- 
<http://www.linaro.org/> Linaro.org │ Open source software for ARM SoCs

Follow Linaro:  <http://www.facebook.com/pages/Linaro> Facebook |
<http://twitter.com/#!/linaroorg> Twitter |
<http://www.linaro.org/linaro-blog/> Blog

  parent reply	other threads:[~2022-05-13 17:23 UTC|newest]

Thread overview: 29+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-05-07 12:54 Daniel Lezcano
2022-05-07 12:54 ` [PATCH v2 01/14] thermal/core: Change thermal_zone_ops to thermal_sensor_ops Daniel Lezcano
2022-05-08 10:26   ` Andy Shevchenko
2022-05-09  9:20   ` Geert Uytterhoeven
2022-05-17 15:42   ` Rafael J. Wysocki
2022-05-17 16:50     ` srinivas pandruvada
2022-05-17 18:53       ` Rafael J. Wysocki
2022-05-17 19:02         ` srinivas pandruvada
2022-05-17 19:07           ` Rafael J. Wysocki
2022-06-26 17:33     ` Daniel Lezcano
2022-05-07 12:54 ` [PATCH v2 02/14] thermal/core: Add a thermal sensor structure in the thermal zone Daniel Lezcano
2022-05-09  7:00   ` Krzysztof Kozlowski
2022-05-09  9:28   ` Geert Uytterhoeven
2022-05-07 12:54 ` [PATCH v2 03/14] thermal/core: Remove duplicate information when an error occurs Daniel Lezcano
2022-05-17 15:45   ` Rafael J. Wysocki
2022-05-07 12:54 ` [PATCH v2 04/14] thermal/of: Replace device node match with device node search Daniel Lezcano
2022-05-07 12:54 ` [PATCH v2 05/14] thermal/of: Remove the device node pointer for thermal_trip Daniel Lezcano
2022-05-07 12:54 ` [PATCH v2 06/14] thermal/of: Move thermal_trip structure to thermal.h Daniel Lezcano
2022-05-07 12:54 ` [PATCH v2 07/14] thermal/core: Remove unneeded EXPORT_SYMBOLS Daniel Lezcano
2022-05-07 12:54 ` [PATCH v2 08/14] thermal/core: Move thermal_set_delay_jiffies to static Daniel Lezcano
2022-05-07 12:54 ` [PATCH v2 09/14] thermal/core: Rename trips to ntrips Daniel Lezcano
2022-05-07 12:54 ` [PATCH v2 10/14] thermal/core: Add thermal_trip in thermal_zone Daniel Lezcano
2022-05-07 12:54 ` [PATCH v2 11/14] thermal/core: Register with the trip points Daniel Lezcano
2022-05-07 12:54 ` [PATCH v2 12/14] thermal/of: Store the trips in the thermal zone Daniel Lezcano
2022-05-07 12:54 ` [PATCH v2 13/14] thermal/of: Use thermal trips stored " Daniel Lezcano
2022-05-07 12:54 ` [PATCH v2 14/14] thermal/of: Initialize trip points separately Daniel Lezcano
2022-05-13 17:23 ` Daniel Lezcano [this message]
2022-05-13 17:56   ` [PATCH v2 00/14] thermal OF rework Rafael J. Wysocki
2022-05-13 19:18     ` Daniel Lezcano

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=63f1c4a0-d2c6-8157-5da0-198c2d8d1013@linaro.org \
    --to=daniel.lezcano@linaro.org \
    --cc=abailon@baylibre.com \
    --cc=daniel.lezcano@linexp.org \
    --cc=khilman@baylibre.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=rafael@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®