From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S932336AbcJZJZv (ORCPT ); Wed, 26 Oct 2016 05:25:51 -0400 Received: from bear.ext.ti.com ([198.47.19.11]:38603 "EHLO bear.ext.ti.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S932207AbcJZJZt (ORCPT ); Wed, 26 Oct 2016 05:25:49 -0400 Subject: Re: [PATCH v6 1/5] ARM: davinci: da8xx: add usb phy clocks To: David Lechner , Kevin Hilman , Rob Herring , Mark Rutland References: <1477451211-31979-1-git-send-email-david@lechnology.com> <1477451211-31979-2-git-send-email-david@lechnology.com> CC: Axel Haslam , Sergei Shtylyov , , , From: Sekhar Nori Message-ID: <64127331-7afd-9af7-60d0-d735aa6af628@ti.com> Date: Wed, 26 Oct 2016 14:54:26 +0530 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.3.0 MIME-Version: 1.0 In-Reply-To: <1477451211-31979-2-git-send-email-david@lechnology.com> Content-Type: text/plain; charset="windows-1252" Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wednesday 26 October 2016 08:36 AM, David Lechner wrote: > diff --git a/arch/arm/mach-davinci/usb-da8xx.c b/arch/arm/mach-davinci/usb-da8xx.c > index f141f51..71a6d85 100644 > --- a/arch/arm/mach-davinci/usb-da8xx.c > +++ b/arch/arm/mach-davinci/usb-da8xx.c > @@ -1,20 +1,248 @@ > /* > * DA8xx USB > */ > -#include > +#include > +#include > #include > #include > #include > +#include > #include > > +#include > #include > #include > #include > -#include Looks like you have cleaned up some unneeded includes. Thats fine, just mention it in the commit description too, so its clear that it is intended. Also, when adding new include files, please do it in alphabetical order. > +static struct clk usb_refclkin = { > + .name = "usb_refclkin", > + .set_rate = davinci_simple_set_rate, > +}; > + > +static struct clk_lookup usb_refclkin_lookup = > + CLK(NULL, "usb_refclkin", &usb_refclkin); > + > +static struct clk usb20_phy_clk = { > + .name = "usb20_phy", > + .clk_enable = usb20_phy_clk_enable, > + .clk_disable = usb20_phy_clk_disable, > + .set_parent = usb20_phy_clk_set_parent, > +}; > + > +static struct clk_lookup usb20_phy_clk_lookup = > + CLK(NULL, "usb20_phy", &usb20_phy_clk); NULL device name here is wrong. There is a PHY device that gets added 3/5. The name of that device should appear here. Since that phy device is the consumer of this clock. You can change the order of patches so the device appears before the associated clocks. > +static struct clk usb11_phy_clk = { > + .name = "usb11_phy", > + .set_parent = usb11_phy_clk_set_parent, > +}; > + > +static struct clk_lookup usb11_phy_clk_lookup = > + CLK(NULL, "usb11_phy", &usb11_phy_clk); here too, please have the phy device name as the consumer of this clock. It is okay to have NULL device name for the usb_refclkin since that is a root clock not associated with any device. Thanks, Sekhar