From: Benjamin Gaignard <benjamin.gaignard@collabora.com>
To: Hans Verkuil <hverkuil-cisco@xs4all.nl>,
mchehab@kernel.org, tfiga@chromium.org, m.szyprowski@samsung.com,
ming.qian@nxp.com, ezequiel@vanguardiasur.com.ar,
p.zabel@pengutronix.de, gregkh@linuxfoundation.org,
nicolas.dufresne@collabora.com
Cc: linux-media@vger.kernel.org, linux-kernel@vger.kernel.org,
linux-arm-kernel@lists.infradead.org,
linux-mediatek@lists.infradead.org,
linux-arm-msm@vger.kernel.org,
linux-rockchip@lists.infradead.org,
linux-staging@lists.linux.dev, kernel@collabora.com
Subject: Re: [PATCH v5 01/10] media: videobuf2: Rework offset 'cookie' encoding pattern
Date: Wed, 30 Aug 2023 14:51:30 +0200 [thread overview]
Message-ID: <643a7811-60ff-6ac9-be3d-edcd9a0b95cc@collabora.com> (raw)
In-Reply-To: <01c299f2-8118-5d86-e9b6-a459c1b6c467@xs4all.nl>
Le 30/08/2023 à 14:25, Hans Verkuil a écrit :
> On 24/08/2023 11:21, Benjamin Gaignard wrote:
>> Change how offset 'cookie' field value is computed to make possible
>> to use more buffers (up to 0xffff).
>> With this encoding pattern we know the maximum number that a queue
>> could store so we can check ing at queue init time.
>> It also make easier and faster to find buffer and plane from using
>> the offset field.
>>
>> Signed-off-by: Benjamin Gaignard <benjamin.gaignard@collabora.com>
>> ---
>> v5:
>> - I haven't change DST_QUEUE_OFF_BASE definition because it used in
>> v4l2-mem2mem and s5p_mfc driver with a shift.
>>
>> .../media/common/videobuf2/videobuf2-core.c | 48 +++++++++----------
>> 1 file changed, 24 insertions(+), 24 deletions(-)
>>
>> diff --git a/drivers/media/common/videobuf2/videobuf2-core.c b/drivers/media/common/videobuf2/videobuf2-core.c
>> index cf6727d9c81f..e06905533ef4 100644
>> --- a/drivers/media/common/videobuf2/videobuf2-core.c
>> +++ b/drivers/media/common/videobuf2/videobuf2-core.c
>> @@ -31,6 +31,10 @@
>>
>> #include <trace/events/vb2.h>
>>
>> +#define PLANE_INDEX_SHIFT 3
>> +#define PLANE_INDEX_MASK 0x7
>> +#define MAX_BUFFERS 0xffff
> Very poor name, see below.
>
>> +
>> static int debug;
>> module_param(debug, int, 0644);
>>
>> @@ -358,21 +362,23 @@ static void __setup_offsets(struct vb2_buffer *vb)
>> unsigned int plane;
>> unsigned long off = 0;
>>
>> - if (vb->index) {
>> - struct vb2_buffer *prev = q->bufs[vb->index - 1];
>> - struct vb2_plane *p = &prev->planes[prev->num_planes - 1];
>> -
>> - off = PAGE_ALIGN(p->m.offset + p->length);
>> - }
>> + /*
>> + * Offsets cookies value have the following constraints:
>> + * - a buffer could have up to 8 planes.
>> + * - v4l2 mem2mem use bit 30 to distinguish between source and destination buffers.
>> + * - must be page aligned
>> + * That led to this bit mapping:
>> + * |30 |29 15|14 12|11 0|
>> + * |DST_QUEUE_OFF_BASE|buffer index|plane index| 0 |
>> + * where there is 16 bits to store buffer index.
> 16 -> 15: there are 15 (not 16!) bits available for buffer indices. So the maximum
> number of buffers is 32768, given that the indices start at 0.
>
>> + */
>> + off = vb->index << (PLANE_INDEX_SHIFT + PAGE_SHIFT);
>>
>> for (plane = 0; plane < vb->num_planes; ++plane) {
>> - vb->planes[plane].m.offset = off;
>> + vb->planes[plane].m.offset = off + (plane << PAGE_SHIFT);
>>
>> dprintk(q, 3, "buffer %d, plane %d offset 0x%08lx\n",
>> vb->index, plane, off);
>> -
>> - off += vb->planes[plane].length;
>> - off = PAGE_ALIGN(off);
>> }
>> }
>>
>> @@ -2209,21 +2215,15 @@ static int __find_plane_by_offset(struct vb2_queue *q, unsigned long off,
>> return -EBUSY;
>> }
>>
>> - /*
>> - * Go over all buffers and their planes, comparing the given offset
>> - * with an offset assigned to each plane. If a match is found,
>> - * return its buffer and plane numbers.
>> - */
>> - for (buffer = 0; buffer < q->num_buffers; ++buffer) {
>> - vb = q->bufs[buffer];
>> + /* Get buffer and plane from the offset */
>> + buffer = (off >> (PLANE_INDEX_SHIFT + PAGE_SHIFT)) & MAX_BUFFERS;
> Hmm, you use it as a mask. The name MAX_BUFFERS is really confusing.
> How about BUFFER_INDEX_MASK? That is consistent with PLANE_INDEX_MASK.
I will follow your advice and fix that in next version.
I will until you have finish your review in this series before send it.
Regards,
Benjamin
>
>> + plane = (off >> PAGE_SHIFT) & PLANE_INDEX_MASK;
>>
>> - for (plane = 0; plane < vb->num_planes; ++plane) {
>> - if (vb->planes[plane].m.offset == off) {
>> - *_buffer = buffer;
>> - *_plane = plane;
>> - return 0;
>> - }
>> - }
>> + vb = q->bufs[buffer];
>> + if (vb->planes[plane].m.offset == off) {
>> + *_buffer = buffer;
>> + *_plane = plane;
>> + return 0;
>> }
>>
>> return -EINVAL;
> Regards,
>
> Hans
>
next prev parent reply other threads:[~2023-08-30 19:14 UTC|newest]
Thread overview: 27+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-08-24 9:21 [PATCH v5 00/10] Add DELETE_BUF ioctl Benjamin Gaignard
2023-08-24 9:21 ` [PATCH v5 01/10] media: videobuf2: Rework offset 'cookie' encoding pattern Benjamin Gaignard
2023-08-30 12:25 ` Hans Verkuil
2023-08-30 12:51 ` Benjamin Gaignard [this message]
2023-08-24 9:21 ` [PATCH v5 02/10] media: videobuf2: Access vb2_queue bufs array through helper functions Benjamin Gaignard
2023-08-30 13:23 ` Hans Verkuil
2023-08-30 16:24 ` Benjamin Gaignard
2023-08-30 16:36 ` Hans Verkuil
2023-08-31 7:54 ` Benjamin Gaignard
2023-08-31 10:22 ` Hans Verkuil
2023-08-31 12:06 ` Benjamin Gaignard
2023-09-01 12:29 ` Benjamin Gaignard
2023-08-24 9:21 ` [PATCH v5 03/10] media: videobuf2: Be more flexible on the number of queue stored buffers Benjamin Gaignard
2023-08-30 13:27 ` Hans Verkuil
2023-08-24 9:21 ` [PATCH v5 04/10] media: verisilicon: Refactor postprocessor to store more buffers Benjamin Gaignard
2023-08-24 9:21 ` [PATCH v5 05/10] media: verisilicon: Store chroma and motion vectors offset Benjamin Gaignard
2023-08-24 9:21 ` [PATCH v5 06/10] media: verisilicon: vp9: Use destination buffer height to compute chroma offset Benjamin Gaignard
2023-08-24 9:21 ` [PATCH v5 07/10] media: verisilicon: postproc: Fix down scale test Benjamin Gaignard
2023-08-24 9:21 ` [PATCH v5 08/10] media: verisilicon: vp9: Allow to change resolution while streaming Benjamin Gaignard
2023-08-24 9:21 ` [PATCH v5 09/10] media: v4l2: Add DELETE_BUFS ioctl Benjamin Gaignard
2023-08-30 13:45 ` Hans Verkuil
2023-08-30 13:51 ` Hans Verkuil
2023-08-24 9:21 ` [PATCH v5 10/10] media: v4l2: Add mem2mem helpers for " Benjamin Gaignard
2023-08-25 10:29 ` kernel test robot
2023-08-25 15:34 ` Benjamin Gaignard
2023-08-25 12:26 ` kernel test robot
2023-08-30 13:53 ` Hans Verkuil
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=643a7811-60ff-6ac9-be3d-edcd9a0b95cc@collabora.com \
--to=benjamin.gaignard@collabora.com \
--cc=ezequiel@vanguardiasur.com.ar \
--cc=gregkh@linuxfoundation.org \
--cc=hverkuil-cisco@xs4all.nl \
--cc=kernel@collabora.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-media@vger.kernel.org \
--cc=linux-mediatek@lists.infradead.org \
--cc=linux-rockchip@lists.infradead.org \
--cc=linux-staging@lists.linux.dev \
--cc=m.szyprowski@samsung.com \
--cc=mchehab@kernel.org \
--cc=ming.qian@nxp.com \
--cc=nicolas.dufresne@collabora.com \
--cc=p.zabel@pengutronix.de \
--cc=tfiga@chromium.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®