From: linmiaohe <linmiaohe@huawei.com>
To: David Hildenbrand <david@redhat.com>,
"akpm@linux-foundation.org" <akpm@linux-foundation.org>,
"richardw.yang@linux.intel.com" <richardw.yang@linux.intel.com>,
"sfr@canb.auug.org.au" <sfr@canb.auug.org.au>,
"rppt@linux.ibm.com" <rppt@linux.ibm.com>,
"jannh@google.com" <jannh@google.com>,
"steve.capper@arm.com" <steve.capper@arm.com>,
"catalin.marinas@arm.com" <catalin.marinas@arm.com>,
"aarcange@redhat.com" <aarcange@redhat.com>,
"walken@google.com" <walken@google.com>,
"dave.hansen@linux.intel.com" <dave.hansen@linux.intel.com>,
"tiny.windzz@gmail.com" <tiny.windzz@gmail.com>,
"jhubbard@nvidia.com" <jhubbard@nvidia.com>
Cc: "linux-mm@kvack.org" <linux-mm@kvack.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v3] mm: get rid of odd jump labels in find_mergeable_anon_vma()
Date: Mon, 18 Nov 2019 11:31:09 +0000 [thread overview]
Message-ID: <649a404995f34fe3ab36ae2c4d58f077@huawei.com> (raw)
David Hildenbrand wrote:
> On 18.11.19 07:39, linmiaohe wrote:
>> From: Miaohe Lin <linmiaohe@huawei.com>
>>
>> The jump labels try_prev and none are not really needed in
>> find_mergeable_anon_vma(), eliminate them to improve readability.
>
>I think you can get rid of near completely as well
>
> if (vma->vm_next) {
> anon_vma = reusable_anon_vma(near, vma, vma->vm_next);
> if (anon_vma)
> return anon_vma;
> }
>
>...
>
>Apart from that looks good to me.
>
>>
>> - anon_vma = reusable_anon_vma(near, vma, near);
>> - if (anon_vma)
>> - return anon_vma;
>> -try_prev:
>> + /* Try prev next. */
>> near = vma->vm_prev;
>> - if (!near)
Thanks for your advice again. I will get rid of near completely in v4. Thanks a lot.
next reply other threads:[~2019-11-18 11:31 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-11-18 11:31 linmiaohe [this message]
-- strict thread matches above, loose matches on Subject: below --
2019-11-18 6:39 linmiaohe
2019-11-18 9:45 ` David Hildenbrand
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=649a404995f34fe3ab36ae2c4d58f077@huawei.com \
--to=linmiaohe@huawei.com \
--cc=aarcange@redhat.com \
--cc=akpm@linux-foundation.org \
--cc=catalin.marinas@arm.com \
--cc=dave.hansen@linux.intel.com \
--cc=david@redhat.com \
--cc=jannh@google.com \
--cc=jhubbard@nvidia.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=richardw.yang@linux.intel.com \
--cc=rppt@linux.ibm.com \
--cc=sfr@canb.auug.org.au \
--cc=steve.capper@arm.com \
--cc=tiny.windzz@gmail.com \
--cc=walken@google.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome