mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Andy Yan" <andyshrk@163.com>
To: "Krzysztof Kozlowski" <krzk@kernel.org>
Cc: heiko@sntech.de, hjc@rock-chips.com, krzk+dt@kernel.org,
	devicetree@vger.kernel.org, dri-devel@lists.freedesktop.org,
	linux-arm-kernel@lists.infradead.org,
	linux-kernel@vger.kernel.org, linux-rockchip@lists.infradead.org,
	derek.foreman@collabora.com, detlev.casanova@collabora.com,
	daniel@fooishbar.org, robh@kernel.org,
	sebastian.reichel@collabora.com,
	"Andy Yan" <andy.yan@rock-chips.com>
Subject: Re:Re:Re: [PATCH v11 10/11] dt-bindings: display: vop2: Add rk3576 support
Date: Thu, 16 Jan 2025 16:27:42 +0800 (CST)	[thread overview]
Message-ID: <652ec3b0.6e7b.1946e39b31e.Coremail.andyshrk@163.com> (raw)
In-Reply-To: <3a93b0e3.1b0c.1945a1f4dbd.Coremail.andyshrk@163.com>


Hi Krzysztof,

At 2025-01-12 18:46:28, "Andy Yan" <andyshrk@163.com> wrote:
>
>Hi Krzysztof,
>
>At 2025-01-12 17:27:18, "Krzysztof Kozlowski" <krzk@kernel.org> wrote:
>>On Sat, Jan 11, 2025 at 07:26:08PM +0800, Andy Yan wrote:
>>>    # See compatible-specific constraints below.
>>>    clocks:
>>> @@ -120,43 +133,98 @@ allOf:
>>>        properties:
>>>          compatible:
>>>            contains:
>>> -            const: rockchip,rk3588-vop
>>> +            enum:
>>> +              - rockchip,rk3566-vop
>>> +              - rockchip,rk3568-vop
>>>      then:
>>>        properties:
>>>          clocks:
>>> -          minItems: 7
>>> +          minItems: 5
>>
>>That's wrong, why maxItems became minItems? How is this related to rk3576?
>>
>>> +
>>>          clock-names:
>>> -          minItems: 7
>>> +          minItems: 5
>>
>>You are doing here way too much. You need to split reorganizing, so we
>>will see what comes new.
>>
>>And of course you need to explain why you are changing EXISTING binding
>>(I am not talking about shuffling around - you change the binding).
>
>How about split this patch to two: One rework the existing binding,  make it
>more suitable for expanding to include new SoCs.
>Then add rk3576 in the second patch ?

Can you confirm whether this approach is acceptable?  I want to  clarify  with you
before sending the next version.


>
>
>>
>>
>>> +
>>> +        interrupts:
>>> +          maxItems: 1
>>> +
>>> +        interrupt-names: false
>>>  
>>>          ports:
>>>            required:
>>>              - port@0
>>>              - port@1
>>>              - port@2
>>> -            - port@3
>>> +
>>> +        rockchip,vo1-grf: false
>>> +        rockchip,vop-grf: false
>>> +        rockchip,pmu: false
>>>  
>>>        required:
>>>          - rockchip,grf
>>> -        - rockchip,vo1-grf
>>> -        - rockchip,vop-grf
>>> -        - rockchip,pmu
>>>  
>>> -    else:
>>> +  - if:
>>> +      properties:
>>> +        compatible:
>>> +          contains:
>>> +            enum:
>>> +              - rockchip,rk3576-vop
>>> +    then:
>>>        properties:
>>> +        clocks:
>>> +          minItems: 5
>>
>>
>>Why minItems? Nothing in this patch makes sense for me. Neither changing
>>existing binding nor new binding for rk3576.
>>
>>> +
>>> +        clock-names:
>>> +          minItems: 5
>>> +
>>> +        interrupts:
>>> +          minItems: 4
>>> +
>>> +        interrupt-names:
>>> +          minItems: 4
>>> +
>>> +        ports:
>>> +          required:
>>> +            - port@0
>>> +            - port@1
>>> +            - port@2
>>> +
>>>          rockchip,vo1-grf: false
>>>          rockchip,vop-grf: false
>>> -        rockchip,pmu: false
>>>  
>>> +      required:
>>> +        - rockchip,grf
>>> +        - rockchip,pmu
>>> +
>>> +  - if:
>>> +      properties:
>>> +        compatible:
>>> +          contains:
>>> +            const: rockchip,rk3588-vop
>>> +    then:
>>> +      properties:
>>>          clocks:
>>> -          maxItems: 5
>>> +          minItems: 7
>>
>>And again weird change to the binding.
>>
>>Best regards,
>>Krzysztof
>>
>>
>>_______________________________________________
>>Linux-rockchip mailing list
>>Linux-rockchip@lists.infradead.org
>>http://lists.infradead.org/mailman/listinfo/linux-rockchip

  reply	other threads:[~2025-01-16  8:30 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-01-11 11:25 [PATCH v11 00/11] VOP Support for rk3576 Andy Yan
2025-01-11 11:25 ` [PATCH v11 01/11] drm/rockchip: vop2: use devm_regmap_field_alloc for cluster-regs Andy Yan
2025-01-11 11:26 ` [PATCH v11 02/11] drm/rockchip: vop2: Rename TRANSFORM_OFFSET to TRANSFORM_OFFS Andy Yan
2025-01-11 11:26 ` [PATCH v11 03/11] drm/rockchip: vop2: Add platform specific callback Andy Yan
2025-01-11 11:26 ` [PATCH v11 04/11] drm/rockchip: vop2: Merge vop2_cluster/esmart_init function Andy Yan
2025-01-11 11:26 ` [PATCH v11 05/11] drm/rockchip: vop2: Support for different layer select configuration between VPs Andy Yan
2025-01-11 11:26 ` [PATCH v11 06/11] drm/rockchip: vop2: Introduce vop hardware version Andy Yan
2025-01-11 11:26 ` [PATCH v11 07/11] drm/rockchip: vop2: Register the primary plane and overlay plane separately Andy Yan
2025-01-11 11:26 ` [PATCH v11 08/11] drm/rockchip: vop2: Set plane possible crtcs by possible vp mask Andy Yan
2025-01-11 11:26 ` [PATCH v11 09/11] drm/rockchip: vop2: Add uv swap for cluster window Andy Yan
2025-01-11 11:26 ` [PATCH v11 10/11] dt-bindings: display: vop2: Add rk3576 support Andy Yan
2025-01-12  9:27   ` Krzysztof Kozlowski
2025-01-12 10:46     ` Andy Yan
2025-01-16  8:27       ` Andy Yan [this message]
2025-01-11 11:27 ` [PATCH v11 11/11] drm/rockchip: vop2: Add support for rk3576 Andy Yan

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=652ec3b0.6e7b.1946e39b31e.Coremail.andyshrk@163.com \
    --to=andyshrk@163.com \
    --cc=andy.yan@rock-chips.com \
    --cc=daniel@fooishbar.org \
    --cc=derek.foreman@collabora.com \
    --cc=detlev.casanova@collabora.com \
    --cc=devicetree@vger.kernel.org \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=heiko@sntech.de \
    --cc=hjc@rock-chips.com \
    --cc=krzk+dt@kernel.org \
    --cc=krzk@kernel.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-rockchip@lists.infradead.org \
    --cc=robh@kernel.org \
    --cc=sebastian.reichel@collabora.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®