From: Frederick Lawler <fred@fredlawl.com>
To: Damien Le Moal <Damien.LeMoal@wdc.com>
Cc: "axboe@kernel.dk" <axboe@kernel.dk>,
"linux-block@vger.kernel.org" <linux-block@vger.kernel.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"bhelgaas@google.com" <bhelgaas@google.com>,
"bvanassche@acm.org" <bvanassche@acm.org>
Subject: Re: [PATCH v2 1/4] skd: Prefer pcie_capability_read_word()
Date: Mon, 18 Nov 2019 19:20:05 -0600 [thread overview]
Message-ID: <653fa44d-7edc-8440-b778-79c127c0aa3b@fredlawl.com> (raw)
In-Reply-To: <BYAPR04MB5816EDC3676A964C2D1D874BE74D0@BYAPR04MB5816.namprd04.prod.outlook.com>
Damien Le Moal wrote on 11/17/19 7:45 PM:
> On 2019/11/18 9:21, Frederick Lawler wrote:
>> Commit 8c0d3a02c130 ("PCI: Add accessors for PCI Express Capability")
>> added accessors for the PCI Express Capability so that drivers didn't
>> need to be aware of differences between v1 and v2 of the PCI
>> Express Capability.
>>
>> Replace pci_read_config_word() and pci_write_config_word() calls with
>> pcie_capability_read_word() and pcie_capability_write_word().
>>
>> Signed-off-by: Frederick Lawler <fred@fredlawl.com>
>> ---
>> drivers/block/skd_main.c | 8 ++------
>> 1 file changed, 2 insertions(+), 6 deletions(-)
>>
>> diff --git a/drivers/block/skd_main.c b/drivers/block/skd_main.c
>> index 51569c199a6c..f25f6ef6b4c7 100644
>> --- a/drivers/block/skd_main.c
>> +++ b/drivers/block/skd_main.c
>> @@ -3134,18 +3134,14 @@ MODULE_DEVICE_TABLE(pci, skd_pci_tbl);
>>
>> static char *skd_pci_info(struct skd_device *skdev, char *str)
>> {
>> - int pcie_reg;
>> -
>> strcpy(str, "PCIe (");
>> - pcie_reg = pci_find_capability(skdev->pdev, PCI_CAP_ID_EXP);
>>
>> - if (pcie_reg) {
>> + if (pci_is_pcie(skdev->pdev)) {
>
> Maybe return early here ? The reason is that if pci_is_pcie() is false,
> then the string "PCIe (" is not terminated with a closing parenthesis.
> So something like:
>
> if (!pci_is_pcie(skdev->pdev)) {
> strcat(str, ")");
> return str;
> }
>
> May be better. Note that the "return str" is also rather pointless since
> it is not used by the caller of skd_pci_info().
>
I agree, but it might be better to include a note that this is not a
PCIe device. Reading "PCIe ()" seems weird to me.
>>
>> char lwstr[6];
>> uint16_t pcie_lstat, lspeed, lwidth;
>>
>> - pcie_reg += 0x12;
>> - pci_read_config_word(skdev->pdev, pcie_reg, &pcie_lstat);
>> + pcie_capability_read_word(skdev->pdev, 0x12, &pcie_lstat);
>> lspeed = pcie_lstat & (0xF);
>> lwidth = (pcie_lstat & 0x3F0) >> 4;
>>
>>
>
>
Thanks,
Frederick Lawler
next prev parent reply other threads:[~2019-11-19 1:20 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-11-18 0:20 [PATCH v2 0/4] skd/mtip32xx: " Frederick Lawler
2019-11-18 0:20 ` [PATCH v2 1/4] skd: " Frederick Lawler
2019-11-18 1:45 ` Damien Le Moal
2019-11-19 1:20 ` Frederick Lawler [this message]
2019-11-19 2:41 ` Damien Le Moal
2019-11-18 0:20 ` [PATCH v2 2/4] skd: Replace magic numbers with PCI constants Frederick Lawler
2019-11-18 1:45 ` Damien Le Moal
2019-11-19 1:21 ` Frederick Lawler
2019-11-18 0:20 ` [PATCH v2 3/4] mtip32xx: Prefer pcie_capability_read_word() Frederick Lawler
2019-11-18 0:20 ` [PATCH v2 4/4] mtip32xx: Replace magic numbers with PCI constants Frederick Lawler
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=653fa44d-7edc-8440-b778-79c127c0aa3b@fredlawl.com \
--to=fred@fredlawl.com \
--cc=Damien.LeMoal@wdc.com \
--cc=axboe@kernel.dk \
--cc=bhelgaas@google.com \
--cc=bvanassche@acm.org \
--cc=linux-block@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®