From: "David Hildenbrand (Arm)" <david@kernel.org>
To: Hui Su <sh_def@163.com>, Andrew Morton <akpm@linux-foundation.org>
Cc: Matthew Brost <matthew.brost@intel.com>,
Balbir Singh <balbirs@nvidia.com>, Zi Yan <ziy@nvidia.com>,
Joshua Hahn <joshua.hahnjy@gmail.com>,
Rakie Kim <rakie.kim@sk.com>, Byungchul Park <byungchul@sk.com>,
Gregory Price <gourry@gourry.net>,
Ying Huang <ying.huang@linux.alibaba.com>,
Alistair Popple <apopple@nvidia.com>,
linux-mm@kvack.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH] mm/migrate_device: consolidate compound folio handling
Date: Fri, 11 Sep 2026 20:01:44 +0200 [thread overview]
Message-ID: <664b3576-05a9-4c49-99c6-ba0928b25300@kernel.org> (raw)
In-Reply-To: <20260911061348.2869524-1-sh_def@163.com>
On 9/11/26 08:13, Hui Su wrote:
> Commit dc41e961a269 ("mm/migrate_device: avoid out-of-bounds writes for
> compound folios") added handling for compound folios that do not fit in
> the remaining PFN array.
>
> migrate_device_range() and migrate_device_pfns() duplicate the logic for
> locking device PFNs, encoding compound folios, and handling this boundary
> condition.
>
> A compound folio cannot be represented partially for migration. Warn when
> one does not fit in the remaining PFN array, while retaining the existing
> defensive handling: release any lock and reference acquired for the
> current folio, clear the remaining entries, and stop collecting.
>
> Move the shared collection and encoding logic into a helper so both
> interfaces handle compound folios consistently. Also use memset() for
> the compound-folio tail entries instead of open-coding the clearing loop.
>
> Document that an encountered compound folio must fit entirely in the
> remaining range or PFN array.
>
> Link: https://lore.kernel.org/r/c99ca53a-73ef-4a0c-8738-eba1cc89bea2@kernel.org
> Suggested-by: David Hildenbrand <david@kernel.org>
> Signed-off-by: Hui Su <sh_def@163.com>
> ---
> Tested on x86_64 with KASAN enabled:
>
> - Built mm/migrate_device.o and the kernel successfully.
> - Ran the HMM migrate_anon_huge_zero selftest; the private-device case
> passed.
> - No KASAN report or truncated compound-folio WARN was observed.
>
> mm/migrate_device.c | 90 ++++++++++++++++++++++++---------------------
> 1 file changed, 49 insertions(+), 41 deletions(-)
>
> diff --git a/mm/migrate_device.c b/mm/migrate_device.c
> index 009bfa8b212d..c57eadea6565 100644
> --- a/mm/migrate_device.c
> +++ b/mm/migrate_device.c
> @@ -1392,6 +1392,39 @@ static unsigned long migrate_device_pfn_lock(unsigned long pfn)
> return migrate_pfn(pfn) | MIGRATE_PFN_MIGRATE;
> }
>
> +/*
> + * Collect a device folio into the page-granular PFN array.
> + *
> + * Return the number of entries consumed, or 0 if the folio does not fit in
> + * the remaining array.
> + */
> +static unsigned int migrate_device_collect_folio(unsigned long *src_pfn,
> + unsigned long pfn,
> + unsigned long remaining)
Two tab indent please.
> +{
> + struct folio *folio = page_folio(pfn_to_page(pfn));
> + unsigned int nr;
> +
> + *src_pfn = migrate_device_pfn_lock(pfn);
> + nr = folio_nr_pages(folio);
> +
> + if (WARN_ON_ONCE(nr > remaining)) {
Just to be sure: there is no way we can currently validly trigger this, right?
> + if (*src_pfn & MIGRATE_PFN_MIGRATE) {
> + folio_unlock(folio);
> + folio_put(folio);
> + }
> + memset(src_pfn, 0, remaining * sizeof(*src_pfn));
> + return 0;
> + }
> +
> + if (nr > 1) {
> + *src_pfn |= MIGRATE_PFN_COMPOUND;
> + memset(src_pfn + 1, 0, (nr - 1) * sizeof(*src_pfn));
> + }
> +
> + return nr;
> +}
Looks much cleaner.
--
Cheers,
David
next prev parent reply other threads:[~2026-09-11 18:01 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-11 6:13 Hui Su
2026-09-11 18:01 ` David Hildenbrand (Arm) [this message]
2026-09-12 3:10 ` Hui Su
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=664b3576-05a9-4c49-99c6-ba0928b25300@kernel.org \
--to=david@kernel.org \
--cc=akpm@linux-foundation.org \
--cc=apopple@nvidia.com \
--cc=balbirs@nvidia.com \
--cc=byungchul@sk.com \
--cc=gourry@gourry.net \
--cc=joshua.hahnjy@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=matthew.brost@intel.com \
--cc=rakie.kim@sk.com \
--cc=sh_def@163.com \
--cc=ying.huang@linux.alibaba.com \
--cc=ziy@nvidia.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®